Author Topic: [SOLVED] Phone line admin page is missing in 1004  (Read 2089 times)

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
[SOLVED] Phone line admin page is missing in 1004
« on: December 20, 2011, 12:42:53 am »
I tried to make the move to 1004 today. Things looked like they went smoothly, but when I tried to install my VOIP line, the phone line admin page would not come up. I selected it in the left pane, but the right pane was simply a blank white slate. I remember that there were some telecom problems but I thought they were fixed.

twodogs
« Last Edit: January 15, 2012, 09:10:24 pm by twodogs »
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3008
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Phone line admin page is missing in 1004
« Reply #1 on: December 20, 2011, 06:36:58 am »
Please open a trac ticket, and make sure to select module Asterisk.

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #2 on: December 20, 2011, 03:14:15 pm »
I have the same problem.

Emanuele

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3008
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Phone line admin page is missing in 1004
« Reply #3 on: December 20, 2011, 03:49:27 pm »
Guess what? My answer is the same ;)

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #4 on: December 20, 2011, 06:54:49 pm »
OK, maybe not an asterisk problem. I tried to reinstall and watch things more closely. Looks like there were download errors. If someone could help me out with the --fix missing syntax then I could investigate further.

Code: [Select]
Get:215 http://deb.linuxmce.org/ubuntu/ lucid/beta2 pluto-dcerouter 2.0.0.45.11121925281 [203kB]
Get:216 http://deb.linuxmce.org/ubuntu/ lucid/beta2 video-wizard-videos 1.1 [469MB]
Err http://deb.linuxmce.org/ubuntu/ lucid/beta2 video-wizard-videos 1.1
  Could not connect to deb.linuxmce.org:80 (87.239.186.102). - connect (110: Connection timed out)
Failed to fetch http://deb.linuxmce.org/ubuntu/dists/lucid/beta2/binary-i386/video-wizard-videos_1.1_all.deb  Could not connect to deb.linuxmce.org:80 (87.239.186.102). - connect (110: Connection timed out)
Fetched 590MB in 17min 9s (574kB/s)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
An error (Exit code 100) occured during the last action
Initial media and dcerouter install
root@Higgins:~# 
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

mkbrown69

  • Guru
  • ****
  • Posts: 193
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #5 on: December 20, 2011, 10:07:27 pm »
OK, maybe not an asterisk problem. I tried to reinstall and watch things more closely. Looks like there were download errors. If someone could help me out with the --fix missing syntax then I could investigate further.

sudo apt-get update
sudo apt-get install --fix-missing

That should do it for you!

/Mike

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #6 on: December 21, 2011, 12:34:49 am »
I tried the "fix missing" command and not much happened so I just restarted the LinuxMCE installer. This time everything loaded and the installation completed with the message that no errors had been detected. Sarah started her intro and the wizard ran just fine. When I rebooted and went into admin, the phone line page was still missing as was freepbx. So it looks like a 1004 problem, not a download error. I'll fill out a ticket.

twodogs
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3008
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Phone line admin page is missing in 1004
« Reply #7 on: December 21, 2011, 05:26:25 am »
Thanks for filling out a ticket. As a side note: We no longer use FreePBX, but are using Realtime database access. Foxi did a lot of work in this area to help us utilize what asterisk has to offer out of the box. Whenever you find stuff, that does not seem to work with asterisk, we need to be made aware of it, so foxi can fix it for us.

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #8 on: December 24, 2011, 12:24:43 pm »
My error is different, i try reinstall lmce-asterisk:

Code: [Select]
ERROR 1064 (42000) at line 338: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT '',
  `channels` int(11) NOT NULL DEFAULT '5',
  PRIMARY KEY (`id`)
)' at line 13
adduser: Il gruppo «asterisk» non esiste.
chown: utente non valido: "asterisk.asterisk"
ERROR 1146 (42S02) at line 1: Table 'asterisk.phonelines' doesn't exist
Adding SIP phone device 22 extension 200
Adding SIP phone device 33 extension 201
Executing Configuration Script configure_snom3xx.pl

Emanuele

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3008
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Phone line admin page is missing in 1004
« Reply #9 on: December 24, 2011, 12:42:59 pm »
rages,

remove all asterisk packages, i.e. all packages you get by executing dpkg -l|grep asterisk, and install lmce-asterisk manually, and see if that helps.

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #10 on: December 24, 2011, 02:28:13 pm »
Posde, I try your suggestion but I have the same error of my previuos post.

Emanuele

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #11 on: December 28, 2011, 10:44:06 am »
Hi,

there is a way to realign the tables without having to reinstall everything?

Emanuele

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3008
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Phone line admin page is missing in 1004
« Reply #12 on: December 28, 2011, 10:52:45 am »
If removing asterisk does not help, please open a trac ticket.

btw: Removal should be done using dpkg --purge to remove the conf files as well.

Rino

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #13 on: December 28, 2011, 10:31:06 pm »
Folks,

If your going to eliminate the asterisk web page, perhaps in your wizard you could allow for a 'Other Provider' Button. So those who didn't use these perticular providers could enter there own.  At least with version 8.10 I was able to point that linuxmce-asterisk to my currently running version of FreePBX to which has all the bells and whistle already configured. so i didn't have to redo all that works.

While I'm suggestion things, perhaps a another possible automation tool as well, perhaps have a modules that tries to discover is there is already a asterisk server or other simular pbx on your network so it would, just integrate that one in?

PS: Posted, Don't get mad, These are just suggestions. in hopes to improve, not to critic you or anyone else.

Foxi352

  • Veteran
  • ***
  • Posts: 52
    • View Profile
Re: Phone line admin page is missing in 1004
« Reply #14 on: December 28, 2011, 10:48:23 pm »
My error is different, i try reinstall lmce-asterisk:

Code: [Select]
ERROR 1064 (42000) at line 338: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT '',
  `channels` int(11) NOT NULL DEFAULT '5',
  PRIMARY KEY (`id`)
)' at line 13
adduser: Il gruppo «asterisk» non esiste.
chown: utente non valido: "asterisk.asterisk"
ERROR 1146 (42S02) at line 1: Table 'asterisk.phonelines' doesn't exist
Adding SIP phone device 22 extension 200
Adding SIP phone device 33 extension 201
Executing Configuration Script configure_snom3xx.pl

Emanuele

Should have been fixed earlier today with changeset 25299. Wait for next build to finish and it should work again ...