Author Topic: Gray screen on playback of VC-1 video codec  (Read 3683 times)

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #15 on: November 14, 2011, 01:41:30 am »
Still at it!!!!


Tried the libxine2 posted in this forum... still no affect on playing mkv files with the vc-1 video codec (still a gray screen)

I tried switching the Hardware acceleration to opengl.. the video became a black screen....

tried an earlier version of NVIDIA graphics driver  (280.13)... no change.

Is anyone able to play these VC-1 video files using LMCE 1004 or even 0810?   I'd like to compare settings and version info.

Here is my video information (via lspci):
VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GTX] (rev a2)


Thanks,
Dennis
« Last Edit: November 14, 2011, 01:44:11 am by ardirtbiker »

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #16 on: November 14, 2011, 04:12:07 pm »
I see something similar with my mt2s files from my Canon AVHCD movie camera

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #17 on: November 15, 2011, 06:56:59 pm »
Here is the latest libxine2 from the yavdr stable ppa repository from source only 2 days ago.  Try it out and let us know what happens.

Code: [Select]
https://launchpad.net/~yavdr/+archive/stable-vdr/+files/libxine2_1.2.0~hg20111113.2230-1yavdr0~lucid_i386.deb

J.

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #18 on: November 16, 2011, 02:28:55 am »
phenigma... YOU ARE THE MAN!!!!!


Thanks...   I am able to watch the VC-1 video files just perfectly.


here is what I ended up doing since the libxine2 file complained about dependencies:

added both of these to my sources.list
deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main
deb-src http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main

then ran apt-get -f install... which pulled in the other dependencies and completed the installation of libxine2



again.. thanks so much.

Dennis

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #19 on: November 16, 2011, 04:00:37 am »
Excellent!  Glad to hear it's working!

J.

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #20 on: November 16, 2011, 04:14:54 am »
ooohhh... I may have spoken too soon...   Mythtv is now a black screen..

Further investigation... if VDPAU is set in Mythtv settings, the screen is black... if set to CPU+ or other than VDPAU, then video is visible.. I think it was updated from the above adds to my sources.list file.

Dennis
« Last Edit: November 16, 2011, 04:24:43 am by ardirtbiker »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #21 on: November 16, 2011, 11:18:40 pm »
I don't see any mythtv components in the yavdr repository...  Do you know which additional packages were pulled from the yavdr repo?  I installed the libxine2 package on my system without any additional packages being required (but I muck with mine a lot and have lots of additional packages installed already).

J.

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #22 on: November 17, 2011, 01:48:21 am »
I think it was libvdpau... I re-installed the nvidia driver 285 series and all is well.


the other files that libxine2 needed were libavcodec, libavutil, and libpostproc


Dennis
« Last Edit: November 17, 2011, 02:06:53 am by ardirtbiker »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #23 on: November 17, 2011, 08:52:32 pm »
So, just so I have this correct... after installing the new libxine2 AND re-installing the nvidia 285 driver you have working video for mythtv AND xine from lmce?  All is working fine now?  :)

J.

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #24 on: November 18, 2011, 01:56:41 am »
that is correct... all stored videos work... mythtv works...   All is well!!

Thank you very much...

Dennis

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #25 on: November 24, 2011, 09:08:18 pm »
Glad it is working for you!

J.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #26 on: November 26, 2011, 11:01:04 am »
Hi Gents,

Do you think this will work only in 1004? I seem to have a bunch of other stuff that is too old for libxine2 using 0810:

Code: [Select]
libxine2: Depends: libasound2 (> 1.0.22) but 1.0.18-1ubuntu9~dia1 is to be installed
            Depends: libavcodec52 (>= 4:0.6-1~) but it is not going to be installed or
                     libavcodec-extra-52 (>= 4:0.6-1~) but it is not going to be installed
            Depends: libavutil50 (>= 4:0.6-1~) but it is not going to be installed or
                     libavutil-extra-50 (>= 4:0.6-1~) but it is not going to be installed
            Depends: libc6 (>= 2.8) but 2.8~20080505-0ubuntu9 is to be installed
            Depends: libcdio10 but it is not installable
            Depends: libdvdread4 but it is not installable
            Depends: libfaad2 but it is not installable
            Depends: libiso9660-7 but it is not installable
            Depends: libjack0 (>= 0.118+svn3796) but 0.109.2-3ubuntu1 is to be installed
            Depends: libmagickcore2 (>= 7:6.5.7.8) but it is not installable
            Depends: libmagickwand2 (>= 7:6.5.7.8) but it is not installable
            Depends: libpostproc51 (>= 4:0.6-1~) but 3:0.svn20080206-12ubuntu3.3 is to be installed or
                     libpostproc-extra-51 (>= 4:0.6-1~) but it is not going to be installed
            Depends: libpulse0 (>= 0.9.16) but 0.9.10-2ubuntu9.4 is to be installed
            Depends: libvcdinfo0 (> 0.7.23) but it is not going to be installed

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #27 on: November 26, 2011, 11:29:02 pm »
the particular .deb file is for lucid (10.04).  I didnt see any files on that site for maverick (8.10).

You'd have to gather up all the dependencies and install them as well... and yes I found it tough!


Dennis

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 976
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #28 on: November 29, 2011, 09:51:17 pm »
Hi Gents,

Do you think this will work only in 1004? I seem to have a bunch of other stuff that is too old for libxine2 using 0810:

That package is for 1004 only.  Are you using libxine2 with 0810 already or are you using the stock libxine1 with 0810?

I have backported the package for 0810, havn't had a chance to test it.  When I do I'll post it.

J.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Gray screen on playback of VC-1 video codec
« Reply #29 on: November 30, 2011, 11:33:44 am »
That package is for 1004 only.  Are you using libxine2 with 0810 already or are you using the stock libxine1 with 0810?

I have backported the package for 0810, havn't had a chance to test it.  When I do I'll post it.

J.

Thanks phenigma :)

I have version 1.1.16 on 810 currently...