Author Topic: Small fonts issue after upgrade to latest 8.10 packages  (Read 489 times)

tmwillett

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Small fonts issue after upgrade to latest 8.10 packages
« on: September 17, 2011, 03:06:24 pm »
After doing the apt-get update/upgrade for the latest 8.10 packages, I've lost the settings that set my dpi for my 40" LCD to larger fonts.  When I reboot, the 'Loading LinuxMCE' messages are all extremely small, and my desktop and web browser fonts unreadable. 

The fix for this in the past was to edit /usr/pluto/bin/Start_X_Wrapper.sh and add -dpi 96 to the end of the xinit line.  Unfortunately, if I try that now, X doesn't start up.  The MD will display the start up commands such as stopping and starting Samba daemons, and then it just stays at a command prompt screen displaying messages, but X never starts.  I also tried to add a dpi command to xorg.conf under monitor (dpi  96 x 96), but I get the same results.  Seems X doesn't like the dpi setting anymore.

Any ideas?

Thanks,


davegravy

  • Addicted
  • *
  • Posts: 518
    • View Profile
Re: Small fonts issue after upgrade to latest 8.10 packages
« Reply #1 on: September 17, 2011, 06:44:31 pm »
For some reason my TV's always had an issue with communicating it's parameters to the OS. I had to modify something in xorg.conf to get it working right. Sorry I can't be more specific... It was a long while ago and I didn't make notes.

tmwillett

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Small fonts issue after upgrade to latest 8.10 packages
« Reply #2 on: September 18, 2011, 01:18:51 am »
Thanks, but I've done the changes to the xorg.conf file and they caused the same problem.  Not sure what changed, but X doesn't like the 'old' way of doing this.  Does anyone know what was changed in the latest release to cause this, or have a work around?

Thanks

tmwillett

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Small fonts issue after upgrade to latest 8.10 packages
« Reply #3 on: September 19, 2011, 03:44:22 am »
Found the fix.  Needed to add:

    Option         "UseEdidDpi" "False"
    Option         "DPI" "96 x 96"

to xorg.conf since it's an nVidia card.