Author Topic: lmce-autotagger ?  (Read 2677 times)

jeangot

  • Guru
  • ****
  • Posts: 233
    • View Profile
lmce-autotagger ?
« on: August 17, 2011, 05:19:52 am »
Hello,

I just updated my 0810 installation to the current version (apt-get update; apt-get upgrade), and one of the improvements I was looking for is the autotagger.
According to this page: http://wiki.linuxmce.org/index.php/LinuxMCE-0810_beta
There was a package lmce-autotagger created on May 30th.

However that package did not install during my update, and
apt-get update; apt-get install lmce-autotagger
says that this package doesn't exist.

What am I doing wrong, and if the autotagger does not come in a package, is the only way to install it compiling it from source?

Thank you!

Jean

sambuca

  • Guru
  • ****
  • Posts: 439
    • View Profile
Re: lmce-autotagger ?
« Reply #1 on: August 17, 2011, 07:37:24 am »
From what I understand, there were missing dependencies(or differing API) for the autotagger in 810, as it was originally built for 1004. So it wasn't built for 810, afaik. The beta page is thus likely wrong in this case. It should be possible for someone with the right motivation to fix this though, but none has yet.

best regards,
sambuca

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: lmce-autotagger ?
« Reply #2 on: August 17, 2011, 10:37:34 am »
since its my baby, i should get that fixed. I have updated it to build on 0810 and updated the source tree, i just keep forgetting to ask possy to add it to the build.

-golgoj4
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

jeangot

  • Guru
  • ****
  • Posts: 233
    • View Profile
Re: lmce-autotagger ?
« Reply #3 on: August 17, 2011, 05:15:32 pm »
Thanks for the quick reply. I have corrected the wiki page so that nobody else gets confused, and will wait for the package to be available in 0810.

Jean

donpaul3

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: lmce-autotagger ?
« Reply #4 on: August 18, 2011, 02:52:52 pm »
Would the lmce-autotagger work with Dianemo 10.10? I am using Dianemo which currently doesn't have IMDB tagging or functional Amazon. Would love to use autotagger.

donpaul3

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: lmce-autotagger ?
« Reply #5 on: August 18, 2011, 03:21:04 pm »
Would the lmce-autotagger work with Dianemo 10.10? I am using Dianemo which currently doesn't have IMDB tagging or functional Amazon. Would love to use autotagger.

I will answer my own question - YES, autotagger works on Dianemo 10.10. First try and flawless. Great job! PM me a Paypal address for donation!

donpaul3

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: lmce-autotagger ?
« Reply #6 on: August 18, 2011, 03:52:46 pm »
Is it possible to put the episode number (s03e11) in the title of the shows? It is difficult to look at the list of shows and know which episode is next.

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: lmce-autotagger ?
« Reply #7 on: August 18, 2011, 07:09:46 pm »
I will answer my own question - YES, autotagger works on Dianemo 10.10. First try and flawless. Great job! PM me a Paypal address for donation!

Donation to the LMCE project in general would be nice. :) If you feel so compelled. :)

as far as whats going to be mapped to what, we are still working that out. The idea is to have episode number and title in two separate fields, but i will see what i can do in the mean time.

-golgoj4
also, kinda cool it works on Dianemo too :) never even crossed my mind when I was writing it. Anyways, on to improvements.

-golgoj4
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

donpaul3

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: lmce-autotagger ?
« Reply #8 on: August 18, 2011, 10:22:54 pm »
I creating my own auto-tag script for TV shows that has been working great. Metadata from TV episodes is in an NFO file and I parse that for details. When I tag shows, I put the show name and the episode as the title and it works out perfectly (Dexter - s02e06).

Code: [Select]
#!/bin/bash

for each in public user_2 user_1 user_5
do

cd "/home/$each/data/videos/TV"

find . -mtime -1| egrep -e 'avi|mkv|xvid|ts|m2ts' | grep -v id3 | while read "files"
do
file=`echo "$files" | cut -f2 -d"/"`
name=`echo "$files" | cut -f4 -d"/" | cut -f1 -d"."`
nfo=`echo "$files" | cut -f1-2 -d"."`
title=`cat "$nfo.nfo" | grep title | cut -f2 -d">" | cut -f1 -d"<"`
aired=`cat "$nfo.nfo" | grep aired | cut -f2 -d">" | cut -f1 -d"<"`
rm "$files.id3"
touch "$files.id3"
id3v2 --TIT2 "$name - $title" "$files.id3"
id3v2 --TYER "$aired" "$files.id3"
eyeD3 --add-image="./$file/folder.jpg":OTHER "$files.id3"
done

done

I used your autotagger to tag a new series of shows, and I loved the result. The only problem is that I have no idea in which order to watch the shows!

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: lmce-autotagger ?
« Reply #9 on: September 19, 2011, 12:36:40 pm »
Hey golgoj4,

I know you are flat out with other things - so am hesitant to interrupt, but thought I might ask if you know what might be going on.

I can run this on my movie collection (dcerouter:~/autotagger$ sudo ./linuxmceTag.bin /directory/location )... but if I try on a large amount of media - it keeps hanging due to what seems like corrupt jpegs. E.g.

Code: [Select]
Done! New AttributeID = 28419|| Now for file...Done! New AttributeID = 28420|| Now for file...Done! New AttributeID = 28421|| Now for file...Done! New AttributeID = 28422|| Now for file...Done! New AttributeID = 28423|| Now for file...Getting Pic for file
Code: [Select]
Corrupt JPEG data: premature end of data segment
 QUrl( "http://cf1.imgobject.com/backdrops/4bc/4bc90714017a3c57fe0024bc/miller-s-crossing-original.jpg" )
 QUrl( "http://cf1.imgobject.com/posters/dbc/4bc92c4b017a3c57fe011dbc/bad-santa-original.jpg" )

Is there any way to force the script to continue? The failures seem to be a bit random. An image it failed on in the past - it will breeze through the next time. Files prior to this point get tagged correctly (assuming the name is found in IMDB).

Can anyone else duplicate this on a largish media collection?

Thanks!
WR.

p.s - not sure if it supposed to work but the "Auto Tag" button in media file sync doesn't do anything for me.

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: lmce-autotagger ?
« Reply #10 on: September 20, 2011, 05:54:54 pm »
Hey golgoj4,

I know you are flat out with other things - so am hesitant to interrupt, but thought I might ask if you know what might be going on.

I can run this on my movie collection (dcerouter:~/autotagger$ sudo ./linuxmceTag.bin /directory/location )... but if I try on a large amount of media - it keeps hanging due to what seems like corrupt jpegs. E.g.

Code: [Select]
Done! New AttributeID = 28419|| Now for file...Done! New AttributeID = 28420|| Now for file...Done! New AttributeID = 28421|| Now for file...Done! New AttributeID = 28422|| Now for file...Done! New AttributeID = 28423|| Now for file...Getting Pic for file
Code: [Select]
Corrupt JPEG data: premature end of data segment
 QUrl( "http://cf1.imgobject.com/backdrops/4bc/4bc90714017a3c57fe0024bc/miller-s-crossing-original.jpg" )
 QUrl( "http://cf1.imgobject.com/posters/dbc/4bc92c4b017a3c57fe011dbc/bad-santa-original.jpg" )

Is there any way to force the script to continue? The failures seem to be a bit random. An image it failed on in the past - it will breeze through the next time. Files prior to this point get tagged correctly (assuming the name is found in IMDB).

Can anyone else duplicate this on a largish media collection?

Thanks!
WR.

p.s - not sure if it supposed to work but the "Auto Tag" button in media file sync doesn't do anything for me.

no worries, this is going to be an important component moving on so it needs attention.
 when you see this happen, are you sure the script stops? I thought I just had that as a warning more than a show-stopper. As far as the button from the webadmin not working, ill need to look into that. Not sure why it stopped.

Ill let you know when I have some fixes.
-golgoj4
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: lmce-autotagger ?
« Reply #11 on: September 21, 2011, 12:27:03 am »
Thx golgoj4!

Yeah pretty sure it stops. I did a top and watched it stop after around 3.5 min. Left it for half and hour anway (before ctrl - C) and nothing happened. I'll test again tonight though to make 100% sure.

Cheers,
WR

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: lmce-autotagger ?
« Reply #12 on: September 21, 2011, 12:47:04 pm »
Yep - it hangs for me.... has been @ 5:30 for the last 40min. Stuck at the Getting pic for file output again. Let me know if you need any info / testing.

Thanks!
WR.

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: lmce-autotagger ?
« Reply #13 on: September 30, 2011, 08:52:04 pm »
Yep - it hangs for me.... has been @ 5:30 for the last 40min. Stuck at the Getting pic for file output again. Let me know if you need any info / testing.

Thanks!
WR.

Can you do an apt-get update / apt-get upgrade then let me know if things are still broken?
-thanks golgoj4
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: lmce-autotagger ?
« Reply #14 on: October 02, 2011, 10:36:29 pm »
bump
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius