Author Topic: What would you suggest for stable release (only bugfixes)  (Read 5173 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« on: January 26, 2007, 08:27:00 pm »
Hi,

I'm starting this thread in hope that more users will contribute. Since Pluto is currently in feature freeze (only bugfixes and stability issues) I'd kindly ask more users if you can contribute what you feel is really important to fix before stability release. Please don't add feature requests...


Thanks in advance,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #1 on: January 26, 2007, 08:57:43 pm »
Hi,

I'll start first. I'll edit my post with new suggestions, so please read it all over again...

1. system related :

checking disks should be somehow done occasionally
newbielink:http://plutohome.com/support/mantis/view.php?id=3141 [nonactive]  
I think that also some sort of healthy checks could be added to detect possible errors. In case of error (in upper URL) I got all kinds of strange errors, cause partition was mounted 800 times without being checked and then it was mounted read only and then all kinds of weird errors appeared... Just as an example...

2. Security features :
Described here :
newbielink:http://plutohome.com/support/phpbb2/viewtopic.php?t=1056 [nonactive]


3. Audio related :

newbielink:http://plutohome.com/support/mantis/view.php?id=3162 [nonactive] Pluto doesn't play files with international characters in pathname !!!
newbielink:http://plutohome.com/support/mantis/view.php?id=2818 [nonactive] I think Audio announcements should be worked on a bit. Fading, playing media in background, proper handling of more announcements in short time, etc... This is afterall important user interface...

4. Orbiter related :
newbielink:http://plutohome.com/support/mantis/view.php?id=3154 [nonactive] (probably already in 0.44)
newbielink:http://plutohome.com/support/mantis/view.php?id=3156 [nonactive] (cosmetic)
newbielink:http://plutohome.com/support/mantis/view.php?id=3086 [nonactive]
newbielink:http://plutohome.com/support/mantis/view.php?id=3108 [nonactive]
something mixes two quad scenarios

5. Web-Admin related  :
newbielink:http://plutohome.com/support/mantis/view.php?id=3152 [nonactive] major usability problem


6. Asterisk related  :
Currently Asterisk is quite a mess under Pluto - it's not being maintained properly. I think that it should be devoted some time to compile more cleanly and solve certain problems like :
newbielink:http:// http://plutohome.com/support/mantis/view.php?id=3142 [nonactive] is Asterisk sniffing LAN ?
newbielink:http://plutohome.com/support/mantis/view.php?id=2789 [nonactive] missing kernel modules cause make_package script is broken...
newbielink:http://plutohome.com/support/mantis/view.php?id=2818 [nonactive] Generic phone line - for all users without "embedded" VOIP providers



HTH,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #2 on: January 27, 2007, 10:25:49 am »
Hi all

I follow the example of Rob and I will put here my suggestions about desired bug fixes.

I'll add here in no particular order, just out of the top of my head.

1. Boot
Up to .42 boot process was a matter of maybe less tha a minute, with .43 boot sequence is taking quite a while (not ages, but still a few minutes) to go past the "Startup Networking" step. This happens either in core or in MD, and it's a bit annoying when you have to "wake up" a sleeping MD to watch a movie or listen a song. I guess it may have to do with some recent changes (maybe migration from nfs to cifs), so maybe there's not much improvement margin, but I would anyway consider it as an issue.

2. MythTv
My MythTv stopped working after update from .39 to .40. Before that it was working simply great, after that I've also performed fresh install to get rid of the upgrade problems I've been affected but MythTv never came back to work. Probably this Pluto feature is in a transition stage and cannot be cosidered stable. Nevertheless I believe that it may be considered a key feature in a fully integrated automation system, and I think it deserves some additional care.

3. Computing
The system used to add applications in Computing sections is a bit complicate. I never really understood the template concept, as I'm using always the same one (Firefox-bin) and things are working.
In past releases the application list were displayed in a little messy way (i.e the application path instead of the description), now the situation seems OK but the application list is mixed (messy entries with proper ones). This actually is a minor issue, and may be solved by manually deleting and recreating entries in PlutoAdmin. But here comes the annoying issue.
As a side effect of recent windows manager change when opening PlutoAdmin with Firefox on my hybrid, only main pages ca be accessed while popup windows are sent in foreground and cannot be accessed in any way, not even "ALT+TAB-ing".
This makes impossible to fully use PlutoAdmin (on a hybrid) to perform such administration operations (editing computing pops up a window, and subsequentely another window).


As Rob said, I will edit this post adding more suggestion (if any). I may check the new ones with a **, to facilitate reading

Regards
Marco

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #3 on: January 28, 2007, 07:20:29 pm »
1. IVTV and V4L need updating due to outdated ioctl calls and many improvements interms of stability and increased chipset support.  Mythtv stability is also improved when these two packages are updated.

2. General problem with Xine/pluggin not sure which prevented me from watching DVB programs with the failed to re-init video message.  Can't check if this was fixed in 2.0.0.43 as mythtv no longer supports dvb cards.

3. Asterisk - problem with initialising zap drivers causes asterisk to fail on startup requiring manual intervention to get it up and running.

4. Appologies this is a feature request, but comes due to painful re-installs after failed upgrades.  It would be good to have an option in the web admin panel to backup/import the media database as setting up cover art etc for my movie collection takes ages when doing a fresh install.

Apart from the above I think 2.0.0.41 was a great release, a few bugs crept in with 2.0.0.42 which were overcome with a little work.  Looking forward to 2.0.0.44 so I can get my system back to a usable state.

NOS

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #4 on: January 29, 2007, 09:42:03 am »
Hi

1) Mythbackend should only be loaded where needed (where the PVR card is), it should not load on an MD without PVR card.
2) Mythbackend can't be configured if run on a core, you need manual config to allow it to display to an orbiter.
3) Problems for synchronization between media files containing ' characters -> SQL single quote problem.
4) Problems when trying to "delete from database" a mediafile. It seems the script deletes far too much in the DB (but this is recovered by the update script) and regularly ends in error.
5) On the orbiter the mouse keeps on being displayed even though the only control device being used is the remote control -> Plasma burn in + visual annoyance.
6) Even using XV or opengl (with a NVIDIA 6100 video card) as the acceleration method there is still a tearing (much less than with .42) of pictures when playing media
7) Lots of compression artefacts when playing movies with xine (The same content played on VLC windows renders near perfectly).

Thank you for this great software.

Christian

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #5 on: January 29, 2007, 10:35:28 am »
Hi,

Somewhere between a bugfix and a feature request...

I have asked for it in another thread but anyway, an update to lcdproc 0.5.1 to be able to use IMON devices

Thanks for great software.

Mikael

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
What would you suggest for stable release (only bugfixes)
« Reply #6 on: January 29, 2007, 03:55:39 pm »
1. PVR. I'm also interested to see a stable PVR - ether VDR or MythTV. Because now MythTV doesn't work properly with DVB card.
2. nVidia drivers. It'd be create to have latest nVidia drivers because they allow to use all features of nVidia video adapters i.e. decode HDTV without getting 100% of processor time.
3. I like the UI2 but it have a lot of bugs: cannot switch between floorplans, not usability functionality to play/stop video/audio, covers for each MP3 are not needed or should be the same for all album (I agree with Rob).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Upgrade the installer to r1
« Reply #7 on: January 30, 2007, 10:55:51 pm »
This may not be a 'bug fix' but it seriously limits hardware compatibility...

Upgrade the kernel to 2.6.18 / the Debian installer from r0 to r1. I posted some stuff about this in the SATA 'sticky' at the top of this forum. Upgrading the installer to r1 would add alot more hardware support, and get rid of the SATA problem.