Author Topic: [SOLVED] MythTv FAILED: xmltv returned error code 256  (Read 4252 times)

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
[SOLVED] MythTv FAILED: xmltv returned error code 256
« on: July 19, 2011, 01:17:57 pm »
i am using  tv_grab_nl_py-r104 as my grabber,
whenever i run mythfilldatabase, mythweb backend status shows:
Code: [Select]
Last mythfilldatabase run started on 2011-07-19 06:54 and ended on 2011-07-19 07:03. FAILED: xmltv returned error code 256.
There's guide data until 2011-07-25 09:55 (6 days).
any thoughts on how to solve this?

br,
Raymond
« Last Edit: July 25, 2011, 01:56:39 pm by RayBe »
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1381
  • If it ain't broke, tweak it
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #1 on: July 19, 2011, 02:13:30 pm »
Permissions problem?

Apparently running...

Code: [Select]
mythfilldatabase --graboptions "--debug"
...might give you more info, BUT I HAVE NO IDEA WHETHER THIS IS SAFE OR NOT!

Why do you not use EIT if you don't mind me asking?

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #2 on: July 19, 2011, 02:49:07 pm »
Hi Matt,
thanks for the reply,

Quote
Why do you not use EIT if you don't mind me asking?
i am using a analog tuner (EIT seems for dvb only), the dvb-c provider in my area requires a CI+ decoder (sadly :() and to my knowledge there is no way to use that in MythTv with a pci-(e)-dvb-tuner.

Code: [Select]
mythfilldatabase --graboptions "--debug"since you don't know if its safe to run
i will wait till someone knows its safe ;) (and investigate further myself ;))

Quote
Permissions problem?
do you know how to check and how to change it? in some other forum i found similar but no solution.

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1381
  • If it ain't broke, tweak it
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #3 on: July 19, 2011, 02:59:45 pm »
Sorry, I just meant run "sudo mythfilldatabase".

Sounds like you've had this working before - have you just done a new install or something?

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

Bazza

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #4 on: July 20, 2011, 12:42:12 am »
Hi RayBe

Dont know if this is any help or not but when mythfilldatabase has thrown up errors for me ive checked /var/log/mythtv/mythbackend.log which usually tells me where the problem is, as Purps said it usually turned out to be a permissions problem, so I change permissions and it runs fine afterwards

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #5 on: July 20, 2011, 02:13:12 pm »
Hi Bazza,

My /var/log/mythtv/mythfilldatabase.log shows at the end:

Code: [Select]
2011-07-20 08:20:11.303 New DB connection, total: 3
2011-07-20 08:20:11.319 Connected to database 'mythconverg' at host: localhost
2011-07-20 08:20:11.321 XMLTV config file is: /root/.mythtv/LMCE-Default.xmltv
2011-07-20 08:20:11.321 New DB connection, total: 4
2011-07-20 08:20:11.322 Connected to database 'mythconverg' at host: localhost
Cannot remove /root/.xmltv/program_cache, check permissionsTraceback (most recent call last):
  File "/usr/bin/tv_grab_nl_py", line 1416, in <module>
    main()
  File "/usr/bin/tv_grab_nl_py", line 1397, in main
    program_cache.dump(program_cache_file)
  File "/usr/bin/tv_grab_nl_py", line 299, in dump
    pickle.dump(self.pdict, open(filename+'.tmp', 'w'))
IOError: [Errno 13] Permission denied: '/root/.xmltv/program_cache.tmp'
2011-07-20 08:28:41.136 FillData, Error: xmltv returned error code 256
2011-07-20 08:28:41.152 Error in 625:1: unexpected end of file
2011-07-20 08:28:41.178 IconData: Updating icons for sourceid: 1
2011-07-20 08:28:41.179 New DB connection, total: 5
2011-07-20 08:28:41.180 Connected to database 'mythconverg' at host: localhost
2011-07-20 08:28:41.183 No programs found in data.
2011-07-20 08:28:41.259 Failed to fetch some program info
2011-07-20 08:28:41.259 Adjusting program database end times.
2011-07-20 08:28:41.534     0 replacements made
2011-07-20 08:28:41.534 Marking generic episodes.
2011-07-20 08:28:41.672     Found 0
2011-07-20 08:28:41.673 Fudging non-unique programids with multiple parts.
2011-07-20 08:28:41.775     Found 0
2011-07-20 08:28:41.775 Marking repeats.
2011-07-20 08:28:41.934     Found 0
2011-07-20 08:28:41.934 Unmarking new episode rebroadcast repeats.
2011-07-20 08:28:41.935     Found 0
2011-07-20 08:28:42.378 Marking episode first showings.
2011-07-20 08:28:59.716     Found 5467
2011-07-20 08:28:59.717 Marking episode last showings.
2011-07-20 08:29:12.007     Found 5467
2011-07-20 08:29:12.011
===============================================================
| Attempting to contact the master backend for rescheduling.  |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted.                            |
===============================================================
2011-07-20 08:29:12.028 MythContext: Connecting to backend server: 192.168.80.1:6543 (try 1 of 1)
2011-07-20 08:29:12.033 Using protocol version 56
2011-07-20 08:29:12.060 Received a remote 'Clear Cache' request
2011-07-20 08:29:13.065 mythfilldatabase run complete.
2011-07-20 08:29:13.066 DataDirect: Deleting temporary files

Somewhere it says "IOError: [Errno 13] Permission denied: '/root/.xmltv/program_cache.tmp'" but i don't know how to fix that,
any help would be much appreciated,

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #6 on: July 20, 2011, 04:06:52 pm »
did you run the mythfilldatabase script as super user as purps suggested?

It looks as if the script was once run under sudo and as a result the cache folder is owned by root.

-Coley.

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #7 on: July 20, 2011, 05:13:38 pm »
Coley, hi,

Yes iirc i did run mythfilldatabase under sudo,
if i understand correctly i have to change te permissions on the cache folder, how do i do that?

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1381
  • If it ain't broke, tweak it
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #8 on: July 20, 2011, 05:22:17 pm »
If it were me I would do a...

Code: [Select]
sudo chmod 777 /root/.xmltv
...but again *covers arse* I accept no responsibility for blah blah blah :)
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

Bazza

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #9 on: July 20, 2011, 06:21:01 pm »
Hi RayBe

I changed the permissions of just the file which gave me the error and mythfilldatabase has been updating every night for the past few months without any more errors.

sudo chmod 777 /root/.xmltv/program_cache.tmp

Bazza

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #10 on: July 20, 2011, 10:33:37 pm »
Hi Bazza,
I did try to give
Code: [Select]
sudo chmod 777 /root/.xmltv/program_cache.tmpit complains it can't get acces to `/root/.xmltv/program_cache.tmp': file or folder does not exists
so i tried
Code: [Select]
sudo chmod 777 /root/.xmltv/program_cachewich seems to work but when i open dolphin and goto the file it still says owner root and is the only one with read and right access.

br,
Raymond

When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

Bazza

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #11 on: July 21, 2011, 06:22:27 pm »
Hi RayBe

I've looked back through my logs and the error I got was.

Failed to write to /root/.xmltv/cache/1fb4ec9170c25a9b69bb9bd7efee0b90.tmp30530

So what I did was,

sudo chmod a+rwx /root/.xmltv/cache
sudo chmod a+rwx /root/.xmltv/cache/*

What folders do you have in /root/,xmltv/

Baz

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #12 on: July 21, 2011, 10:06:02 pm »
Hi Bazza,
Thanks for helping me,

When i do ls in /root/.xmltv/ i see:
Code: [Select]
program_cache supplement
program_cache doesn't seem te be a folder,
supplement is a folder

EDIT: could it be that its something about program_cache does NOT have a .tmp at the end?
can/should i add that?

br,
Raymond
« Last Edit: July 22, 2011, 02:17:31 am by RayBe »
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

RayBe

  • Guru
  • ****
  • Posts: 272
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #13 on: July 25, 2011, 01:56:04 pm »
Code: [Select]
chmod -R 777 /root/.xmltvDid the trick, thanks all for helping,

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1381
  • If it ain't broke, tweak it
    • View Profile
Re: MythTv FAILED: xmltv returned error code 256
« Reply #14 on: July 25, 2011, 02:50:18 pm »
Code: [Select]
chmod -R 777 /root/.xmltvDid the trick, thanks all for helping,

br,
Raymond

I thought that applying the chmod to the whole folder would be best, but completely forgot about the need for the "-R", sorry about that.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps