Author Topic: New Onkyo device  (Read 3812 times)

WhateverFits

  • Guru
  • ****
  • Posts: 227
    • View Profile
    • Sean Walker
Re: New Onkyo device
« Reply #15 on: January 25, 2012, 06:18:43 pm »
Thanks Posde! Now I need to go find out the MAC ranges for these Onkyo devices. Google is my friend.

OK, now to add more work for this upcoming weekend. How do I get my orbiters to control it? I want the volume control to control the volume on the receiver and I can't create a media scenario because my Onkyo shows up in red when I attempt to add one. It also doesn't show up on the wizard when I'm trying to add it to my living room. I'm obviously missing something in the configuration but, for the life of me, I can't find it. :( I did manage to "resend codes" to it and get it do do various things.

iberium

  • Veteran
  • ***
  • Posts: 84
    • View Profile
    • Innovative Sight & Sound
Re: New Onkyo device
« Reply #16 on: July 16, 2012, 12:47:10 am »
Was the command that you said the correct one for power on:

ISCP\x00\x00\x00\x10\x00\x00\x0\x01\x00\x00\x00!1PWR01\x0D\r

I've been trying to work on a driver.  I actually was able to create a new driver by just adding the serial one, going into the a/v properties of it, and the viewing the template and renaming it.  It then was an exact copy with a new name.  I'm just wondering if this was the ruby command that you sent.

thanks

WhateverFits

  • Guru
  • ****
  • Posts: 227
    • View Profile
    • Sean Walker
Re: New Onkyo device
« Reply #17 on: July 16, 2012, 10:19:26 pm »
Was the command that you said the correct one for power on:

ISCP\x00\x00\x00\x10\x00\x00\x0\x01\x00\x00\x00!1PWR01\x0D\r

I've been trying to work on a driver.  I actually was able to create a new driver by just adding the serial one, going into the a/v properties of it, and the viewing the template and renaming it.  It then was an exact copy with a new name.  I'm just wondering if this was the ruby command that you sent.

thanks

The driver I created has been checked in and it should be available. Thom confirmed a few days ago that it was committed and it should be available for public consumption soon if not already. Given that, it looks right.

WhateverFits

  • Guru
  • ****
  • Posts: 227
    • View Profile
    • Sean Walker
Re: New Onkyo device
« Reply #18 on: March 08, 2013, 09:34:50 pm »
I checked in my changes again for the auto-detect. My system burned down and I had to make these changes again and re-commit them. I'm still getting errors when I commit so if someone can take a look at that (Bug #1527) and get my changes committed, I would be very happy.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5476
  • DOES work for LinuxMCE.
    • View Profile
Re: New Onkyo device
« Reply #19 on: March 08, 2013, 09:46:02 pm »
I'll look @ it tonight.

-Thom