Author Topic: 1004 dependency problems  (Read 1087 times)

WhateverFits

  • Guru
  • ****
  • Posts: 228
    • View Profile
    • Sean Walker
1004 dependency problems
« on: July 18, 2011, 06:57:55 pm »
Hello!

I'm testing out 1004 (on a clean install) and found a couple dependency problems. So far php-pear was not installed, which broke the weborbiter and, just recently, I upgraded and pluto-proxy-orbiter (2.0.0.45.11071624219) now depends upon an older version of bluez-utils because the newest version doesn't provide /etc/bluetooth/hcid.conf nor /etc/init.d/bluez-utils. It looks like bluez now includes /etc/init.d/bluetooth and I have yet to find what provides /etc/bluetooth/hcid.conf or it's replacement. I'll keep digging and see what else I can find. If anyone already knows the fix (or it has been fixed) let me know.

I'm guessing the php-pear dependency just needs tacked onto the requirements for pluto-website-admin.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2997
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 1004 dependency problems
« Reply #1 on: July 19, 2011, 12:28:28 am »
Please open trac tickets for each of the problems you experience, and assign them to 1004.

Thanks.

Foxi352

  • Veteran
  • ***
  • Posts: 52
    • View Profile
Re: 1004 dependency problems
« Reply #2 on: July 19, 2011, 11:58:13 am »
WhateverFits: Thank you for reporting this. I can confirm the bluez-utils part and i opened ticket #1144 for this.
As a temporary fix postinst of proxy-orbiter first tests if bluez-utils exists. If not it ignores the bluetooth part.

We will investigate bluetooth package changes and come up with a definitive fix.

Meanwhile, after next package build, proxy-orbiter should install again ...

Foxi352

  • Veteran
  • ***
  • Posts: 52
    • View Profile

WhateverFits

  • Guru
  • ****
  • Posts: 228
    • View Profile
    • Sean Walker
Re: 1004 dependency problems
« Reply #4 on: July 19, 2011, 05:39:05 pm »
Sounds great! I really want to get involved more in the development but time is short. I'll do what I can.

Foxi352

  • Veteran
  • ***
  • Posts: 52
    • View Profile
Re: 1004 dependency problems
« Reply #5 on: July 19, 2011, 09:15:13 pm »
You know, posting bugs like this is already a great help. A greater help would be opening a ticket for it in http://svn.linuxmce.org :-)

Cheers,

Serge

WhateverFits

  • Guru
  • ****
  • Posts: 228
    • View Profile
    • Sean Walker
Re: 1004 dependency problems
« Reply #6 on: July 26, 2011, 07:37:18 am »
Yup. Did it. Opened one bug.  ;D I'll keep testing and doing what I can.