Author Topic: {extif} for second interface  (Read 1034 times)

brononius

  • Guru
  • ****
  • Posts: 376
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
{extif} for second interface
« on: June 26, 2011, 04:43:19 pm »
Hey,

I'm having troubles with my 2 network cards. These are 2 build in ones on a Dell poweredge server.

  • In the config, the first one (WAN) is tagged as {extif}, and doesn't get a IP from my provider. The second one (LAN) is seen correctly (fixed ip on eth0).
    So this isn't working.
  • When i now swap the cables and chooes 'swap interfaces', my new WAN-port is tagged as eth0 and gets a proper IP from the provider.
    The second one is now tagged as {extif} with a fix ip.

So it's working in situation 2, but i suppose that something isn't 100% correct here.
Any thoughts on it?
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

brononius

  • Guru
  • ****
  • Posts: 376
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: {extif} for second interface
« Reply #1 on: June 26, 2011, 05:30:45 pm »
Not working like it should be.
I don't get any dhcp offers on the LAN with this configuration.

When i swap them back again, the LAN is working 100% correctly, but the WAN isn't recieving an IP from the provider.
So i think that this {extif} must be resolved before i can continue...



ps the installation was done as http://wiki.linuxmce.org/index.php/Installing_1004.
This went great. With the ISO the system stops constantly with rendering and so... :$
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: {extif} for second interface
« Reply #2 on: July 01, 2011, 05:04:39 am »
Something did not go correctly during setup and detection never finished in postinstall.sh. This should not happen... and may indicate other problems... but to fix this problem, edit /etc/network/interfaces to read as such:
Code: [Select]
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
auto eth1
iface eth1 inet static
        address 192.168.80.1
        netmask 255.255.255.0

Where eth0 is the external network and eth1 is the internal network.
I never quit... I just ping out.

brononius

  • Guru
  • ****
  • Posts: 376
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: {extif} for second interface
« Reply #3 on: July 01, 2011, 05:48:16 pm »
hmmm, strange...

I did this, and then 'sudo /etc/init.d/networking restart'.
And everything seems in order. I nicely get an IP from my provider, the LAN is working...

Before i do anything else, i want to be sure that all settings are known everywhere.
So i rebooted the server.
But when i look nows, the /etc/network/interfaces is overwritten with the old stuff? The {extif} is back in place?


any idea how this come?

Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: {extif} for second interface
« Reply #4 on: July 01, 2011, 07:34:17 pm »
I can't say for sure, but I believe that postinstall sets up a script in init.d which attempts to finish up assignment. I would grep the whole dir for extif and see if something exists and needs to be altered/disabled... but as I said... this may just be the tip of the iceberg. If it were mine, I would attempt a fresh install.
I never quit... I just ping out.

brononius

  • Guru
  • ****
  • Posts: 376
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: {extif} for second interface
« Reply #5 on: July 04, 2011, 08:44:42 am »
Okay, you're absolete right.

...If you don't have the time to do it good, when will you have the time to do it over...


This weekend a fresh installation, but it fails, again...
Damend, why is it so hard to install this linuxmce stuff... A simple apt-get install would be fantastic...  :(
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2958
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: {extif} for second interface
« Reply #6 on: July 04, 2011, 09:00:51 am »
brononi,

absolutely right. We appreciate any patches/scripts that will create corresponding debs.

Thanks in advance.