Author Topic: Xine with live tv  (Read 2146 times)

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Xine with live tv
« on: May 09, 2011, 06:47:56 pm »
I have a pvr-150 hooked up composite to a roku box running 0810 linuxmce. When I attempt to start the live tv entry for the roku box xine just hangs.

Xine_Player::CMD_Play_Media() called for id 1009 filename: fifo:///dev/video0 () with corresponding stream 0x8417dd0. <0xb651eb90>
05   05/08/11 17:02:21.545      Opening media without chapters/title position: 'fifo:///dev/video0'  <0xb651eb90>
05   05/08/11 17:02:22.757      Playback (Buffering...) is at 0 <0xb14f3b90>
05   05/08/11 17:02:22.757      Playback (Buffering...) is at 4 <0xb14f3b90>
Return code: 143
3   05/08/11 17:05:23   46 (spawning-device)   Device died... count=1/50 dev=46

When i drop to the kde desktop xine also hangs I tried all sorts of command line variations without any luck. Strange thing is mplayer player back the live caputure just fine using mplayer /dev/video and after setting


v4l2-ctl -v width=640,height=480 --device=/dev/video0 --set-input=2. Any idea's how to change live tv to use mplayer or what might be going on with xine? Dvd playback work fine under xine so I know it is not totally broken.

edit: apparently it is a vdpau issue if i launch xine as xine -V xv fifo:/dev/video0 it works fine.
« Last Edit: May 10, 2011, 12:14:14 am by drksun »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: Xine with live tv
« Reply #1 on: May 10, 2011, 12:18:14 am »
If you need to, go into the web admin, Wizard > Media directors, find your media director, and change the video accelleration drop down to xv.

-Thom

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #2 on: May 10, 2011, 12:23:57 am »
yeah  but then I lose vdpau for mythtv :-( I have a hdpvr so I need vdpau to run the mythtv recording on the md as it is a slow old amd. I know i can manually override the vdapu setting in mythtv but trying to do things the lmce way.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #3 on: May 10, 2011, 12:41:53 am »
Thank you thom. I set xv in the media director and the roku box is working great from lmce. I also still have vdpau in mythtv (not sure why I suspected that setting xv in the media director screen was going to change this). Anyway thank you.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #4 on: May 10, 2011, 12:48:19 am »
Another observation mythtv video files from the hdpvr 1212 now play with xv set on the media director in linuxmce. ( I can not acutally watch them due to the lack of vdpau support) but they do play. Strange thing is dvd playback works with vdpau looks like it is just mpeg playback that is broken with xine and vdpau at least on my system.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 962
    • View Profile
Re: Xine with live tv
« Reply #5 on: May 10, 2011, 08:28:07 pm »
Something else you could try is updating libxine to libxine2: http://forum.linuxmce.org/index.php?topic=11497.0

If you post a small sample of the video that is not working, to the web somewhere, I would be happy to test that video playback here and let you know if it works or not.

J.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #6 on: May 10, 2011, 10:42:34 pm »
Yeah I have tried the libxine2 from that thread with no dice. When I get off work ill post a test clip from the hdpvr and pvr-150.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #7 on: May 11, 2011, 12:33:44 am »
Here is the link to the pvr-150 mpg and the hdpvr. The pvr-150 playes fine with xine -V xv fifo://. I have attached logs for the file's run with xine -V vdpau fifo://.

http://znfmt.com/download/pvr150.mpg

http://znfmt.com/download/hdpvr.mpg

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 962
    • View Profile
Re: Xine with live tv
« Reply #8 on: May 11, 2011, 08:03:32 pm »
The PVR-150 file plays flawlessy with vdpau for me in 0810 (with the updated xine_player, libxine2 & nvidia driver from the thread above) and it plays flawlessly in 1004 here.

The hd-pvr file has some video corruption for the first 10-12 seconds but plays perfectly from that point forward for me in 0810 (with updates) and it plays equally as well in 1004 here.

J.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #9 on: May 11, 2011, 08:11:04 pm »
Humm, ok thank you for testing. Ill reload the updated xine_player, libxine2 and nvidia driver and give it another whirl.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #10 on: May 11, 2011, 08:37:13 pm »
Strange I reloaded the xinelib2, pluto xine player, and nvidia drivers and still does not play.  I only tested the pvr-150.mpg so far. Could it be a incompatibility with my vid card? I'm running a Asus EN210 silent geforce 210 512 ddr2. From what I can tell on the vdpau wiki this card should support vdpau feature set C. I can post new logs when i get off work today if that helps.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 962
    • View Profile
Re: Xine with live tv
« Reply #11 on: May 11, 2011, 10:09:45 pm »
Your card sounds like it is similar to my Palit GT210 512MB Fanless.

Are you trying from lmce or from the command line?
Does video play at all or does the player die before showing any video?
How do you have your audio connected?

Launching xine at the command line will still use the old libxine1 (1.1.16) but if you use the media functions of lmce it will use libxine2 (1.2).

J.

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #12 on: May 11, 2011, 10:26:20 pm »
I was testing from command line. Ill reset my vdpau in lmce and give it another whirl from lmce. I do have stereo sound connected. When launching from command line with xine -V vdpau fifo:/ it does  open the xine player but just sits there with a black screen and the last entry in the verbose log is

xine: found demuxer plugin: MPEG program stream demux plugin

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #13 on: May 11, 2011, 11:56:17 pm »
Ok, I reset the media director back to vdpau, rebooted and gave it another whirl inside lmce. Still just a black screen.

05/11/11 15:52:51.862      Xine_Player::CMD_Play_Media() called for id 1004 filename: fifo:///dev/video0 () <0xb6624b90>
05   05/11/11 15:52:51.863      Xine_Player::CMD_Play_Media() stopping PSS <0xb6624b90>
05   05/11/11 15:52:51.863      Xine_Stream_Factory::GetStream streamID is 0 <0xb6624b90>
05   05/11/11 15:52:53.404      Created new stream with ID=1004 deint 0  100 0 <0xb6624b90>
05   05/11/11 15:52:53.404      Xine_Player::CMD_Play_Media() set stream 1004 as last rendering to screen. <0xb6624b90>
05   05/11/11 15:52:53.404      Xine_Player::CMD_Play_Media() called for id 1004 filename: fifo:///dev/video0 () with corresponding stream 0x96fc6f0. <0xb6624b90>
05   05/11/11 15:52:53.405      Opening media without chapters/title position: 'fifo:///dev/video0'  <0xb6624b90>
05   05/11/11 15:52:55.120      Playback (Buffering...) is at 0 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 4 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 5 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 6 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 7 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 9 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 10 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 11 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 12 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 13 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 16 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 19 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 20 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 21 <0xb1bbab90>
05   05/11/11 15:52:55.123      Playback (Buffering...) is at 22 <0xb1bbab90>
 

drksun

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Xine with live tv
« Reply #14 on: May 12, 2011, 12:44:28 am »
I upgraded nvdia drivers to the latest posted on nvidia's website 270.41.06 and now I can manually run the video files from the command line with xine -V vdpau fifo://. this works for both the pvr-150 and hdpvr files. Still a black screen in lmce with vdpau support on tho. There is no audio on the hdpvr file but i understand this to be a problem with the transport stream the hdpvr uses.