Author Topic: duwi dimmer switch  (Read 3849 times)

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
duwi dimmer switch
« on: March 25, 2011, 01:29:09 pm »
hi,

I am trying to install a duwi dimmer switch found here :

http://www.uk-automation.co.uk/products/Z%252dWave-Dimmer-Switch-by-Duwi.html

I have followed the installation instructions here

http://wiki.linuxmce.org/index.php/ZWave

-I have added a child device
-template dimmer switch

I retrieved node ID from Wizard>devices>lights page under Port/Channel. THis number was 1

I have tried leaving the node as 1 with no output change

I have then tried following the instructions for adding a right hand paddle dimmer. addingin 1/2 into Port/Channel number. with No output.

My logs under /var/log/pluto/36_ZWave are:

removing job after three tries <0xb723ab90>
05   03/25/11 12:06:21.489      Error: ZW_SEND failed, removing job after three tries <0xb723ab90>
05   03/25/11 12:06:26.878      Error: ZW_SEND failed, removing job after three tries <0xb723ab90>
05   03/25/11 12:06:32.594      Error: ZW_SEND failed, removing job after three tries <0xb723ab90>
05   03/25/11 12:06:38.569      Error: ZW_SEND failed, removing job after three tries <0xb723ab90>
05   03/25/11 12:10:28.812      No callback received: await_callback: 42 timer: 31 <0xb723ab90>
05   03/25/11 12:11:08.472      No callback received: await_callback: 46 timer: 31 <0xb723ab90>
05   03/25/11 12:13:31.832      No callback received: await_callback: 57 timer: 31 <0xb723ab90>

My logs under /var/log/pluto/44_ZWave are:

No device found for id 2 <0xb70c8b90>
05   03/25/11 10:44:20.630      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:44:50.903      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:45:34.235      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:45:46.047      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:46:16.299      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:46:49.298      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:47:07.727      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>
05   03/25/11 10:47:37.998      ZWave::InternalIDToDevice() No device found for id 2 <0xb70c8b90>

I also have a homepro wall switch plug that works fine so I know the Aeon USB is working ok.

I have managed to get green light when associating switch with usb stick so that is ok

Does anyone have any idea in what my problem might be.

Thanks
Dan


 
« Last Edit: March 25, 2011, 01:31:32 pm by magner »

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: duwi dimmer switch
« Reply #1 on: March 26, 2011, 12:59:00 am »
I did introduce a regression when adding another specific z-wave type of dimmers. Please update to the latest z-wave revision/package.

br Hari
rock your home - http://www.agocontrol.com home automation

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3671
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: duwi dimmer switch
« Reply #2 on: March 26, 2011, 12:33:46 pm »
The 810 package has not been updated yet. We have had some hdd problems on the builder. It should be ready by 4pm GMT

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: duwi dimmer switch
« Reply #3 on: March 26, 2011, 02:03:57 pm »
Sorry when you mean update to the latest revision...

Do you mean do an apt-get update?

Cheers
Dan

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3671
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: duwi dimmer switch
« Reply #4 on: March 26, 2011, 02:57:15 pm »
magner,

yes
Code: [Select]
apt-get update
apt-get upgrade

will bring you the latest packages. But the Z-Wave update has not hit the repo yet. fluffy is still busy building it.

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: duwi dimmer switch
« Reply #5 on: March 26, 2011, 07:57:05 pm »
Thanks for the low down.

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: duwi dimmer switch
« Reply #6 on: March 28, 2011, 10:40:25 pm »
Hi,

I have just tried to update. Now when I start up AV wizard and plug in my Aeon USB dongle, I get a message

"Error getting data: ZWave interface not responding"

I proceeded to reformat and do a fresh install with the same problem occuring. When I look for logs under Var/log/pluto there are no logs for zwave.

any ideas?

Cheers
Dan

 

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: duwi dimmer switch
« Reply #7 on: March 28, 2011, 11:27:44 pm »
ignore the wizard and do a quick reload. After that make sure that the devices show up in the device tree in the web admin.
rock your home - http://www.agocontrol.com home automation

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: duwi dimmer switch
« Reply #8 on: March 30, 2011, 11:35:00 pm »
Hi,

Under
Advanced>config>device>core there is a zwave tab in the left hand side list

under this...

ZWave embedded climate interface
ZWave embedded security interface

Pluto does not seem to automatically recognise my associated wall plug switch which it usually does and includes in this list.

So I proceeded to add child device, I have tried wall outlet and on/off switch. Then done reload router. No response from testing.

Any help would be appreciated.

Cheers
DAn 


hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: duwi dimmer switch
« Reply #9 on: April 03, 2011, 08:37:42 pm »
please use the latest z-wave binary, this is already fixed.
br Hari
rock your home - http://www.agocontrol.com home automation

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: duwi dimmer switch
« Reply #10 on: April 05, 2011, 08:47:11 am »
Thank you.

works a treat.

cheers