Author Topic: [Solved] Failed to Setup X  (Read 2734 times)


  • Making baby steps
  • Posts: 2
    • View Profile
[Solved] Failed to Setup X
« on: March 14, 2011, 07:45:09 pm »
Im new here and to LinuxMCE. From all i have read and watched i love it. MCE is exactly the program/system i have been looking for.
I would firstly like to thank the users of this Forum for such detailed and helpful instructions and answers and i hope someone can find the time to try and help me in this way.
I would secondly like to thank tschak909 for his Video walkthroughs. These have really help me in underatinding MCE and its abilities.
Please bear in mind i have only recently started playing with linux.

I have a problem while trying to install a Core/Hybrid which for the moment will be the only machine in my system.
I downloaded a snapshot a few weeks ago and installed. all worked fine and i got to Sarah and then into the MCE. all good. I didnt know what i was doing and nothing worked, no media, no flicker images. so i reinstalled a different version and i have now installed so many different versions i have lost count. I even went to 1004 for a time but asterisk didnt work and thats fundamental to what i need. If i am honest i have no idea now which versions did work.
Every time i had a go i read a bit more on the forums and wiki and learnt a bit more and realised i should be installing the latest snapshot.

Therefore i downloaded 23759. Failed to Start X
then 23796. Failed to Start X and all the way through to the newest one which i tried yesturday.
All fail.

My machine is old but should be good enough. it has two ethernet cards although one is a usb one at present. I will change that tonight.
Grahics card is an ATI one which is all i had but i have been trying to get my hands on a nvidia card so i will try that when i can.

I download the dvd snapshot and boot from DVD.
Click english and then install LinuxMCE
Clean install full HD partition
Installation works well and i boot into Kubuntu
I go to terminal and type sudo su -
enter password and run apt-get update
this fails on some but i am assured from recent forum posts that this is fine.
run apt-get dist-upgrade
run apt-get update
run apt-get upgrade

When rebooted i run the LinuxMCE installer from the desktop having checked that the snapshot i am using doesnt have the problem with the _ missing.
MCE installs fine. it takes quite a while and doesnt seem to throw up any errors.
I reboot and Failed to Start X

if i press alt F4 and type startx that fails if i try and run from the command it cannot find the file even though it appeard if i dir that directory.

Does anyone have any ideas.

Thanks in advance and for taking the time to read and help me.
« Last Edit: March 15, 2011, 05:06:21 pm by ben.hornshaw »


  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Failed to Setup X
« Reply #1 on: March 14, 2011, 08:01:46 pm »

Do you have Internet access when you are in Kubuntu, before the
What does  ifconfig  show?

Thanks Josh
My Setup: On it's way


  • Veteran
  • ***
  • Posts: 79
    • View Profile
Re: Failed to Setup X
« Reply #2 on: March 14, 2011, 08:18:14 pm »
Your issue here is the ATI graphics card. I had the same issue installing on an old test computer that had an ATI card.  You *might* be able to get it working with some tweaking, but for out of the box support grab an Nvidia. The reason is the Linux drivers for the Nvidia hardware are so much better. Good luck.


  • Making baby steps
  • Posts: 2
    • View Profile
Re: Failed to Setup X
« Reply #3 on: March 15, 2011, 05:05:58 pm »
Have internet Connection

Swopped Graphics Card. Working!

All Great Thanks Both for your replys