Author Topic: Cannot boot from PXE  (Read 1021 times)

electric_flesh

  • Newbie
  • *
  • Posts: 14
    • View Profile
Cannot boot from PXE
« on: March 11, 2011, 02:10:26 am »
Hello friends,


I hope you can help me with this issue:

1.- Ive set the Diskless MD PC to boot from PXE. The HDD is out.

2.- Ive created the Image using the admin web interface at the Core. Appeared "finished setting up diskless Media Directors".

3.- I boot the MD PC (client), Appear "booting vmlinuz..." and all that stuff. The MD has its own IP adress and all seems to be ok, but the screens shows:

Begin: Running /scripts/nfs-premount...
Done.

4.- I wait for about 5 minutes (or more) and the screens shows "connect: connection timed out". So, a cannot boot the MD Diskless




Please hel me.. what can i do? i cant find and answer on forums, please, i want to donate to the project, but i need to know how to make it work. Thanks for your help.

Regards from Santiago de Chile. :)

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Cannot boot from PXE
« Reply #1 on: March 11, 2011, 02:19:56 am »
Did you run:

/usr/pluto/bin/Diskless_CreateTBZ.sh

on the core before setting up the MD?


electric_flesh

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Cannot boot from PXE
« Reply #2 on: March 11, 2011, 03:40:23 am »
Yes, i did it through the web admin. The image was created successfully.... but it still shows "connection timed out".
.... :S

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 920
    • View Profile
Re: Cannot boot from PXE
« Reply #3 on: March 11, 2011, 04:13:47 am »
Welcome to LMCE!

You will need to open a terminal on the Core and run:

Code: [Select]
sudo /usr/pluto/bin/Diskless_CreateTBZ.sh

before your diskless MD will be able to boot.

J.

electric_flesh

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Cannot boot from PXE
« Reply #4 on: March 11, 2011, 03:08:51 pm »
Ok,

I did "sudo /usr/pluto/bin/Diskless_CreateTBZ.sh" an the core,  the last output lines says:


"
Code: [Select]
####Installing pluto-orbiter
Reading package lists... Done
Building dependency tree... Done
Package pluto-orbiter is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package pluto-orbiter has no installation candidate
#### Package pluto-orbiter faile (/tmp/tmp.FbivP29837)



The core computer is connected to the Internet trought a switch and then and DSL router, but if i use Konqueror, the Internet isnt working for me.

It is necessary to be connected to the internet to get the Netboot image working?

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 920
    • View Profile
Re: Cannot boot from PXE
« Reply #5 on: March 11, 2011, 07:27:34 pm »
Yes, you will need an active internet connection on the core when you run Diskless_CreateTBZ.sh.

J.

electric_flesh

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Cannot boot from PXE
« Reply #6 on: March 15, 2011, 08:45:34 pm »
It wanst necessary to be connected to the Internet.

At he end, the MDs were taken a lot of time to boot from PXE because my ethernet switch wasnt working good. I replaced the switch and the MDs boot very fast.

Problem solved.


Thanks a lot!