Author Topic: Audio - Video Sync.  (Read 660 times)

gtsupport

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Audio - Video Sync.
« on: March 01, 2011, 10:00:13 am »
I have a problem with the audio sync when watching tv on my kitchen MD.  I have a Hauppauge HD-PVR capturing the input signal from the satellite box on the core/hybrid, then LMCE streams it to the kitchen MD.  If I watch it on the core, the audio is in perfect sync with the picture, but on the MD the sound is about 1 second faster.  Its fine watching ripped dvd's or even playing them from the dvd drive in the core, its only the live TV (I'm not using Myth).  I've tried using the analogue stereo output on the MD with pc speakers, and I'm now using the HDMI cable with the TV speakers.  Both the same.

Network is gigabit LAN.

The MD is a Zotac MAG (MAGHD-ND01) which uses the Nvidia ION graphics card.  In Webadmin -> Devices -> the graphics card is set to standard video card.  I know some receivers have a delay option you can set, but I'm using the speakers in the TV, and there is no option there to delay it.

I'm living with it because I only use it to watch the news in the morning when getting ready for work, and mostly just listen, but it annoys me that its not right, so if there's a fix I'd love to sort it.

Cheers.
Matt.
LinuxMCE - If it was easy, everybody would be doing it!!

gtsupport

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Audio - Video Sync.
« Reply #1 on: March 02, 2011, 10:38:02 am »
OK, I had a thought this morning, tried the following, and it got better.

Start live TV. (audio is out of sync with video)
press pause. (LMCE sends pause to SKY HD box)
Everything is paused.
press play. (LMCE sends play to Sky HD box)
media starts again and sync. is much better. :D

Maybe the video card is just a bit slow to respond when the signals start arriving, slower than the audio anyway. I dunno ???
LinuxMCE - If it was easy, everybody would be doing it!!

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Audio - Video Sync.
« Reply #2 on: March 02, 2011, 10:58:27 am »
Shouldn't you be using vdpau with that motherboard, rather than the standard graphics?

If you decide to change it, then apparently you only need to click "Update" at the bottom of the page - rebuilding the image, as I have been doing all this time, is not necessary. Not had chance to test this myself, but the information comes from a reliable source :)

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps