Author Topic: [Solved] Slow internet through core  (Read 2799 times)

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
[Solved] Slow internet through core
« on: February 27, 2011, 02:53:31 pm »
Hi all,
I'm trying to set up my core again with a new board and all seems to be good so far but any PC connected to the internal network seems to have very slow internet connection. Pages get part way through loading and then seem to freeze. (the circle keeps turning but no more downloading.) PC's connected to the external network seem fine. Internet from the core seems okay too.

Are there any commands I can use to find out more or any idea what the problem might be?

ifconfig

Code: [Select]
eth0      Link encap:Ethernet  HWaddr 00:25:22:97:f0:dc
          inet addr:192.168.80.1  Bcast:192.168.80.255  Mask:255.255.255.0
          inet6 addr: fe80::225:22ff:fe97:f0dc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8128750 errors:1 dropped:0 overruns:0 frame:1
          TX packets:4345311 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3311348389 (3.3 GB)  TX bytes:295912710 (295.9 MB)
          Interrupt:220 Base address:0xa000

eth1      Link encap:Ethernet  HWaddr 00:a1:b0:69:73:45
          inet addr:192.168.1.53  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2a1:b0ff:fe69:7345/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23410 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17553 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21909961 (21.9 MB)  TX bytes:2313458 (2.3 MB)
          Interrupt:19 Base address:0x2c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:88553 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88553 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:13779081 (13.7 MB)  TX bytes:13779081 (13.7 MB)

Thanks Josh
« Last Edit: March 09, 2011, 08:32:56 pm by joshpond »
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #1 on: February 27, 2011, 08:46:29 pm »
Code: [Select]
lspci
...and tell us details of the NICs, saying which is which.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #2 on: February 27, 2011, 09:36:57 pm »
Thanks Matt

Code: [Select]
00:00.0 RAM memory: nVidia Corporation MCP61 LPC Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation Device 03d6 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

The motherboard is an ASRock N68 S3 UCC DDR3
Kingston 2GB RAM
Sempron 140
Onboard PCI - Realtek PHY RTL8201EL
Second NIC is a Ritmo PCI which worked on the other motherboard which is a Realtek 8169 chip.

Apparently the onboard nic is on 100MBps and it is the internal card at the moment so I'll swap the interfaces too but that shouldn't make too much of a difference. If I read this right is the onboard NIC there?

Josh

EDIT: Swapped interfaces and the internal network went down. Ping from the core didn't reach any PCs.

ifconfig showed both eth there, sorry don't know how to copy and paste from the core.

Josh
« Last Edit: February 27, 2011, 09:52:30 pm by joshpond »
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #3 on: February 27, 2011, 10:41:40 pm »
If it's the r8169 NIC that is giving you the trouble, I would recommend blacklisting it (the r8169 module) and using the r8168 driver from the Realek site instead.

Edit "etc/modprobe.d/blacklist" and add "blacklist r8169".

Run...

Code: [Select]
sudo update-initramfs -k all -u
...and then...

Code: [Select]
rmmod r8169
Then install r8168 driver from Realtek site.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #4 on: February 28, 2011, 07:39:43 am »
Thanks Matt.

I've been reading up all over the forum about the r8169 issue, it all worked on the previous core so something must have broke it recently.

Haven't blacklisted the r8169 yet, just trying to make sure I get the files ready first and luckily I did as i'm having issues trying to tar the realtek driver:
Code: [Select]
core@dcerouter:/root/Desktop$ sudo tar -jvxf r8168-8.021.00.tar.bz2
tar: This does not look like a tar archive
tar: Skipping to next header

bzip2: Data integrity error when decompressing.
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Child returned status 2
tar: Error exit delayed from previous errors

Is it an error with the file?
Does anyone have a copy I can use or is there something I' doing wrong.

Josh
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #5 on: February 28, 2011, 09:57:18 am »
Should have asked you to do a
Code: [Select]
lsmod |grep r8* first.

FYI if you uncompress that folder using the GUI, you should see a very handy script for installing the driver.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #6 on: February 28, 2011, 10:27:57 am »
Okay, when I get to the KDE desktop and the file, click on it and it opens up ARK.

It looks like it is empty in there.


Josh
« Last Edit: February 28, 2011, 10:43:57 am by joshpond »
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #7 on: February 28, 2011, 11:19:13 am »
When you uncompress there is an option to check that says "all files and folders" or something like that.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #8 on: February 28, 2011, 12:18:14 pm »
Okay,

I think there may have been an issue with all downloads on the core as ark was showing the file as empty, no extract button available and terminal wouldn't allow me to tar -j.

Anyhoo, downloaded on another computer and tar'd there copied the files onto the core.

blacklisted r8169

sudo update-initramfs -k all -u

rmmod r8169

ran the ./autorun.sh for the r8168-8.021.00

lsmod shows the r8168.

This is where I get stuck.

ifconfig shows no eth1 now and no internet connection at all.
ifup eth1
comes back with error getting interface flags.

reboot and lsmod shows the r8168 is gone so ./autorun.sh the r8168 module again

Still the same error.

How do I get my eth1 back using the r8168?

thanks Josh



My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #9 on: February 28, 2011, 12:31:41 pm »
That sounds odd. It was at that point it started working for me.

Just delete the line you added in the black list file, reboot, and "modprobe r8169", that should take you back to where you were before.

Other thing you can do is have a look in "/lib/modules/<your_kernel>/kernel/drivers/net/" for r8168.ko/r8169.ko and see what is going on in there.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #10 on: March 01, 2011, 12:18:43 am »
Thanks Matt,

I thought I was missing something else to get it going.
r8168.ko was there and there was a r8169.bak which I assume the realtek autoinstall may have pushed it there or something.

Tried the r8169 from phenigma from this post
http://forum.linuxmce.org/index.php?topic=11395.0
and something killed it as it won't boot so I'm reinstalling and trying to get it r8168 to work in kubuntu first.

Do you know if it is something recent in the update/upgrade that has caused the r8169 to have problems?

I ask as I've used this network card in my previous core (different motherboard) with no problems but that install was updated about jan this year.

Josh
My Setup: On it's way

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #11 on: March 01, 2011, 09:35:19 pm »
okay,
new install, in kubuntu only, haven't run the linuxmce script.

blacklisted r8169
update initramfs
autorun the r8168 driver.

lsmod shows r8168 is there
ifconig only shows eth0 and lo
ifconfig -a shows:
Code: [Select]
eth0      Link encap:Ethernet  HWaddr 00:25:22:97:f0:dc
          inet addr:192.168.1.51  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::225:22ff:fe97:f0dc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:111952 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60177 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:157668742 (157.6 MB)  TX bytes:4721272 (4.7 MB)
          Interrupt:220 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1000 (1000.0 B)  TX bytes:1000 (1000.0 B)

pan0      Link encap:Ethernet  HWaddr ea:fc:4c:83:c4:eb
          inet6 addr: fe80::e8fc:4cff:fe83:c4eb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B

There is a pan0 there and there is no bluetooth on the motherboard.

lshw -C network
Code: [Select]
WARNING: you should run this program as super-user.
  *-network UNCLAIMED
       description: Ethernet controller
       product: RTL-8169 Gigabit Ethernet
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: a
       bus info: pci@0000:01:0a.0
       version: 10
       width: 32 bits
       clock: 66MHz
       capabilities: cap_list
       configuration: latency=64 maxlatency=64 mingnt=32
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: pan0
       serial: ea:fc:4c:83:c4:eb
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A multicast=yes

Does this mean that the second network card is being picked up as pan0 instead?

/etc/udev/rules.d/70-persistent-net.rules file

Code: [Select]
# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# PCI device 0x10de:0x03ef (forcedeth)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:25:22:97:f0:dc", ATTR{type}=="1", KERNEL=="$

# PCI device 0x10ec:0x8169 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:a1:b0:69:73:45", ATTR{type}=="1", KERNEL=="$


I don't know much about this but finding stuff on google. is it possible that the eth1 in the rules file is blocking the second card from coming up as eth1?

Josh

PS also tried undoing it by
#the blacklist r8169 out.
sudo update-initramfs -k all -u
reboot
no eth1 or r8169 in lsmod
modprobe r8169 shows;
FATAL: Module r8169 not found.
the file r8169.ko is in the /lib/....../drivers/net

????lost????
« Last Edit: March 01, 2011, 10:38:46 pm by joshpond »
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #12 on: March 02, 2011, 05:34:15 pm »
Sorry I have no idea what to suggest. I have just formatted my core with latest snapshot; once I get the r8169 NIC working again, I will have a look around and see how it compares to yours.

IF I get it working again  :)

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joshpond

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Slow internet through core
« Reply #13 on: March 06, 2011, 11:20:04 am »
Thanks for trying anyway Matt.

The frustrating thing and I see it in you MD troubles is that it worked before (albeit with another motherboard).

I might try an older snapshot and not try the updates or a different PCI network card as they aren't that expensive.

Anyone know of any decent ones that are plug and play?

Thanks Josh
My Setup: On it's way

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: Slow internet through core
« Reply #14 on: March 06, 2011, 03:53:31 pm »
Well I am having serious problems with the new install. I can get the r8169 NIC working with the old r8168 driver as before, but now my MDs are acting very oddly.

These are MDs that have always worked OOTB in the past with previous snapshots. Now I am getting very VERY slow boot times, kernel panics, all sorts.

If I get working and find anything that is relevant to you, will report back.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps