Author Topic: MD freezes at "done rebuilding nis cache"  (Read 807 times)

bob1212

  • Making baby steps
  • Posts: 2
    • View Profile
MD freezes at "done rebuilding nis cache"
« on: February 13, 2011, 06:20:08 am »
I have a fresh install of LinuxMCE, installed using the most recent snapshot.  The orbiter on the core loads fine, but I can't get it to work on either of 2 MDs.  One MD is a foxconn nt-510, the other is a generic virtual machine in VMware.  With both MDs, I get through the AV wizard, but every time I restart after that, when the big white letters come up on the screen, neither one will go past "done rebuilding nis cache".  It just sits there, and after a few minutes the screen goes blank.

Also, while it's hanging there, there is a bunch of data being transmitted from the MD to the core.  An excessive amount actually, in the last 45 minutes over 4 GB. The MD is still responive, ctrl+alt+F1 brings up another virtual terminal, so I ssh'd in to look at what was running.  I pasted that here:
Code: newbielink:javascript:void(0); [nonactive]
sambahelper@moon40:~$ ps ax         
  PID TTY      STAT   TIME COMMAND
    1 ?        Ss     0:02 /sbin/init
    2 ?        S<     0:00 [kthreadd]
    3 ?        S<     0:00 [migration/0]
    4 ?        S<     0:01 [ksoftirqd/0]
    5 ?        S<     0:00 [watchdog/0]
    6 ?        S<     0:00 [migration/1]
    7 ?        S<     0:01 [ksoftirqd/1]
    8 ?        S<     0:00 [watchdog/1]
    9 ?        S<     0:00 [migration/2]
   10 ?        S<     0:01 [ksoftirqd/2]
   11 ?        S<     0:00 [watchdog/2]
   12 ?        S<     0:00 [migration/3]
   13 ?        S<     0:01 [ksoftirqd/3]
   14 ?        S<     0:00 [watchdog/3]
   15 ?        S<     0:00 [events/0]
   16 ?        S<     0:00 [events/1]
   17 ?        S<     0:00 [events/2]
   18 ?        S<     0:00 [events/3]
   19 ?        S<     0:00 [khelper]
   60 ?        S<     0:00 [kintegrityd/0]
   61 ?        S<     0:00 [kintegrityd/1]
   62 ?        S<     0:00 [kintegrityd/2]
   63 ?        S<     0:00 [kintegrityd/3]
   65 ?        S<     0:00 [kblockd/0]
   66 ?        S<     0:00 [kblockd/1]
   67 ?        S<     0:00 [kblockd/2]
   68 ?        S<     0:00 [kblockd/3]
   70 ?        S<     0:00 [kacpid]
   71 ?        S<     0:00 [kacpi_notify]
  153 ?        S<     0:00 [cqueue]
  157 ?        S<     0:00 [kseriod]
  209 ?        S      0:00 [pdflush]
  210 ?        S      0:00 [pdflush]
  211 ?        S<     0:02 [kswapd0]
  253 ?        S<     0:00 [aio/0]
  254 ?        S<     0:00 [aio/1]
  255 ?        S<     0:00 [aio/2]
  256 ?        S<     0:00 [aio/3]
  424 pts/4    S      0:00 su bob
  444 pts/4    S+     0:00 bash
 1448 ?        S<     0:00 [ksuspend_usbd]
 1451 ?        S<     0:00 [khubd]
 1545 ?        S<     0:00 [ata/0]
 1565 ?        S<     0:00 [ata/1]
 1567 ?        S<     0:00 [ata/2]
 1569 ?        S<     0:00 [ata/3]
 1572 ?        S<     0:00 [ata_aux]
 2376 ?        S<     0:00 [scsi_eh_0]
 2377 ?        S<     0:00 [scsi_eh_1]
 2484 ?        S<     0:00 [scsi_eh_2]
 2485 ?        S<     0:00 [usb-storage]
 2507 ?        S<     0:10 [rpciod/0]
 2508 ?        S<     0:10 [rpciod/1]
 2509 ?        S<     0:09 [rpciod/2]
 2510 ?        S<     0:10 [rpciod/3]
 2526 ?        S<     0:10 [nfsiod]
 2686 ?        S<s    0:04 /sbin/udevd --daemon
 2987 ?        S<     0:00 [kpsmoused]
 3037 ?        S<     0:00 [btaddconn]
 3038 ?        S<     0:00 [btdelconn]
 4411 ?        Ss     0:00 /sbin/mdadm --monitor --pid-file /var/run/mdadm/monit
 4769 ?        Ss     0:00 /sbin/portmap
 4804 ?        Ss     0:00 /sbin/rpc.statd
 5046 tty4     Ss+    0:00 /sbin/getty 38400 tty4
 5047 tty5     Ss+    0:00 /sbin/getty 38400 tty5
 5049 tty2     Ss     0:00 /bin/login --   
 5050 tty3     Ss+    0:00 /sbin/getty 38400 tty3
 5051 tty6     Ss+    0:00 /sbin/getty 38400 tty6
 5274 ?        Ss     0:00 /usr/sbin/acpid -c /etc/acpi/events -s /var/run/acpid
 5331 ?        S<     0:00 [kondemand/0]
 5333 ?        S<     0:00 [kondemand/1]
 5334 ?        S<     0:00 [kondemand/2]
 5335 ?        S<     0:00 [kondemand/3]
 5429 ?        Ss     0:02 /sbin/syslogd -u syslog
 5486 ?        S      0:04 /bin/dd bs 1 if /proc/kmsg of /var/run/klogd/kmsg
 5488 ?        Ss     0:03 /sbin/klogd -P /var/run/klogd/kmsg
 5568 ?        Ss     0:00 /bin/dbus-daemon --system
 5646 ?        Ss     0:00 avahi-daemon: running [moon40.local]
 5656 ?        Ss     0:00 avahi-daemon: chroot helper
 5860 ?        Sl     0:00 /usr/sbin/ypbind
 6700 ?        Ss     0:00 /usr/sbin/cupsd
 6805 ?        S<     0:00 [lockd]
 6806 ?        S<     0:00 [nfsd4]
 6807 ?        S<     0:00 [nfsd]
 6808 ?        S<     0:00 [nfsd]
 6809 ?        S<     0:00 [nfsd]
 6810 ?        S<     0:00 [nfsd]
 6811 ?        S<     0:00 [nfsd]
 6812 ?        S<     0:00 [nfsd]
 6813 ?        S<     0:00 [nfsd]
 6814 ?        S<     0:00 [nfsd]
 6820 ?        Ss     0:00 /usr/sbin/rpc.mountd
 6889 ?        Ss     0:01 /usr/sbin/hald
 6906 ?        Ssl    0:00 /usr/sbin/console-kit-daemon
 6907 ?        S      0:00 hald-runner
 6990 ?        S      0:00 hald-addon-input: Listening on /dev/input/event5 /dev
 6998 ?        S      0:00 hald-addon-acpi: listening on acpid socket /var/run/a
 7025 ?        S      0:00 hald-addon-storage: polling /dev/sdb (every 2 sec)
 7054 ?        Ss     0:00 /usr/sbin/bluetoothd
 7082 ?        S<     0:00 [krfcommd]
 7171 ?        Ssl    0:00 /usr/bin/mythbackend --daemon --logfile /var/log/myth
 7223 ?        Ss     0:00 /usr/sbin/cron
15693 ?        Ss     0:00 SCREEN -d -m -S StorageStatusRadar /usr/pluto/bin/Sto
15702 pts/0    Ss+    0:00 /bin/bash /usr/pluto/bin/StorageDevices_StatusRadar.s
15944 ?        Ss     0:00 /usr/sbin/sshd
16089 ?        Ss     0:00 /usr/sbin/automount --pid-file=/var/run/autofs/_mnt_d
16610 ?        Ss     0:00 SCREEN -d -m -S XWindowSystem /usr/pluto/bin/Start_X_
16613 pts/1    Ss+    0:00 /bin/bash /usr/pluto/bin/Start_X_Wrapper.sh --parms s
16628 pts/1    S+     0:00 xinit /usr/pluto/bin/XWM_Wrapper.sh /usr/bin/xfwm4 --
16629 tty7     S<s+   0:09 X :0 -ignoreABI -ac -allowMouseOpenFail vt7 -logverbo
16670 ?        Ss     0:07 SCREEN -d -m -S LMCE_Launch_Manager /usr/pluto/bin/La
16673 pts/2    Ss+    0:05 /bin/bash /usr/pluto/bin/LaunchManagerDaemon.sh
16699 tty1     Ss+    0:00 /sbin/getty 38400 tty1
16708 pts/1    S      0:00 /usr/bin/xfwm4 --compositor=off
16735 ?        S      0:00 dbus-launch --autolaunch 027e474d260b88021418c0874d57
16742 ?        Ss     0:00 //bin/dbus-daemon --fork --print-pid 5 --print-addres
16748 ?        S      0:01 /usr/bin/python /usr/lib/gnome-osd/gnome-osd-server
16816 ?        S      0:00 /usr/lib/libgconf2-4/gconfd-2
16827 ?        Ssl    0:00 /usr/lib/bonobo-activation/bonobo-activation-server -
16902 ?        Ss     0:00 xfce-mcs-manager
18232 ?        Ss     0:00 /usr/sbin/nmbd -D
18244 ?        Ss     0:00 /usr/sbin/smbd -D
18251 ?        S      0:00 /usr/sbin/smbd -D
20421 ?        Ss     0:00 sshd: bob [priv]
20572 ?        S      0:00 sshd: bob@pts/5 
20580 pts/5    Ss     0:00 -bash
20927 pts/2    Dl+    0:00 /usr/pluto/bin/LMCE_Launch_Manager --nofork --nocrash
20947 pts/0    S+     0:00 sleep 5
20949 pts/5    R+     0:00 ps ax
24796 tty2     S      0:00 -bash
29860 tty2     S+     0:00 screen
29863 ?        Ss     0:00 SCREEN
29870 pts/3    Ss     0:00 /bin/bash
30298 pts/3    S+     0:03 top
30451 pts/4    Ss     0:00 /bin/bash

Here's bwm-ng running on the core:
Code: newbielink:javascript:void(0); [nonactive]
  bwm-ng v0.6 (probing every 0.500s), press 'h' for help
  input: /proc/net/dev type: sum
  /         iface                   Rx                   Tx                Total
  ==============================================================================
               lo:        1353.60 KB           1353.60 KB           2707.21 KB
             eth0:        3498.65 KB           2244.17 KB           5742.81 KB
             eth1:     6028401.20 KB         183037.21 KB        6211438.41 KB
  ------------------------------------------------------------------------------
            total:     6033253.46 KB         186634.98 KB        6219888.43 KB


Is there anything unusual going on here?

Anan

  • First post!
  • Posts: 1
    • View Profile
Re: MD freezes at "done rebuilding nis cache"
« Reply #1 on: December 27, 2011, 12:30:59 pm »
I have installed Kubuntu 8.10 and then clicked on the LinuxMCE icon on the Desktop. After reboot there was few actions until "done rebuilding nis cache". It hangs on it, and after few minutes the screen goes white with X cursor.

Any ideas, what might be the reason?

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1080
    • View Profile
Re: MD freezes at "done rebuilding nis cache"
« Reply #2 on: December 27, 2011, 04:34:54 pm »
Are you guys making it through AVWizard? Or is it dumping directly to orbiter gen after diskless setup?

* Rereading, I see OP is.

Try this...
ssh into MD as root, and
Code: [Select]
apt-get install -y pluto-orbiter pluto-orbiter-gen
Please report results, whether or not it said latest version installed, or if it had to install.
« Last Edit: December 27, 2011, 04:57:36 pm by l3mce »
I never quit... I just ping out.