Author Topic: [SOLVED!] dual sound-card setup, no sound on sdpif-coax  (Read 2037 times)

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
[SOLVED!] dual sound-card setup, no sound on sdpif-coax
« on: February 11, 2011, 01:14:23 pm »
Hi,

Hardware:
asus k8v se deluxe with onboard SoundMax ADI ad1980, i use the spdif-coax bracket that i got with the mobo.
Installed on this mobo a extra soundblaster live!

The Soundblaster live! i wanna use in the future as a squeezeslave.
The onboard spdif-coax (through bracket) i hooked up to my reciever (Onkyo TX-SR600E)
I used that connection on my reciever with my dvd-player so i know its good.

Problem:
in webadmin under MD it says sound card: soundblaster live! and when i change it its set-back to this!
and the strange thing is under advanced, section sound card it says "no sound cards found"

Question:
How do i get my md to default to spdif-coax-onboard-soundcard?

thanks for any help in advanced,
br,
Raymond
« Last Edit: February 16, 2011, 04:28:57 pm by RayBe »
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #1 on: February 11, 2011, 04:43:08 pm »
you need to run the avwizard to change settings like that.
you also need to make sure to disable any other sound cards, and if you cant then you may have to blacklist them to keep the driver from loading.

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #2 on: February 11, 2011, 06:32:46 pm »
merkur2k thanks for replying,

thats actually what i did, and i choose spdif-coax, but no sound.
blacklisting the driver for one of the cards isn't a option since i am planning to use both cards.

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #3 on: February 11, 2011, 06:42:39 pm »
i also did ssh moon into my md and then i did:
sudo asoundconf list
wich showed me: live and "the onboard card"
i then did:
sudo asoundconf set-default-card "the onboard card" and rebooted.

now when i ssh moon into the MD and do alsamixer it showes me "the onboard card" instead of the soundblaster live, i unmute the IEC958 Output but still no sound.

so i checked the webadmin once more, still it says Sound Card: SB live!, changed it, rebooted md and it defaults back to SB live!.

anybody any ideas?

thanks upfront,
br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #4 on: February 11, 2011, 08:03:35 pm »
Hi Raymond,

Why would u want to use 2 sound cards?

Karel

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #5 on: February 11, 2011, 10:45:26 pm »
to use multiple SqueezeSlaves ;)

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: dual sound-card setup, no sound on sdpif-coax
« Reply #6 on: February 13, 2011, 02:37:25 pm »
things i tried so far:

- in kde-desktop settings->sound i rearranged the list of sound cards so that via 8237 entries are on top off every list.
- in mixer i un-muted all spdif-sliders in mixer of Via 8237 and set them to max.
After this, in webadmin, i tried to set SB Live! to standard soundcard but it keeps defaulting back to SB Live!
I also tried instead of SPDIF-Coax the manual settings but that didn't helped either.

someone any ideas as where to look?
thanks in advance,
br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
[SOLVED] Re: dual sound-card setup, no sound on sdpif-coax
« Reply #7 on: February 16, 2011, 04:28:20 pm »
Hi all, after a long, long search i finally found a solution that worked for me,
http://forum.vectorlinux.com/index.php?topic=4888.0
i copied it below for reference:

Quote
If you have multiple soundcards (like an onboard and an external one), you might have had the problem that the wrong one is the default soundcard. This is because the kernel module for the "wrong" card is loaded first, and if no option is passed when loading the module it gets the first available card number (0).

If they both use a different kernel module you can easily make sure the right one is the default card.

Find out what module is being used for your soundcards:
Code: [Select]
cat /proc/asound/modules

On my computer this could give
Code: [Select]
0 snd_usb_audio
1 snd_es1968
This means that the card that's currently the default soundcard (card 0) uses the snd_usb_audio module.

This is my EMI M4U, a device that's just capable of sending and receiving midi signals, not audio. So when I try to play sound I get an error. So I want the other one to be default.

You can't "reserve" card 0 for a particular module, because the options for a module are only passed when the module is loaded, and the whole problem was that the wrong module is loaded first. So, to make sure the right soundcard is default, we have to make sure the other one becomes card 1 when the module for it is loaded. This can be done by adding 1 simple line to /etc/modprobe.d/sound:
Code: [Select]
options name_of_offending_module index=1

So, in my case this would be
Code: [Select]
options snd_usb_audio index=1

Reboot and try!

Hope this helps other too,
br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #8 on: February 17, 2011, 12:36:59 pm »
Hi Raymond,

Why not update/create a wiki page for it.
It would be easier for others to search.

Karel

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #9 on: February 17, 2011, 09:05:37 pm »
good idea!, will do,
first have to find out how to do that,

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #10 on: February 17, 2011, 09:14:12 pm »
Raymond,

http://wiki.linuxmce.org/index.php/Add_a_page_to_the_wiki

If I recall correctly, u need to create a user account for the WIKI to.

Karel

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #11 on: February 17, 2011, 09:46:43 pm »
Thanks Karel,
Wil look into it,
br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

RayBe

  • Guru
  • ****
  • Posts: 291
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #12 on: February 25, 2011, 11:42:13 pm »
check my first contribution to the wiki  :D:
http://wiki.linuxmce.org/index.php/Dual_Sound_Cards
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: [SOLVED!] dual sound-card setup, no sound on sdpif-coax
« Reply #13 on: February 26, 2011, 07:54:14 am »
Great job Raymond.


Whats next.......  ;)