Author Topic: Pad Orbiter and WPA2  (Read 3113 times)


  • Veteran
  • ***
  • Posts: 108
    • View Profile
Pad Orbiter and WPA2
« on: February 17, 2011, 02:50:58 pm »
***** See post 3 for how to setup *******

Hi all,

First off a bit of a noob so basically googled my way through this but want to see if I'm on the right track or not.

WebDt 360, just installed padobiter but not fully configured as no core.

Purchased these cheap PCMCIA cards off ebay.
They are basically a RT2500 chip wireless card which is supported by linux.
The card when plugged in shows up under lspci as the RT2500
Now the assumptions begin:
I can't use iwconfig to setup the wlan0 as it doesn't support wpa2
I've updated wpasupplicant and the needed dependencies.
edited my /etc/network/interfaces to look like that recommended by:
Code: [Select]
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key>
NOTE: my gateway is the router set at (no core) and essid broadcast.
ifup wlan0

Is the debian interfaces setup the same as ubuntu?
Should this work in theory?
I tried ping (my NAS) and no reply
Am I better off just waiting for my core to come back before trying all this.
Is it even possible or am I barking up the wrong tree and wasting my time.

Thanks Josh

Sorry if there are any errors here, it is getting very late and the old eyes are struggling.

PS what is the exact keystrokes to get from the splash to the terminal. I press CTRL + C +T but all I get is the cursor cross becoming a square. I then mash 1 and enter and sometimes the terminal comes up. It does say no managed window in the corner.
« Last Edit: February 21, 2011, 06:10:43 am by joshpond »
My Setup: On it's way


  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Pad Orbiter and WPA2
« Reply #1 on: February 19, 2011, 09:50:29 pm »
Okay, Pretty stupid, but it all works now. I changed a setting on mu wireless AP and when saving the changes froze so nothing was connecting. A reboot of the AP solved the issue.

I'll post a write up when I get some time but essentially the PCMCIA card is pretty much plug and play and cheap too. It does stick out the top of the webdt about 2.5cm.

I'll have to wait for my motherboard to come back for my core and I'll give it a go then but pinging works so far.

My Setup: On it's way


  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Pad Orbiter and WPA2
« Reply #2 on: February 21, 2011, 06:08:37 am »
Okay update for all who are interested.

To get WPA2 security on the Webdt 366 I purchased a pcmcia card (EDUP brand) off ebay. Pretty cheap and plentiful. It uses a Ralink RT2500 chip which if you search there website is also in a lot of other cards from asus, gigabyte and a whole lot of no name brand ones.

Card plugs in but does stick out of the top as it doesn't use an external antenna.

Upon boot up, enter terminal
Code: [Select]
lspciShould show RT2500 loaded.

edit and copy the interfaces file as a backup
I used nano but pick your poison
Code: [Select]
cd /etc/network
cp interfaces interfaces.old
nano interfaces

Edit the interfaces file as per this website
My core was set at
NOT the recommended
Also most of my IP addresses are static, hence the static not DHCP setting.

I removed the eth0 line and started there.
Mine is listed in the first post.
Ping works but I have to wait for a core to test.

« Last Edit: February 21, 2011, 06:12:42 am by joshpond »
My Setup: On it's way


  • LinuxMCE God
  • ****
  • Posts: 1758
    • View Profile
Re: Pad Orbiter and WPA2
« Reply #3 on: February 21, 2011, 08:26:42 am »
Great stuff Josh!  Thanks for posting a howto!