Author Topic: Asterisk is not work with LinuxMCE1004  (Read 3559 times)

Megart.vlad

  • Newbie
  • *
  • Posts: 9
    • View Profile
Asterisk is not work with LinuxMCE1004
« on: January 23, 2011, 12:31:31 pm »
Asterisk 1.6 is not run. When Asterisk is run, not load chan_sip.so

I have placed it in tracker (http://svn.linuxmce.org/trac.cgi/ticket/963)

Decision:
Do installation:
wget -c deb.linuxmce.org/ubuntu/new-installer-latest.tar.gz
tar xvf new-installer-latest.tar.gz
cd new-installer
./pre-install-from-repo.sh
./mce-install.sh

After that we do:
vi /etc/asterisk/modules.conf
Add in section [modules]
noload => app_voicemail_imap.so
noload => app_voicemail_odbc.so :wq

cp /etc/asterisk/sip.conf /etc/asterisk/sip_general_custom.conf
> /etc/asterisk/sip_general_custom.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_nat.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_registrations_custom.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_general_additional.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_custom.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_registrations.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_additional.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_notify.conf
cp /etc/asterisk/sip_general_custom.conf /etc/asterisk/sip_registration.conf
chown asterisk:asterisk /etc/asterisk/*

rm /usr/share/asterisk/agi-bin/ -R
ln -s /var/lib/asterisk/agi-bin/ /usr/share/asterisk/

vi /var/lib/asterisk/bin/freepbx_engine

Change string:
/usr/sbin/asterisk -rx "stop gracefully"

On:
/usr/sbin/asterisk -rx "core stop gracefully"

vi /usr/sbin/safe_asterisk
Change:
BACKGROUND=0

On:
BACKGROUND=1

./post-install.sh
reboot

After that asterisk and sip is work. But have problem with communications with Orbiter. I can call, but whet softphone is ring, I am not see that in Orbiner, only listen. Not see Active call.

I think, problem with change API command in Asterisk 1.6 (need begin with "core" (core show channels, and any)).
« Last Edit: January 23, 2011, 12:35:20 pm by Megart.vlad »

Megart.vlad

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #1 on: January 23, 2011, 02:30:49 pm »
Dear developers. Please, tell, what a problem with work Asterisk 1.6 in LinuxMCE 1004?
After each new installation I find new problems. Perhaps, I can help to start Asterisk 1.6 normal work with FreePBX 2.8 (or 2.2).

Today I not found file /etc/asterisk/extensions_additional.conf
It's need for FreePBX. FreePBX is not work. Sip users in not adding in mysql base (asterisk).
Sip trunk is adding in mysql base, but not adding in asterisk's conf files.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk is not work with LinuxMCE1004
« Reply #2 on: January 23, 2011, 04:16:12 pm »
Megart.vlad,

feel free to create patches for the integration of Asterisk 1.6 into our system. 1004 is NOT being supported at all at the moment. We are in the middle of having stuff compile under 1004, and have a few plugins working. Telecom is one plugin that is not working atm, due to major work needing to be done with the move from 1.4 to 1.6.

Dig in, and help us make it work.

Thanks.

Megart.vlad

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #3 on: January 23, 2011, 05:34:23 pm »
It's news from http://linuxmce.org/index.php/news/developer
Sunday, 05 December 2010 10:27

"Best regards Peer Oliver Schmidt Release Manager LinuxMCE Ohhhh, and one more thing: Preliminary support 1004 is available. This is more than bleeding edge. svn download the new-installer on a 1004 install, and see what happens."

I have updates every day.

Someboby update asterisk?


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk is not work with LinuxMCE1004
« Reply #4 on: January 23, 2011, 05:50:08 pm »
At the moment there are no updates in the asterisk area. Please check the comments in your asterisk tickets.

Thanks.

evilecho

  • Regular Poster
  • **
  • Posts: 36
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #5 on: January 23, 2011, 06:06:38 pm »
I dont know if this will help you.... but as I was going thru the logs (0810) it said that there where a bunch of config files missing, and that currently asterisk will run, but in the future the files need to exist even if they are blank, if they arnt there, asterisk will fail to start.

Megart.vlad

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #6 on: February 05, 2011, 11:28:29 pm »
Patch for Phones:
Asterisk 1.6.2.16
FreePBX 2.8

asterisk.tar.gz -- Compiled Asterisk and FreePBX 2.8
pluto.tar -- Changes scripts (sync_pluto2amp.pl, create_amp_broadvoice.pl) for add trunk broadvoice (can used for other SIP providers)(Lines) and Phones

For delete use FreePBX (192.168.80.1/admin/index.php)

sudo su
rm /etc/asterisk/* /var/lib/asterisk/* /var/www/admin/ /var/www/panel/ /var/www/_asterisk/ /usr/sbin/amportal /etc/amportal.conf -Rf
cd /usr/src/
wget officetele.com/media/kunena/attachments/63/asterisk.tar.gz
tar xfvz /usr/src/asterisk.tar.gz -C /
mysql -uroot asterisk < /tmp/asterisk_freepbx.sql
amportal restart
wget officetele.com/media/kunena/attachments/63/pluto.tar
tar xfv pluto.tar
mv sync_pluto2amp.pl /usr/pluto/bin/
mv create_amp_broadvoice.pl /usr/pluto/bin/

Reboot or Reload

After
apt-get update && apt-get upgrade -y
do:
wget officetele.com/media/kunena/attachments/63/pluto.tar
tar xfv pluto.tar
mv sync_pluto2amp.pl /usr/pluto/bin/
mv create_amp_broadvoice.pl /usr/pluto/bin/
rm pluto.tar

Because files will change.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk is not work with LinuxMCE1004
« Reply #7 on: February 06, 2011, 11:57:45 am »
Megart.vlad,

you seem to be fairly adept at working with asterisk. Would you mind coming by our IRC channel #linuxmce-devel @ freenode.net and talk about becoming more involved into the project?

Megart.vlad

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #8 on: February 20, 2011, 07:23:07 pm »
It's Patch for SVN directory src/Asterisk. For Asterisk 1.6 and FreePBX 2.8

I want do deb package for freepbx and asterisk 1.6.
Are you want have asterisk from standart package or have own package asterisk-pluto without install asterisk from standart repo?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk is not work with LinuxMCE1004
« Reply #9 on: March 08, 2011, 09:57:07 am »
We would love to keep the standard asterisk from the ubuntu repo, and amend the configuration files as needed for us. FreePBX we keep in our own repo. We want to be able to built freepbx debs on our regular builder, like we do atm.

Thanks for your work

LmceCape

  • Veteran
  • ***
  • Posts: 65
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #10 on: March 16, 2011, 04:35:18 pm »
Hi Megart

Your tar file works great to get Asterisk up, but to get the security side working as well you need the original extensions.conf file.

Also the "/var/lib/asterisk/sounds/pluto" folder/files were missing.

I also had to modify the "/usr/pluto/bin/pluto-sos-gen.pl" file a bit.
need to include:
$EXT_BUFFER .= "[trusted]\n";
$EXT_BUFFER .= "include => from-internal\n";


and modify line 75

---    $EXT_BUFFER .= "exten => 997,n,MeetMe(997|q)\n";  #The dialplan has change from using "|" to comma
+++   $EXT_BUFFER .= "exten => 997,n,MeetMe(997,q)\n";

also changed (not sure if needed)

---   `/usr/bin/sox /tmp/festival.wav  -t raw -r 8000 -s -2 -c 1  $FILE resample -ql`;     to
+++  `/usr/bin/sox /tmp/festival.wav $FILE`;


The "/var/lib/asterisk/agi-bin/linuxmce-validate-user-pin.agi" file also need the "|" replaced with commas

Line 67
---    print "EXEC Goto pluto-security-custom|s|1\n";
+++   print "EXEC Goto pluto-security-custom,s,1\n";


Regards
LMCECape

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk is not work with LinuxMCE1004
« Reply #11 on: March 16, 2011, 04:47:15 pm »
LmceCape,

I have found the two lines you specified by line number. But did not find the place where to add the first EXT_BUFFER. Any hints?

LmceCape

  • Veteran
  • ***
  • Posts: 65
    • View Profile
Re: Asterisk is not work with LinuxMCE1004
« Reply #12 on: March 16, 2011, 05:20:29 pm »
I added them above line 66
$EXT_BUFFER .= "[from-internal-custom]\n";