Author Topic: 1wire support  (Read 23137 times)

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #90 on: March 13, 2011, 07:17:52 pm »
just to add: I added a second sensor today and the new 'auto sensor recognition' feature works really well.

Connect the sensor, quick reload, a new multilevelsensor device is created, you enter the sensors ID (you get it out of the interface log), quick reload. After that you can place the new sensor in your floorplan. That's it!

it does not put the sensor id in the port/channel field automatically?

br Hari
rock your home - http://www.agocontrol.com home automation

_if_

  • Guru
  • ****
  • Posts: 238
    • View Profile
Re: 1wire support
« Reply #91 on: March 13, 2011, 07:25:48 pm »
I will add a third sensor and check again...

_if_

  • Guru
  • ****
  • Posts: 238
    • View Profile
Re: 1wire support
« Reply #92 on: March 13, 2011, 07:41:20 pm »
nope: ID, ObjectType and room are empty...

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #93 on: March 13, 2011, 11:14:06 pm »
nope: ID, ObjectType and room are empty...
then we have a bug, the ID should be filled in automatically..
rock your home - http://www.agocontrol.com home automation

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 1wire support
« Reply #94 on: March 13, 2011, 11:37:04 pm »
I just destroyed my install while trying to set up owfs.  I think those instructions need some work

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: 1wire support
« Reply #95 on: March 14, 2011, 04:27:27 am »
Guys, why haven't we worked towards putting this in as part of the build? to get owfs packages, and the 1Wire device, put them into the Package database, so that the system can automatically deal with it?

come on, guys...

-Thom

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #96 on: March 14, 2011, 03:08:14 pm »
come on tschak, I did ask in the devel channel how to add an external package to our over-engineered build system.. nobody knows..

My part was the code, I have no time right now to fiddle with packages.

br Hari
rock your home - http://www.agocontrol.com home automation

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #97 on: March 14, 2011, 03:09:19 pm »
I just destroyed my install while trying to set up owfs.  I think those instructions need some work
I think you should provide more details what the hack you were doing..
rock your home - http://www.agocontrol.com home automation

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 1wire support
« Reply #98 on: March 14, 2011, 09:28:27 pm »
while trying to install OWFS i was following the instructions:

http://www.mail-archive.com/owfs-developers@lists.sourceforge.net/msg04821.html

specifically:

Code: [Select]
sudo apt-get install cvs autoconf automake libtool libfuse-dev libusb-dev swig php5 php5-dev php5-cli python-dev libperl-dev tcl-dev
Which casue some dependency issues which were not resolved, I asked some questions in the irc channel and did some Googling that made me do something stupid which ultimately killed my install.

I will give exact issues later when I get back to my irc client

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #99 on: March 15, 2011, 12:27:24 am »
thanks possy for taking care of the packaging!

Guys be patient, proper OneWire and libowfs packages will be available very soon.

br Hari
rock your home - http://www.agocontrol.com home automation

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 1wire support
« Reply #100 on: March 15, 2011, 12:50:38 am »
No Problem, I will wait.  Just let me know if you want me to test anything

Thanks for all your work

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: 1wire support
« Reply #101 on: March 15, 2011, 07:09:47 pm »
nope: ID, ObjectType and room are empty...
should be fixed now, please checkout rev 23832 and test again

br Hari
rock your home - http://www.agocontrol.com home automation

_if_

  • Guru
  • ****
  • Posts: 238
    • View Profile
Re: 1wire support
« Reply #102 on: March 15, 2011, 07:34:40 pm »
should be fixed now, please checkout rev 23832 and test again

br Hari

update is working! only room and objtype needs to be filled in manually now. Thanks!

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: 1wire support
« Reply #103 on: March 21, 2011, 12:29:14 am »
off-topic posts removed by moderator - Hari
« Last Edit: March 21, 2011, 10:07:56 am by hari »
"Change is inevitable. Progress is optional."
-- Anonymous


uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: 1wire support
« Reply #104 on: March 21, 2011, 09:58:54 am »
That depends, are you going to keep pretending that you're retarded?

Zaerc, this time around you're digging yourself a big hole on your own. I wonder what you'll do to yourself when you're the one who screwed you over.