Author Topic: Playing .mkv in xine_player - how to show subtitles?  (Read 1310 times)

Vagner

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Playing .mkv in xine_player - how to show subtitles?
« on: January 05, 2011, 06:20:29 am »
I made the following modifications (uncommented) in /etc/pluto/xine.conf:
gui.subtitle_autoload: 1
misc.spu_subtitle_size: large

The video is normal, but found no way to change or display the subtitles. I tried #, j, b, +, -, etc.. etc.. etc.

I also can not change the audio track.

Thanks,

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Playing .mkv in xine_player - how to show subtitles?
« Reply #1 on: January 05, 2011, 01:12:38 pm »
Hi Vagner,

Possibility to change audio track in AVI/MKV video and switch on/off subtitles is one of the most important features missed in LinuxMCE. Currently you can use following command on your core to change the audio track:

Code: [Select]
/usr/pluto/bin/MessageSend localhost 0 23 1 140 5 "<track number>" 41 ""
Audio track number can be 0, 1, 2 etc.

To show subtitles the subtitle's file should have the same name as video file, i. e. video-file.avi.srt. Also have a look this instruction about changing xine.conf.
« Last Edit: January 05, 2011, 01:16:36 pm by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Vagner

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Playing .mkv in xine_player - how to show subtitles?
« Reply #2 on: January 06, 2011, 02:14:01 am »
Ok thanks,

The audio worked, but how do I change the subtitles themselves . (dot) and , (comma) do not work? ... besides that I should not have keyboard

A new parameter in MessageSend?

Regards,