Author Topic: Event Problem  (Read 651 times)

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Event Problem
« on: December 21, 2010, 11:50:32 pm »
Hi,

I have created an IR template for my TV. I have saved pronto code for the power on/off.
I have tested on/off and everything works fine.

I have set up an event so that, when my PIR is activated (motion detected), my Z-Wave dimmer comes on. All this works fine.
On the same events page wizard>event handler>Respond to events. I add an additional event to motion detected, of power on for my IR TV.

When I test the IR command nothing happens. Seems either a I have not activated an option or something is broken.

Anyone got any ideas on what might be happening?

thanks for your time

Daniel


 

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Event Problem
« Reply #1 on: December 22, 2010, 04:36:25 pm »
does the system think the tv is already on when you test this? you need to let it time out and turn the tv off itself, or do so manually via an orbiter "power" menu.

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: Event Problem
« Reply #2 on: December 22, 2010, 10:44:43 pm »
Thanks for the reply merk,

When I press the test button on the events page for my IR TV nothing happens. When I do the same test from my IR template everything works fine.
I am 1st trying to get the event page to send a signal from pressing the test button before I go to the next stage of trying to activate the IR TV from a PIR activation.


Have you managed to use IR signal with the events? Or is the events designed for the Z Wave, X-10 devices?
 
At present I am playing with different events and scenarios so would like to try and avoid having to press the power button on the orbitor screen.

Cheers
Daniel

magner

  • Veteran
  • ***
  • Posts: 81
    • View Profile
Re: Event Problem
« Reply #3 on: December 26, 2010, 02:50:27 pm »
Hi,

Can somebody tell me if IR works with events please?

Thanks
Daniel

sambuca

  • Guru
  • ****
  • Posts: 439
    • View Profile
Re: Event Problem
« Reply #4 on: December 28, 2010, 01:33:44 pm »
Sending IR codes is just a command sent to the right device. A such, there is no limitation on events wrt. sending IR. You just have to make sure that the command is correct and destined to the correct device. You can test the command itself if you navigate to  Advanced -> Device and find your device. In the right pane, click "send command to device" and select the correct command. If you get that to work, there is no reason it should not work from an event.

br,
sambuca