Author Topic: New PLCBUS driver  (Read 17408 times)

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
New PLCBUS driver
« on: December 19, 2010, 10:17:16 pm »
Hi Folks,

I did write a new PLCBUS driver. The old one from ddamron was written as a GSD and had some issues. The new one is a multithreaded c++ DCE device. It should be much faster and more reliable. There is also a pnp script to auto-detect the PLCBUS 1141 adapter. The driver is included in the latest 0810 beta2. The wiki instructions are not yet updated.

If you have any wishes for new features or want to provide feedback: feel free to post.

br Hari
rock your home - http://www.agocontrol.com home automation

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #1 on: December 19, 2010, 11:54:09 pm »
http://x10-hk.com/store/manual/plcbus/plcbus-1141.pdf

Here is the datasheet of PLCBUS.

I would like to see

-on/off single unit (already implemented)
-Set level (already implemented)
 There also is Dim and Bright, but I do not see need for this
-All units on/off
-All lights on/off
-Status Request
-Report/get signal strength
-Report/get noise level
Also if you flip a lightswitch to on/off , it should report back to the system it is on/off
« Last Edit: December 20, 2010, 02:55:18 pm by bongowongo »

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #2 on: January 03, 2011, 10:19:57 am »
tested PnP in a bigger setup. First plugin in core, found a serial to usb device. I ignored it, plugged it in another port and got recognized. Could it be that when you plug it in, it does the buzz directly to recognize the commands for PLCBUS for PnP and the script didn't not run yet?

If you switch off/on a dimmable light switch it takes very long to go from 100 to 0% or vice versa, almost 1 minute more or less.
I would prefer 3 to 5 seconds. Maybe a timing mistake?
It would be nice for a wake up light though :).

When I select on the floorplan 5 lamps, A1, A3, A9, A6 and A7. One of those will not go on or off. It seems at random.
If I select 4 of those, they always go on and off.

The dimmable PLCBUS devices, remember the last dimstate they were in.
e.g. If I dimm the lamp to 50%, turn it off, and turn it on it goes to 50%. The max I can set it then on the floorplan would be 90%, because there is no 100% button. I want to know from you if this is something in the driver, or not. Because I suspect it could be a more general bug in the system. Depending on your reply, I will post a bug in trac.
« Last Edit: January 03, 2011, 10:22:01 am by bongowongo »

pezho

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: New PLCBUS driver
« Reply #3 on: January 04, 2011, 02:44:40 am »
Hi Guys!
I use the PLCBus devices from June 2010 were purchased from Shanghai Super Smart (www.s10.cn)
I have computer interface PLCBUS-T 1141 usb (http://www.plcbus.com.cn/Html/news/1440.html), Transceiver Module PLCBUS-T 4023G (http://www.plcbus.com.cn/Html/news/1462.html) and various lighting modules which I can operate via remote PLC-RF 4073E (http://www.plcbus.com.cn/Html/news/1477.html) and in Win XP, but never in LinuxMCE via Ruby or New Driver.
PLease kindly advise me that how I should setting up plcbus devices in LMCE.
1. I plug computer interface into usb, generic USB to RS232 dongle has been ignored.
2. Creating new interface PLCBUS.
3. Creating new lightings devices.
_______________________________________
With best wishes in NEW YEAR 2011 from Russia!

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #4 on: January 04, 2011, 09:31:19 am »
Are steps 1,2,3 taken, or you want advice on how to take them?

pezho

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: New PLCBUS driver
« Reply #5 on: January 04, 2011, 10:50:44 am »
Dear bongowongo,

1-3 is standard steps which I taken, but controling of plcbus in lmce have not working. If you can help me I can give you log's.

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #6 on: January 04, 2011, 11:06:41 am »
Could you verify that in your /usr/pluto/pnp, there is a script named PLCBus?
if not, you should update your core. Maybe it is better if you drop into IRC and we can troubleshoot there.

pezho

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: New PLCBUS driver
« Reply #7 on: January 04, 2011, 11:22:17 am »
Dear bongowongo,

I install clean 8.10 and update/upgrade lmce on 01.01.2011, last update today. What is IRC? Is it ICQ? I'm not use it. just skype: vmctech

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #8 on: January 04, 2011, 12:07:54 pm »
http://www.linuxmce.org/index.php/support
and
http://en.wikipedia.org/wiki/Internet_Relay_Chat
please do some research about IRC yourself, it is not that hard. at #linuxmce we can troubleshoot.
or open a new forum topic with your problems, otherwise we are filling this topic only with your troubleshooting, and that is not the topic of this post.
« Last Edit: January 04, 2011, 12:12:14 pm by bongowongo »

pezho

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: New PLCBUS driver
« Reply #9 on: January 04, 2011, 01:08:10 pm »
I run the Konversation and connect to Kubuntu room. I don't understand how to connect to lmce room

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: New PLCBUS driver
« Reply #10 on: January 04, 2011, 01:13:58 pm »
Could you please make a new forum topic.
I will help you there.

pezho

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: New PLCBUS driver
« Reply #11 on: January 04, 2011, 01:22:10 pm »

Esperanto

  • Guru
  • ****
  • Posts: 269
    • View Profile
Re: New PLCBUS driver
« Reply #12 on: January 29, 2011, 06:16:19 pm »
Hari,

Is the 3-phase functional and tested? I saw the checkbox in the admin but can't seem to get it to work.

thx!

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: New PLCBUS driver
« Reply #13 on: January 29, 2011, 09:10:54 pm »
Hari,

Is the 3-phase functional and tested? I saw the checkbox in the admin but can't seem to get it to work.

thx!
neither functional nor tested.. do you want that feature and volunteer to test it?


br Hari
rock your home - http://www.agocontrol.com home automation

Esperanto

  • Guru
  • ****
  • Posts: 269
    • View Profile
Re: New PLCBUS driver
« Reply #14 on: January 30, 2011, 06:08:26 pm »
neither functional nor tested.. do you want that feature and volunteer to test it?

thx a lot Hari for implementing it!