Author Topic: mkv no worky after upgrades  (Read 1015 times)

slampt

  • Veteran
  • ***
  • Posts: 102
    • View Profile
mkv no worky after upgrades
« on: December 17, 2010, 01:06:08 pm »
Has anyone else had some media files cease working after the upgrade?
I will do some debugging as to why but after about 2 seconds of playing most HD videos I have seem to just crash now.

Cheers
Slampt

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: mkv no worky after upgrades
« Reply #1 on: February 06, 2011, 06:54:28 pm »
seems like I'm having the same issue (I just noticed today)

I have some mkv containers that worked after the libxine1 update and now they don't.  I have verified the /etc/apt/preferences and sources.list and did the apt-get updates and upgrade, even dist-upgrade and everything seems to be up-to=date; yet some 1080p mkv containers work and some don't and some of the ones that don't work used to work after the libxine update of 2010-07-27 23202.

some will just freeze... at like 6 seconds into the video...

the log files say a bunch of stuff, but there doesn't seem to be a difference between a mkv that works and one that doesn't. so, the same mkv that used to play, no longer plays.  It didn't play before the libxine1 update, then after the update it did ( a few months ago )
and today  I noticed it doesn't anymore ( but it could have started a few weeks ago, I started investigating today).  I haven't really done anything different; except maybe a update now and then when I started playing with asterisk and then again recently when I realized quite a few newly acquired mkv's were not working; thats when I went back today to test older containers that worked fine and turned out not be working.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: mkv no worky after upgrades
« Reply #2 on: February 07, 2011, 11:14:47 pm »
Did you guys try this? Made all MKVs work for me, and I guess you would have to redo it after any updates. Just guessing here mind.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: mkv no worky after upgrades
« Reply #3 on: February 08, 2011, 02:12:21 am »
uh... try what?

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1375
  • If it ain't broke, tweak it
    • View Profile
Re: mkv no worky after upgrades
« Reply #4 on: February 08, 2011, 02:53:53 pm »
Sorry man, you have to press Ctrl + V after you press Ctrl +C don't you! My bad http://wiki.linuxmce.org/index.php/Play_mkv_files
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

daballiemo

  • Guru
  • ****
  • Posts: 244
  • Full Blown Addict
    • View Profile
Re: mkv no worky after upgrades
« Reply #5 on: February 08, 2011, 09:56:42 pm »
Purps,

do you know of another location to get the deb's mentioned in the wiki, it seems that one is down.

rgds

Han
HP N40L12.04 KVM with virt LCME8.10/10.04
MD: FoxConn NetBox 330I - Samsung LE 26 (1360* 768)
MD: M2NPV-VM dual core AMD 64/3800/2Gb/NV6150 - Samsung UE 55 C8700 (full hd, 3d)
MD: FoxConn NetBox 330I - LG 32ld350

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: mkv no worky after upgrades
« Reply #6 on: March 09, 2011, 05:02:37 am »
a recent update to xine fixed every single problem I had playing back mkvs

http://forum.linuxmce.org/index.php?topic=11497.0

just wanted to let anyone know who has had similar problems.

Thanks phenigma