Author Topic: apt-get upgrade = Lock 'pluto.conf' (Config_Ops-ConfEval) stale... etc..  (Read 946 times)

dextaslab81

  • Newbie
  • *
  • Posts: 7
    • View Profile
Hi,
I've tried to do an apt-get upgrade on the core after it had been turned off for 2 weeks and got the following:

Log started: 2011-01-02  02:46:00
(Reading database ... 190822 files and directories currently installed.)
Preparing to replace pluto-orbiter 2.0.0.44.10120523479 (using .../pluto-orbiter_2.0.0.44.10121623525_i386.deb) ...
Unpacking replacement pluto-orbiter ...
Preparing to replace pluto-proxy-orbiter 2.0.0.44.10103123388 (using .../pluto-proxy-orbiter_2.0.0.44.10121623525_i386.deb) ...
Unpacking replacement pluto-proxy-orbiter ...
Preparing to replace pluto-website-admin 2.0.0.44.10120523479 (using .../pluto-website-admin_2.0.0.44.10121623525_i386.deb) ...
Unpacking replacement pluto-website-admin ...
Preparing to replace lmce-shoutcast-radio-plugin 2.0.0.44.09112922522 (using .../lmce-shoutcast-radio-plugin_2.0.0.44.10120823488_i386.deb) ...
Unpacking replacement lmce-shoutcast-radio-plugin ...
Preparing to replace pluto-system-database 2.0.0.44.10120523479 (using .../pluto-system-database_2.0.0.44.10121623525_i386.deb) ...
Unpacking replacement pluto-system-database ...
Setting up pluto-orbiter (2.0.0.44.10121623525) ...
dpkg: error processing pluto-orbiter (--configure):
 subprocess post-installation script returned error exit status 2
Setting up pluto-proxy-orbiter (2.0.0.44.10121623525) ...
Setting up pluto-website-admin (2.0.0.44.10121623525) ...
16153 Sun Jan  2 02:46:21 WST 2011 Lock 'pluto.conf' (Config_Ops-ConfEval) stale. Removing /usr/pluto/locks/pluto.conf (/proc/16145-Config_Ops-ConfEval)
16153 Sun Jan  2 02:46:21 WST 2011 Retrying lock 'pluto.conf' (Config_Ops-ConfEval)
dpkg: error processing pluto-website-admin (--configure):
 subprocess post-installation script returned error exit status 2
=================================================================

Have since narrowed it down to:
/var/lib/dpkg/info/pluto-orbiter.postinst configure
Which returned the locking fault listed above.

Closer inspection shows most of the symlinks in /usr/pluto/locks/ dont point to valid files..??
I've looked around and tried editing the scripts, but it still fails.

Any and all help would be appreciated.

Cheers

dextaslab81

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: apt-get upgrade = Lock 'pluto.conf' (Config_Ops-ConfEval) stale... etc..
« Reply #1 on: January 03, 2011, 09:18:49 am »
Has no one had this issue? i've got this issue with my test 1004 install aswell:
For some reason the lock files in  /usr/pluto/locks/ dont point to the correct (I'm assuming) PID files or for some reason they dont get created in the /proc dir. Atleast I think thats why the script fails.
The core is a 810 build, and it's also stopping other programs from install installing aswell:

Unpacking replacement pluto-boot-scripts ...
19098 Mon Jan  3 14:08:16 WST 2011 Lock 'pluto.conf' (Config_Ops-ConfEval) stale. Removing /usr/pluto/locks/pluto.conf (/proc/18380-Config_Ops-ConfEval)
19098 Mon Jan  3 14:08:16 WST 2011 Retrying lock 'pluto.conf' (Config_Ops-ConfEval)
dpkg: warning - old post-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
19109 Mon Jan  3 14:08:16 WST 2011 Lock 'pluto.conf' (Config_Ops-ConfEval) stale. Removing /usr/pluto/locks/pluto.conf (/proc/19098-Config_Ops-ConfEval)
19109 Mon Jan  3 14:08:16 WST 2011 Retrying lock 'pluto.conf' (Config_Ops-ConfEval)
dpkg: error processing /var/cache/apt/archives/pluto-boot-scripts_2.0.0.44.10122723559_i386.deb (--unpack):
 subprocess new post-removal script returned error exit status 2