Author Topic: MCE 8.10 Network Shares on External Lan ?  (Read 2816 times)


  • Regular Poster
  • **
  • Posts: 16
    • View Profile
MCE 8.10 Network Shares on External Lan ?
« on: December 14, 2010, 05:00:40 pm »
Dose anyone have suggestions as to setting up external lan bridge in order to see network shares?
I just got my 8.10 install up and am starting the process of config.  Hopefully the config will be similar to 710 as far as working well with my equipment. "I have been blessed so far in that regards.. Only slight issues". I never bothered to try to integrate the two networks last time but if I am going to permanently set up this install in my house then I need to address this issue now before I get into peripheral setup.

Just a snapshot of what I currently have

Ubuntu 10.04 lts set up as server
   amd64 install with x86 processor
   dhcp server -- points to cisco vpn router as gateway.
   ssh server                                                                         NETWORK A
   samba server
   cups server
   hdb1 -- dedicated disk for network shares and storage.
   Ltsp server

cisco vpn router & firewall
   Points to cable modem as gateway
   Hooks to wireless g router as access point
   hooks to Motorola routers (2) for clients in house ( ltsp diskless clients and Ubuntu 10 Desktops)

Windows xp box with amd processor
    eth0 to Motorola router
    Has Smarthome 2414u hooked up

Dell Laptop - Ubuntu 10.04 amd64 install with x86 processor

Dell Laptop - Ubuntu 10.04 amd 64 install with x86 Processor  -- connects with SSH vpn through dialup

Linuxmce core/hybrid
    eth0 Hooks to motorola router w/802.11g
    ipod touch for orbiter
    eth1 to network A -- set in autoconfig dhcp
using old dell laptop mainbord for Media director                              NETWORK B

using old gateway mainbord for media dirrector
This is a basic topology of the main components of my setup.. as you can see I have one prevelant issue... LTSP and MCE playing pretty with each other.. As I have in the past messed up my LTSP config by accidentally hooked the wrong cat 6 connect into the wrong router at the attic patch panel while labeling and boom down goes TFT boot. :) ... MCE surprisingly had no ill effect, but the Motorola routers have a weird quirk when it comes to having contact with conflicting Net-masks and you better have a saved config backup or you will be stuck reconfiguring the router from the ground up. It actually took me a while to repair my LTSP configuration... Not sure Why what happened did, other than the conflict was between the 2 DHCP servers running into each other with different net-masks.

I would not be totally opposed to running a NAS server... but then again, my money tree is looking kind of bear these days, and I still would rather have these networks be able to share storage.Uniform Administrative access through SSH is as well a necessity.

peripherals yet to be hooked into MCE system
allinco 10P alarm system
x-10 and insteon controls
pvr card  -------------

I know this will not be a overnighter.... :(

I would allso like to say that I have read deeper into these forums and have got to say that I am no longer frustated with this or the wiki documentation as I really had no Idea that there were so few people involved in the Development side.  YOU GUYS KICK ASS!!!!  This project is a Monsterous undertaking.  I do not think the general lot of the people who are complaining understand that this project IS NOT a Marketed Software package!!! It is a Massive undertaking with amazing potential that there is no comparison to unless you want to spend $10 to $15 THOUSAND US Dollars for a basic version of a supported Whole House Automation Suite... and even those systems only support whatever they have been tailored too.  Most of these systems I describe are directly developed and customized into fairly stable system packages from the same projects that MCE is as well built from. A lot of the software components of the Marketed packages will still be in open-source form despite the fact that you paid for it. 
Have you ever called Microsoft and been told " We do not support that software" or " Hardware "
Same deal.
At least in this system I can save some money and learn something new... and if I just so happen to succeed..... What a system it will be.

I have showed an operational 710 system to many of my friends and relatives and never failed to IMPRESS.


John Middleton

John Middleton


  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MCE 8.10 Network Shares on External Lan ?
« Reply #1 on: December 15, 2010, 02:39:48 pm »
I was doing some of my own research under ubuntu and ltsp forums and wiki and stumbled on this linuxmce wiki.

It claims to adjust samba settings from within Web Admin and setup a new child device for a file server pointing to only a single server...
This actually might work fine for my purpose of my Network media storage... but it dose not help the network transparency for purpose  of intagrating the two networks togeather

#      "The external network does not get scanned for Samba servers."  ... "The good thing about LinuxMCE is, that LinuxMCE routinely scans the internal network for servers, and if found, scans those servers for shares to be mounted and spidered for media. To initiate the scan for shares manually (because of a manually added server) do the following

    * Open a terminal
    * Execute

/usr/pluto/bin/ -d <device-id> -i '<ip-address>' -m '<mac-address>'

This will execute the scan for new shares. The shares will be presented to you on any orbiter. "   #;;

So will this be retained upon a restart of the Server or will it need to automate this upon startup?
Is this process going to be necessary for the purposes of MCE regardless of any network bridging?

If I setup a bridge as so in etc/network/interfaces

     auto br0
              iface br0 inet static
                  netmask                                                       #my network A DHCP is on
                  bridge_ports " ??? will have to get a list of necessary ports"

Will MCE see and recognize shares and services from Network A ??

John Middleton


  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MCE 8.10 Network Shares on External Lan ?
« Reply #2 on: December 15, 2010, 06:11:31 pm »
Update:  Followed the Samba approach and had mixed success. Had errors with command... -d <device_id>  was apparently named incorrectly... Process ran .. had Mount errors.... permission denied... finished ... dcerouter rebooted... and nothing...
While researching what needed to be in place of <device_id>  ... out of the blue,,,  "FOUND WIDOWS SHARE" comes up on the Media Director.... OK....  Never had a F**k up work before... go to manage drives on Media-director... Nothing... Quick reload router... BINGO.....
go back to manage drives, open windows share... Nada.... hmmm possibly a permissions issue... Oh yea.. Now a Windows Share shoes up in my A network as LINUXMCE but am not able to access it.

Update2:  Read this poll
Firewall port settings.... opened port...
Wow .. this seems to have been a touchy subject...
Would have never believed that network subdividing would ever be so political.
I have 2 independent networks that need to share resources and services in the name of preventing redundancy and overall cost of implementation.
I see the need for a home automation system to not be loaded down with competing tasks.
At the same time I have a network dedicated for my business and personal that I do not need a home automation system in...
These 2 networks have successfully ran side by side for near a year now... and I am just upgrading all of my software for both networks..
Network A is already configured and operational after upgrade.
Network B is in beginning stages of configuration.
To not have to duplicate Data is a financial an logistic endeavor
I do agree that completely opening up your system by disabling your firewall is an inherently bad idea... Your firewall is a tool... Use it.
I have subnets all over my A network already and they all work fine...
Would you have an AP guest walking around in your system files when all they needed was INTERNET access?
Or maby you have a office worker that only needs a desktop terminal that is set up for nothing but what they need to see and use?? and the same network is in the same structure...
You see I have 3 independent ethernet systems.. My workers can plug into my LTSP port with their personal laptops and there system PXE boots into the server... I don't have to worry about administering multiple platforms... I don't have Software issues ... I don't have browsing and privilege issues... I don't have people playing solitaire or updating their facebook pages... I don't have to physically touch the devices that are being used as terminals... and I don't even need them to be in the same building (SSH VPN)... And I don't have to worry if my server is going to start adding client resources to my setup. All I have to do is add a new user and bam... it works! The MCE way of handling resources and clients is a more permanent approach and requires setting up each individual device manually. I can just edit and update my LTSP and all my clients behave exactly the same. I have at one time booted 7 laptops at the same time that have never been on my system before and it only took 3 minuets.
I have plenty of Media (some of it backed up from previous MCE (710) install) , and space already on my Network A server...
My Core on network B has only 120 gigs of space available... and I really don't want to have media for either network spread between each other.
Like Thom said in that post  "Why are you people butchering your setups?!"
Well I don't want to butcher a perfectly good LTSP setup that works flawlessly for it's intended design and the two networks will need to share data  that makes no sense to duplicate.  ( 2.8 TB)
yea don't think so.
I am willing to try any suggestions as to how to implement within MCE design intentions...
I see no reason that anyone couldn't run the two networks beside each other and share data.
As far a worrying about windows shares.... I only run one windows box in order to debug compatibility issues with Microsoft Office and Quick books files... Don't really care other than I have a windows mobile device (HTC Touch Pro 2). But it has its own web server set up to access files so I know that works allready.

If you are running a business you will aways have to contend with Data produced from Microsoft Products!! YOU WILL NEVER ESCAPE!!!
But I am a true Linux believer to the core!
Long Winded if you can't tell
But I hope someone can either contribute to or learn from this post!

Update3: Opening firewall and rebooting systems had no effect.. :(
              I believe the problem to be in the Core router setup because I cannot load the mce shares or Vice versa. I cannot bring
              up the Web Admin page from the external network either... I have seen postings about this as well as wiki info so I  will start with the Web Admin issue first and work backwards... hopefully this will revile the misconfiguration in the process.

Update4: Retried my original known error with command
/usr/pluto/bin/ -d <device-id> -i '<ip-address>' -m '<mac-address>

Even though I did not find any docs on the net about use of this command I deducted that since it was in the pluto file system then <device-id> must be the device-id given to the file server child device IE "32" ... well it worked to some degree... Now I still have a
failed w/return code = -13.... AKA Permission denied... I know... Password issue...
Wow.. system trying to access every file... Maybe I need to ^C this thing... but never liked interrupting a process that I am unfamiliar with.
So... I'm sure there is documents as to what Password should be... Just not found it yet.
But ... before this task even finished... "Still going"... I was able to access MCE from external network... Even Web Admin.
I don't think this had to do with the port forwarding options I set in Physical routers... As it would have taken an hour on its own.
I will change the routers back to original settings to see if that actually disrupts it or not... Better to know what actually makes the difference.

ended up rebooting everything
command got Core tty2 stuck in loop !!!
my bad..
Nice to have web admin on External Net.. ;)

I think I am Missing something obvious though.... Everything I have done so far and by trying to follow the MCE documents is different from How I go about setting up my other network... Maybe I am looking at MCE in the wrong context.

Well after reboot... media director went through the process of p&p auto detect and doubled up the listings in the manage drives section. but only has single entries in the core directory tree under web admin.... $h*t.... didn't mean for that to happen... Can Access files from Network A to LMCE but not vise versa... MCE sees shares but cannot access... (permission denied.) (Cannot get share list)

Ok... How do I repair my listings in the manage drives settings so i can try this routine again?

« Last Edit: December 16, 2010, 05:55:01 pm by chemdtn687 »
John Middleton


  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: MCE 8.10 Network Shares on External Lan ?
« Reply #3 on: December 16, 2010, 09:14:36 pm »
Update5: Found the duplicate entries... deleted all file server entries .... started from scratch... corrected password errors... success after reboot.
Played a video.... libdvd issue... I had installed kubuntu_restricted_extras.... hmmm.
Played Audio... works great...
Wait ... got ahead of myself... First I had to remap the shares I wanted from Web Admin...
installed libdvdcss2 videos played :)
ok so everything seems to work flawlessly... Now I have to deconstruct it to see what I did!!!

Wow.... Video playback is Beautiful... 1080p.... UI seems less buggy... works great.. (latest snapshot)
Now I can't seem to get pictures to sync.... try a reboot
Pictures still not syncing... found that Web Admin claims to see on disk but not in database no matter what. That didn't happen with the other files???

Looks like if I had followed the Instructions I originally found more carefully I would have had quicker success... The developers are right... If you do it their way.... IT WORKS!!!
John Middleton