Author Topic: DVB-card triplication in MythTV.  (Read 713 times)

madness

  • Making baby steps
  • Posts: 3
    • View Profile
DVB-card triplication in MythTV.
« on: December 17, 2010, 04:03:53 pm »
Hi, Comrades!  :)

810-snapshot for 05.12.2010
Core/Hybrid with 2 tuners TT-budget S-1500
MD with 2 tuners TT-budget S-1500

Problem:
By some reason, first (1 of 2) DVB-card on each machine duplicates, or even triplicates.
I.e. I see 2 cards in MythTV Setup, but "max recordings" = 3 on FIRST(/dev/dvb/adapter0/frontend0) card, even if i set it to 1, after exiting setup it turns back to 3.

Tried to delete manualy those unexisting tuners directly in sql, but after reload they are here again, under new id numbers.

And it could be OK, it works well, shows and records using all inputs... BUT! System THINKS there are 4 more tuners and it tries to use them for recording TV, causing not even conflicts, but just missing records.

SQL:
Code: newbielink:javascript:void(0); [nonactive]
select cardid, videodevice, hostname from capturecard;

cardid  videodevice     hostname
1       /dev/dvb/adapter0/frontend0     dcerouter
2       /dev/dvb/adapter1/frontend0     dcerouter
3       /dev/dvb/adapter1/frontend0     moon58
4       /dev/dvb/adapter0/frontend0     moon58
73      /dev/dvb/adapter0/frontend0     dcerouter
74      /dev/dvb/adapter0/frontend0     dcerouter
77      /dev/dvb/adapter0/frontend0     moon58
78      /dev/dvb/adapter0/frontend0     moon58

Table "cardinput" has the same strings, with same "cardid" values as "capturecard".
Code: newbielink:javascript:void(0); [nonactive]
select cardid, inputname, displayname from cardinput;

cardid  inputname       displayname
1       DVBInput        a0
2       DVBInput        a1
3       DVBInput        b1
4       DVBInput        b0
73      MPEG2
74      MPEG2
77      MPEG2
78      MPEG2

More detailed export from mythconverg.capturecard:
Code: newbielink:javascript:void(0); [nonactive]
"1";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"dcerouter";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"5500";"9500";"0";"0";"0";"0";"0";"2";"1"
"2";"/dev/dvb/adapter1/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"dcerouter";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"5250";"9250";"0";"0";"0";"0";"0";"3";"1"
"3";"/dev/dvb/adapter1/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"moon58";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"5750";"9750";"0";"0";"0";"0";"0";"5";"1"
"4";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"moon58";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"5500";"9500";"0";"0";"0";"0";"0";"7";"1"
"73";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"MPEG2";NULL;"dcerouter";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"1000";"3000";"0";"0";"0";"0";"0";NULL;"1"
"74";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"dcerouter";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"1000";"3000";"0";"0";"0";"0";"0";NULL;"1"
"77";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"moon58";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"1000";"3000";"0";"0";"0";"0";"0";NULL;"1"
"78";"/dev/dvb/adapter0/frontend0";NULL;NULL;"DVB";"DVBInput";NULL;"moon58";"0";"0";"1";"0";"0";NULL;"0";NULL;"0";"1000";"3000";"0";"0";"0";"0";"0";NULL;"1"

I tried to insert sql-script in the end of MythTVSyncDB.sh, that deletes those cards with cardid>4 from tables, it works, no more exessive tuners, but it causes constant restart of backend and errors in MythTV Plugin log, looks like mythfilldatabase tries to run.

So... Any ideas?  ???