Author Topic: OSD for my TV not centered  (Read 642 times)

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
OSD for my TV not centered
« on: August 06, 2011, 11:25:27 pm »
Hello,

I've done a lot of research and tried a number mod's to change the display settings many times causing X to not start and eventually required to re-install and start over.  In the wizard I have selected 720p as my screen output for my Sony Wega projection tv.  The TV is connected via HDMI out from my Pioneer Elite receiver with an output selection of digital.

OSD for Orbiter is sized correctly, maybe just a touch too large but I've been able to adjust that from the advanced settings.

Like I stated above, I've tried playing with mode lines, but I'm just not the rocket scientest it takes to understand exactly what I'm doing there and have been reading to try and make sense of it.

Its within KDE that everything goes haywire.  The screen is badly off to the left, all of the controls for the environment are off the screen to the bottom, cannot visually see any.


Q:  Is there a way to adjust all this whereby switching between KDE and OSD Orbiter are the same ?  Pic of my screen attached.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: OSD for my TV not centered
« Reply #1 on: August 07, 2011, 06:06:00 am »
this is due to overscan. the only real fix is if your tv has an option to adjust the screen to fit the image (disable overscan). some TVs have this in the aspect ratio manual as "actual pixels," "just scan", etc.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: OSD for my TV not centered
« Reply #2 on: August 13, 2011, 10:27:08 pm »
Some other TV's, like mine, do not have the overscan fix.The way i did it was having the file /etc/pluto/X-PostStart.sh with the folong permission and content:
Permission: -rwxr-xr-x 1 root root 198 2011-08-13 11:38 /etc/pluto/X-PostStart.sh
Content:
#!/bin/bash
nvidia-settings -a "OverscanCompensation[DFP-0]=64"
nvidia-settings -a "SyncToVBlank=1"
nvidia-settings -a "XVideoTextureSyncToVBlank=1"
nvidia-settings -a "XVideoBlitterSyncToVBlank=1"

Not a clean solution, but it was the only way the have the overscan fixed.