Author Topic: FreeNAS not automatically being recognized in LinuxMCE  (Read 761 times)

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
FreeNAS not automatically being recognized in LinuxMCE
« on: December 04, 2010, 10:55:34 pm »
Hi all,

I've read a number of threads discussing the subject and yet still have not figured out how to get this working.  Followed the LinuxMCE Wiki for FreeNAS setting the device up manually.  No problem doing that.  Copied the file structure from my MS Windows desktop to the RAID disks.  My problem:

a.  Each time I try and synch the media from the NAS - I have to go to  /mnt/device/56/public/data/pictures.
b.  when I click the resynchronize button I get the following message in the progress window:

10   12/04/10 13:51:02.262      UpdateMedia::ReadDirectory /mnt/device/56/public/data/pictures <0xb6a486c0>
05   12/04/10 13:51:03.878      Skipped locked folder: /mnt/device/56/public/data/pictures <0xb6a486c0>
10   12/04/10 13:51:03.878      Sync'ing db with directory... <0xb6a486c0>
10   12/04/10 13:51:03.902      DB sync'd with directory! <0xb6a486c0>
10   12/04/10 13:51:03.903      AlarmManager::~AlarmManager start 0x80c4258 <0xb6a486c0>
10   12/04/10 13:51:03.903      AlarmManager::~AlarmManager done 0x80c4258 <0xb6a486c0>



I do not have any security on the NAS and have enabled CIFS/SMB share.  I can access the RAID via all other systems in my home.

When I go to Screen Saver I cannot see the RAID/Share at all

Is there something I'm doing wrong here ?








pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: FreeNAS not automatically being recognized in LinuxMCE
« Reply #1 on: December 05, 2010, 06:35:44 pm »
Hi,

I might be staying something really dumb but the second line is saying Skipped locked folder.

So do you need to change privileges on the NAS using chmod?

Regards

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: FreeNAS not automatically being recognized in LinuxMCE
« Reply #2 on: December 05, 2010, 07:51:27 pm »
Not sure what that is but will look it up and attempt.  I'm now installing 810 latest snapshot to see if I get a different response with the NAS as I had to manually add it in 710.

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: FreeNAS not automatically being recognized in LinuxMCE
« Reply #3 on: December 06, 2010, 03:23:06 am »
Just installed 810, snapshot 23388 and it installed flawlessly.  In addition, it picked up my freenas server and share without requiring "manual" add.  Man I wish I was able to assist with the development cause I really love this system, even through all of the frustrations.

To you who are responsible, great job and keep it up.  Maybe someday I'll be able to help.