Author Topic: New flash 10.2 beta has VDPAU support!  (Read 1161 times)

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
New flash 10.2 beta has VDPAU support!
« on: December 02, 2010, 08:01:19 pm »
What this means is that in the near future, HuluDesktop (ala lmce hulu player) will be able to handle full HD with very low CPU usage and smooth framerates on low end media directors (Atom/Ion boxes for example)

Although full VDPAU support is in the new flash beta, it is not  yet working for Hulu - here is why:
http://www.adobe.com/devnet/flashplayer/articles/stage_video.html
As you can read, there is a  new API spec for the new object which does GPU video decoding, and vendors must update their software before the benefits of the GPU decoding can be leveraged.

YouTube is already updating their video playback to the new API calls. You can read about YouTube's speedy adoption of the new API calls  here:
http://apiblog.youtube.com/2010/12/accelerating-youtube-playback.html


Just wanted to post this, as I'm sure many people will be wondering why they aren't seeing any performance gains if they manually installed the new Flash 10.2 beta manually.  As soon as Hulu  updates their software, we will be in for a big treat!

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: New flash 10.2 beta has VDPAU support!
« Reply #1 on: December 02, 2010, 09:50:40 pm »
Does this news address the problem described here? http://forum.linuxmce.org/index.php?topic=10248.0

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: New flash 10.2 beta has VDPAU support!
« Reply #2 on: December 03, 2010, 04:48:01 pm »
good news indeed for all the hulu and youtube users

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4515
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: New flash 10.2 beta has VDPAU support!
« Reply #3 on: December 06, 2010, 01:45:46 pm »
Does this news address the problem described here? http://forum.linuxmce.org/index.php?topic=10248.0

Cheers,
Matt.

Yes it does...or should at least once sites update their code to support the new API calls.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk