Author Topic: How to install end of life linuxmce and get mythtv working. [Not Solved]  (Read 4336 times)

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
I am trying to install lmce 810 since sept, and came upon the end of life mess.
Even today there are workarounds posted here that do not tell me if the project can be installed on my system.

My info:
2 boxes connected by lan, gigabit switch etc, nothing special.
2 lan cards in core.
At the moment the two boxes see each other, I can create orbiters with laptops, etc.

I cannot get mythtv working, and reading how to install or update this system with workarounds is a moving target.

Even posts today of workarounds are confusing at best to someone familiar with Linux, although not much on 'buntu distros.

I hope I can mark this solved soon. IRC chat help is ok, but people come and go in midstream probably distracted by real life. (How dare they)?

[Note: This is for using core running mythtv as a hybrid, the MD will be worked on later].

I installed from snapshot 23436.
Before running the lmce script, (the shortcut on the desktop), I followed both prompts that popped up, such as some default language install error. (Mine is English so I just clicked it away).

The gear on bottom right of screen said I had a few updates, and I followed that but DID NOT upgrade to 9.04, and I told the nag screen not to ask again.

I am not sure of the sequence I used next, but I made sure I had propitiatory nvidia driver installed for my card, a geforce fx5200 with 128MB memory. [A Media Director will be set up later with  geforce 8600].

At the time of installation, I was not sure if my sources list was correct, but I did see something saying old-releases in the list, so I thought I was getting the proper packages.

Now I can't get Mythtv running. I was able to get the mythtv software to show up in 'computing' and run the service menu setup of Mythtv. Followed defaults, and set up and edited channels to my local analog cable feed.

I have Schedules Direct account, and I have run Mythtv ok on Mythbuntu, Knoppmyth, and PCLinuxOS (long ago, their major upgrade a few years ago broke my working mythtv.) with same hardware.

I got HDhomerun dual tuner set up, ran scans, it locked into my expected unencrypted qam.

The same HDhomerun can be successfully used at any time form any box on the network withits config program viewer, Windows 7 Media Center runs with no issue, and mythbuntu worked fine.

I do not have any of that stuff on line when working on this lmce install.

So now I await help in assuring I have an install with the correct packages before blaming the Mythtv plugin.
 
Where do I start? Sources list? Apt-get? Synaptic? (Which shows interesting mythtv packages not installed).

Thanks












jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #1 on: November 28, 2010, 05:55:00 pm »
I will post the steps I am taking while waiting for response:

(I will come back and edit this post window)

History to my first post above:

0. Prepared hard drive: Divided 330GB drive in two, making a NTFS partition, and leaving swap part and PCLinuxOS installed (Later, LinuxMCE would wipe out the Linux dual boot I was planning on).

1. Installed the snapshot DVD, using manual partition choice, I gave it SDA1, and the swap.

2. Updated the install by the prompts on the gear Icon, bottom right, except for 9.04 upgrade.
* This may have been a mistake, later I read 'open a term and type apt-get update, apt-get upgrade'.

3. I do not believe I immediately installed the nvidia proprietary driver.  I had problems with this in my first install in Sept.

4. Then I ran the LinuxMCE install script from the shortcut on the desktop. This took a good chunk of an hour, and the term said it was ok to reboot.
[Here I made a Clonezilla copy to the 2nd drive partition I made just for this purpose]

5. I followed Sarah's wizard process, without any peripherals, and without asking to setup mythtv media, I was just working on the house setup, which was going ok.

6. Sometime in that process, I noticed mythtv stuff being downloaded as per the activity popup.

7. I went away for some time before coming back to setup media part with Sarah.

8. I went through the media-mythtv selection, and I was prompted for my location, which popped up correctly, my provider, Schedules Direct user and password, and apparently finished.

9. Later, after letting it settle down, I went into the Mythtv service menu as I call it from my ISF days, and left most everything at default except of course when it needed my details.

10 . I selected my HDHomerun tuner, which the system saw, its ip and serial etc for the two tuners.

11. I ran through the channel setup, the tuner locking in ok to the expected analog channels on my cable.
Then I edited the channels properly and made sure the starting channel was a valid number.

12. I never saw any prompt regarding mythfilldatabase, So I opened a term and ran sudo mythfilldatabase, which took around a half hour, and looked like it was downloading my schedule ok.

13. Later I tried to run Mythtv on the hybrid and failed, mostly myth could not find backend, mythfilldatabase, backend is having trouble, reset? and the like.

14. Believing I only had a few loose ends in Mythtv to set up, I ran the /usr/pluto/bin/Create_DisklessTBZ.sh and waited the eternity.

15. Connected the main MD (living room or dragon box as I refer to it), and allowed it to boot with PXE, as it had done ok in previous install.

16. It promped it was doing diskless install, and I let it run.

17. I tried some mythtv access, but it would go to dark green screen with just mouse pointer, and other failures, so I Clonezilla'd it at this point to avoid running diskless hours of setup.

18. I just read about using apt-get in a term, and running apt-get update, I get all manner of failed to fetch...

This is a link I also noticed it was just posted today in the 'Installation' thread, it is not easy to figure what to do:http://wiki.linuxmce.org/index.php/Installing_0810.
As I mention above, running the apt-get update fails with failed to fetch, etc again my snapshot 23436.

19. 1:09p est This is my list, is it ok, or what is to be done?
deb file:/usr/pluto/deb-cache/ ./  
deb http://us.archive.ubuntu.com/ubuntu/ intrepid  main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ intrepid  main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ intrepid-updates  main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ intrepid-updates  main restricted universe multiverse
deb http://deb.linuxmce.org/ubuntu/ intrepid  beta2
deb http://debian.slimdevices.com/ stable  main
deb http://packages.medibuntu.org/ intrepid  free non-free
deb http://old-releases.ubuntu.com/ubuntu/ intrepid  main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ intrepid-security  main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ intrepid-security  main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ intrepid  main universe multiverse
deb http://deb.linuxmce.org/ubuntu/ 20dev_ubuntu  main
« Last Edit: November 28, 2010, 07:15:03 pm by jh15 »

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #2 on: November 28, 2010, 07:18:29 pm »
QUOTE: The snapshots are the bleeding edge and most of the time are up-to-par with svn. However, the repo does not always contain the latest, but only gets updated after a period of activity and testing using the snapshots.

To see what packages are in the pipe to be updated in the repo, one can look at http://wiki.linuxmce.org/index.php/LinuxMCE-0810_beta#Upcoming_fixes...END QUOTE

I take this to read that if you use a new snapshot, doing the apt-get update, apt-get upgrade may load an older inferior set of packages to the snapshot just installed.

But in the same post he says to refer to a link that does just that.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3669
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #3 on: November 28, 2010, 08:50:30 pm »
apt-get upgrade does not downgrade if not explicitly told to do so.

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #4 on: November 28, 2010, 10:18:07 pm »
Thanks for the reply.

Is my sources list correct? and if so why do I get errors in the term during apt-get update.?

404 and "failed to fetch mostly.


mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #5 on: November 28, 2010, 11:42:12 pm »
No not yet.  All instances of archive, us.archive, or security need to be changed to old-releases.  You still have us.archive or security in some or your lines in sources.list.  You may have to manually install the latest nvidia driver if it is not picked up during the install.  The version in the hardware applet should be 195.  Out of curiosity I tried a newer snapshot and the proper nvidia driver was not downloaded and installed.  Good luck.

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #6 on: November 29, 2010, 12:02:47 am »
Could you give an example?

Do I add old-releases to each line?

right after the http:// for all of them? Or just the ones you mentioned?
Like this?

deb http://OLD-RELEASES.security.ubuntu.com/ubuntu/ intrepid-security  main restricted universe multiverse

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #7 on: November 29, 2010, 02:38:37 am »
There are several posts that discuss this already. 
I found this in a thread that you have already participated in.  This is a working sources.list file that came from that thread and a good example for you to follow:

deb file:/usr/pluto/deb-cache/ ./
deb http://old-releases.ubuntu.com/ubuntu/ intrepid  main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid  main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intepid-updates  main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-updates  main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intrepid-security  main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-security  main restricted universe multiverse
deb http://deb.linuxmce.org/ubuntu/ intrepid  beta2
deb http://debian.slimdevices.com/ stable  main
deb http://packages.medibuntu.org/ intrepid  free non-free
deb http://deb.linuxmce.org/ubuntu/ 20dev_ubuntu  main
deb http://deb.linuxmce.org/ubuntu/ replacements_debian  main

It was found in this post
http://forum.linuxmce.org/index.php?topic=10917.30

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #8 on: November 29, 2010, 03:20:45 am »
I had no idea where that guy ended up at the time of my question.
I also did not want to hijack someone else's thread.

Also, when I remove the 'not' from my subject, my path might help others.'

I can't imagine a beginner trying to find this info from the present wiki.

Thank you, I'll put this in my etc/apt folder and report back.

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #9 on: November 29, 2010, 08:46:43 pm »
jh15 i'm perplexed, i thought we had told you about the old-releases several times, sorry we didn't catch that in the irc.

Hope it's working now for you,

Richard

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #10 on: November 29, 2010, 09:07:26 pm »
I had no idea where that guy ended up at the time of my question.
I also did not want to hijack someone else's thread.

Also, when I remove the 'not' from my subject, my path might help others.'

I can't imagine a beginner trying to find this info from the present wiki.

Thank you, I'll put this in my etc/apt folder and report back.

If I appeared to be stern it was not my intention.  I understand what it means to be new to linux let alone linuxmce.  It will take some time but if you stick with linux it will get easier.  It is especially tough if you are coming from a stricly Windows world where everything is pretty much done for you.  I have been messing with linux for years and am just now feeling comfortable enough with it to start migrating some of my windoze boxes to Ubuntu.

jh15

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #11 on: November 30, 2010, 03:28:19 am »
Sternness accepted, but I do take offence about coming from a strictly windows world.
Your mother wears army boots.

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: How to install end of life linuxmce and get mythtv working. [Not Solved]
« Reply #12 on: November 30, 2010, 12:12:10 pm »
Sternness accepted, but I do take offence about coming from a strictly windows world.
Your mother wears army boots.

How did you know she wore army boots?  You knew my mom?
<look of nostalgic thoughfulnes> Mom could sure put a spit shine to those boots too.