Author Topic: Mythtv plays hdpvr content perfectly, but LMCE plays it with no sound  (Read 1244 times)


  • Veteran
  • ***
  • Posts: 82
    • View Profile
I got the Hauppauge hdpvr ID 4903 to load in LMCE by tweaking the hdpvr driver to recognize the ID (waiting to see if the next update from developers fixes this detection issue of this ID before posting a how to).

Overall,  the hdpvr functions extremely well when recorded material is played from the mythtv frontend. The problem is when I select the same file to play from the orbiter under media video (the files are being written to /home/public/data/pvr and LMCE is picking them up in that directory.) The file plays with the same image quality but there is no sound. I'm using VDPAU and S/PDIF from the motherboard to a receiver. I have followed the various posts in this forum and the wiki and tried the variations in the web admin for the media director, but this doesn't seem to be the problem. MY DVD, audio files, and live TV streamed through the HDPVR are all fine when selected from the orbiter--it is just the recorded h264 which is transcoded to a mpg file by mythtv that will not play back sound.

Since mythtv uses its own player for playback, I'm starting to think that Xine in LMCE does not have the right drivers loaded and perhaps I need to patch or update Xine. I also saw a post that mplayer is capable of playing blu ray decoded disks with some tweaking so I am wondering if I should focus on this as a better alternative for playing back these files.

If anyone could shed some light on what might be going on here and how to approach the problem I would be very grateful. Thanks in advance.


  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Mythtv plays hdpvr content perfectly, but LinuxMCE plays it with no sound
« Reply #1 on: November 30, 2010, 11:18:37 am »
There is definitely an issue here, and it has to do with the v4l2-ctl calls in, and possibly some interesting  foobage in Xine Player... This needs to be investigated a bit more.



  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: Mythtv plays hdpvr content perfectly, but LinuxMCE plays it with no sound
« Reply #2 on: November 30, 2010, 11:42:30 am »
I also have this issue but using the Nova-TD-500. Everything works fine except the sound on TV recordings when played via orbiter video section.

From memory there was nothing much in the logs that I could tell but this was at least 6 months ago when last tried it. Can do some more testing if that would be of any use?