Author Topic: squeezeslave and USB DAC  (Read 1852 times)

coley

  • Guru
  • ****
  • Posts: 465
    • View Profile
squeezeslave and USB DAC
« on: November 12, 2010, 01:51:34 pm »
I've just ordered a Topping TP30 USB DAC Class T Amplifier from ebay. They use a PCM2704 chip so should play nice with ALSA.
Hoping to use this to drive some ceiling speakers with squeezeslave from the core.
Anyone else used one of these with LinuxMCE?

-Coley.

buckle

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: squeezeslave and USB DAC
« Reply #1 on: November 12, 2010, 09:22:45 pm »
Anyone else used one of these with LinuxMCE?

No, but I'm looking forward to hear your results.  I have some ceiling speakers that I just installed and still need a permanent solution for (temp. using an old car audio amp and usb audio adapter).  Also, I'm looking to add more rooms into the mix.

Let us know how it works out for you.

EDIT:  I was also thinking of diy'ing something with these: http://www.parts-express.com/pe/showdetl.cfm?Partnumber=300-385 and running multiple units off of one efficient power supply.
« Last Edit: November 12, 2010, 10:08:44 pm by buckle »

ggmce

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: squeezeslave and USB DAC
« Reply #2 on: November 12, 2010, 11:50:16 pm »
I've been looking at something like this to power each audio zone from a central wiring closet since I have all my speaker wires running back to where the Hybrid/Core will be. My thought was to have the audio from each MD travel back to the wiring closet via coax and then feed that input to an amp to power the speakers (I know this is a round-about way to do it, but speaker wiring was already run that way). Curious to see how this works for you....

coley

  • Guru
  • ****
  • Posts: 465
    • View Profile
Re: squeezeslave and USB DAC
« Reply #3 on: November 18, 2010, 02:24:28 pm »
This arrived yesterday :)
Plugged it in and nada, a quick peek in dmesg and saw usb symbol disagreements :(
poked around checking alsa versions etc, still no sound card.
I'm remote from the box at the mo so did a quick restart and woohoo its picked up this time round
Code: [Select]
!!Soundcards recognised by ALSA
!!-----------------------------

 0 [default        ]: USB-Audio - USB Audio DAC   
                      Burr-Brown from TI               USB Audio DAC    at usb-0000:00:02.0-1, full s
Won't get to check sound out till later.

-Coley.

buckle

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: squeezeslave and USB DAC
« Reply #4 on: November 18, 2010, 04:40:39 pm »
Looks promising.

coley

  • Guru
  • ****
  • Posts: 465
    • View Profile
Re: squeezeslave and USB DAC
« Reply #5 on: November 19, 2010, 01:51:21 pm »
Trying device zero I get this
Code: [Select]
Expression 'snd_pcm_prepare( stream->playback.pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2069
Expression 'AlsaStart( stream, 0 )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3282
Expression 'snd_pcm_drop( stream->playback.pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2191
More digging required, might step back and get it up and running with aplay first.

-Coley.

Don't know what caused this error - seems to be working correctly now. Maybe it depended on the type of stream I fed it.
Ceiling speakers singing to me now :)
« Last Edit: November 19, 2010, 09:34:59 pm by coley »

buckle

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: squeezeslave and USB DAC
« Reply #6 on: November 19, 2010, 10:30:18 pm »
I get "Expression failed" just by listing the outputs on my machine.
Code: [Select]
dcerouter_1:~# squeezeslave -L
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Output devices:

So, I'm not sure that is specific to the output device. 

optimus

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: squeezeslave and USB DAC
« Reply #7 on: November 20, 2010, 08:32:12 am »
i wasn't check it but i have copied it and try it later when i am free and then tell you about it.......

coley

  • Guru
  • ****
  • Posts: 465
    • View Profile
Re: squeezeslave and USB DAC
« Reply #8 on: November 20, 2010, 10:37:57 am »
I get "Expression failed" just by listing the outputs on my machine.
Code: [Select]
dcerouter_1:~# squeezeslave -L
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Output devices:

So, I'm not sure that is specific to the output device. 

did you sudo first before you tried?
-Coley.

coley

  • Guru
  • ****
  • Posts: 465
    • View Profile
Re: squeezeslave and USB DAC
« Reply #9 on: November 24, 2010, 06:07:57 pm »
added wiki entry
http://wiki.linuxmce.org/index.php/TP30
working well so far. :D

-Coley.

buckle

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: squeezeslave and USB DAC
« Reply #10 on: November 28, 2010, 03:19:55 pm »
I get "Expression failed" just by listing the outputs on my machine.
Code: [Select]
dcerouter_1:~# squeezeslave -L
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams, &lowLatency )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 421
Output devices:

So, I'm not sure that is specific to the output device. 

did you sudo first before you tried?
-Coley.

I get this as root.  It still works fine, though.