Author Topic: Greetings to all, back from exile!!! help wanted  (Read 1158 times)

Newguy2

  • Veteran
  • ***
  • Posts: 110
    • View Profile
Greetings to all, back from exile!!! help wanted
« on: November 11, 2010, 04:03:28 pm »
Good day to all, i was forced into linuxmce exile and i'm back trying to get my system back up and running from the latest snapshot. I've been reading up on all the changes and let me say thanks to all who have contributed to this project. good work guys. I have the core setup ok, other than the source list list issues which i somewhat resolved with this post:

http://forum.linuxmce.org/index.php?topic=10917.0.
 i was having trouble with the MD script /usr/pluto/bin/Diskless_CreateTBZ.sh before changing the source list. it would loop with the common crt-c request.  anyway, now now it gets to the point where the md script ends with a "Password for root on localhost?" request.  i'm not sure what the issue is, can someone help an old lmce junky out, i've been going through withdrawal symptoms lol.

Newguy2

  • Veteran
  • ***
  • Posts: 110
    • View Profile
Re: Greetings to all, back from exile!!! help wanted
« Reply #1 on: November 11, 2010, 10:59:25 pm »
Access denied for user 'root'@'localhost' (using password: YES)
« Last Edit: November 15, 2010, 07:26:59 am by Newguy2 »

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Greetings to all, back from exile!!! help wanted
« Reply #2 on: November 12, 2010, 07:08:42 am »
there should be no password set for the mysql root user

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Greetings to all, back from exile!!! help wanted
« Reply #3 on: November 12, 2010, 04:34:35 pm »
Thank you for giving us all the password to your box though. ;)

-Thom

chrysemys

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Greetings to all, back from exile!!! help wanted
« Reply #4 on: November 13, 2010, 01:33:20 pm »
I 've got a similar problem at installing:

Setting up pluto-database-settings (2.0.0.44.09112922522) ...                                                                                               
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

I tried to unset the password:
*****************************
[root@mce-core]E_install/new-installer>mysql -u root -p                                                                                   
Enter password:                                                                                                                                             
Welcome to the MySQL monitor.  Commands end with ; or \g.                                                                                                   
Your MySQL connection id is 113                                                                                                                             
Server version: 5.0.67-0ubuntu6.1 (Ubuntu)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> update user set password = '' where user = 'root' and host = 'localhost';
uery OK, 0 rows affected (0.00 sec)
Rows matched: 1  Changed: 0  Warnings: 0

mysql> select Host, User, Password from user ;
+------------------+------------------+-------------------------------------------+
| Host             | User             | Password                                  |
+------------------+------------------+-------------------------------------------+
| localhost        | root             |                                           |
| mce-core       | root             |                                           |
| 127.0.0.1       | root             |                                           |
| localhost        |                    |                                           |
| mce-core       |                    |                                           |
| localhost        | debian-sys-maint | *F610B9CF0BD777D6B52C1D5639E503D894265680 |
| localhost        | zmuser           | *C1D2D6FC5C596AFB19FFC4331DF6DAA287749A3E |
+------------------+------------------+-------------------------------------------+
7 rows in set (0.00 sec)

mysql>
******************
but I still get this password problem, any quickfix please?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Greetings to all, back from exile!!! help wanted
« Reply #5 on: November 14, 2010, 04:24:59 pm »
I 've got a similar problem at installing:

Setting up pluto-database-settings (2.0.0.44.09112922522) ...                                                                                               
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

I tried to unset the password:
*****************************
[root@mce-core]E_install/new-installer>mysql -u root -p                                                                                   
Enter password:                                                                                                                                             
Welcome to the MySQL monitor.  Commands end with ; or \g.                                                                                                   
Your MySQL connection id is 113                                                                                                                             
Server version: 5.0.67-0ubuntu6.1 (Ubuntu)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> update user set password = '' where user = 'root' and host = 'localhost';
uery OK, 0 rows affected (0.00 sec)
Rows matched: 1  Changed: 0  Warnings: 0

mysql> select Host, User, Password from user ;
+------------------+------------------+-------------------------------------------+
| Host             | User             | Password                                  |
+------------------+------------------+-------------------------------------------+
| localhost        | root             |                                           |
| mce-core       | root             |                                           |
| 127.0.0.1       | root             |                                           |
| localhost        |                    |                                           |
| mce-core       |                    |                                           |
| localhost        | debian-sys-maint | *F610B9CF0BD777D6B52C1D5639E503D894265680 |
| localhost        | zmuser           | *C1D2D6FC5C596AFB19FFC4331DF6DAA287749A3E |
+------------------+------------------+-------------------------------------------+
7 rows in set (0.00 sec)

mysql>
******************
but I still get this password problem, any quickfix please?

This seems to be missing:
Code: [Select]
mysql> FLUSH PRIVILEGES;
"Change is inevitable. Progress is optional."
-- Anonymous