Author Topic: LIRC_DCE problem after apt-get upgrade  (Read 732 times)

cfernandes

  • Guru
  • ****
  • Posts: 290
    • View Profile
    • my company web site
LIRC_DCE problem after apt-get upgrade
« on: October 10, 2010, 04:16:53 pm »
After i do apt-get upgrade

my mce_usb not work and on pluto.log i have this message

"1       10/10/10 11:13:43       147 (spawning-device)   Found /usr/pluto/bin/LIRC_DCE
3       10/10/10 11:13:43       147 (spawning-device)   Device died... count=4/50 dev=147
"
i try to load manualy LIRC_DCE and i found this message


 /usr/pluto/bin/LIRC_DCE
/usr/pluto/bin/LIRC_DCE: error while loading shared libraries: libMessageTranslation.so: cannot open shared object file: No such file or directory


so anyone can help me ?

sambuca

  • Guru
  • ****
  • Posts: 447
    • View Profile
Re: LIRC_DCE problem after apt-get upgrade
« Reply #1 on: October 10, 2010, 09:27:37 pm »
There is a missing dependency in the LIRC package after some changes in the last update. For now you can manually install the pluto-messagetrans package on the MD in question.

br,
sambuca

cfernandes

  • Guru
  • ****
  • Posts: 290
    • View Profile
    • my company web site
Re: LIRC_DCE problem after apt-get upgrade
« Reply #2 on: October 10, 2010, 09:51:42 pm »
Thank you Sambuca ,

i need to install pluto-irbase too .

sambuca

  • Guru
  • ****
  • Posts: 447
    • View Profile
Re: LIRC_DCE problem after apt-get upgrade
« Reply #3 on: October 12, 2010, 02:18:00 pm »
Thank you for finding and reporting the issue, it should be fixed in the next update. In the meantime, you can install the two packages manually to resolve it.

best regards,
sambuca

DEMNVT

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: LIRC_DCE problem after apt-get upgrade
« Reply #4 on: October 12, 2010, 03:00:02 pm »
Thanks sambuca, that worked for me too. My mce_usb2 (Windows MCE Remote) stopped functioning after the upgrade. Ran:

sudo apt-get install pluto-messagetrans

and

sudo apt-get install pluto-irbase

and then rebooted the core/hybrid and all is well again. :)