Author Topic: First diskless MD boot  (Read 1206 times)

ThinkCentre

  • Regular Poster
  • **
  • Posts: 32
    • View Profile
First diskless MD boot
« on: October 06, 2010, 11:07:36 am »
Hi all.

I just installed a LMCE core and attempted to network boot a MD. I still havn’t got one to work. Here’s a few issues I’ve encountered.

1.You need to run /usr/pluto/bin/Diskless_CreateTBZ.sh I couldn’t run it under the command line interface, I had to do it through Bash on the KDE desktop.

2.Although there is loads of information detailing network settings they are based on a 2 network card configuration. There is no space in my PC for a second card. I have a fantastic integrated modem/wireless router that from what I understand doesn’t fit well with the duel network card theory. The following is the way I’m currently preparing my system for a network boot.

On the Core
Advanced >> Network Settings >> Use DHCP
Computing >>Web Admin >> Advanced >> Network >> Network Settings >>
   a.Check Enable DHCP Server Proxies 192.168.80.1 to 192.168.80.128
   b.Check Provide IP addresses for anonymous devices not in Pluto Database 192.168.80.129 to 192.168.80.254
   c.Choose “Obtain an IP address from DHCP server”
On the router
DHCP settings >> Turn DHCP off >> Save and reboot
On the MD (Windows) Apparently with this configuration MD’s need static IP’s??
Plug in LAN cable. Right click on the LAN connection, select Properties >> Select Internet Protocol Version 4, click Properties >> Choose “Use the following IP Address
-IP: 192.168.1.101
-Subnet Mask: 225.225.225.0
-Default Gateway: 192.168.1.1

And “Use the following DNS server address
-Preferred DNS: 192.168.1.1
-Alternate DNS: XXX.XXX.XX.XX (this is from my ISP)

At startup ensure BIOS is set to Network boot first preference


3.On first attempt at network boot I got the error
“Trying to load pxelinux.cfg/default
Kernel panic – Not syncing. Attempted to kill init”

It appears that I can solve that problem by going into /tftpboot/pxelinux.cfg and editing the default boot script to remove acpi=off.

4.I now get stuck at the following error-
Ipconfig: no devices to configure
/init: .: line 1: can’t open /tmp/net-eth0.conf
[4.193551 Kernel panic – not syncing: Attempted to kill init”

Judging from the post by bombastic here http://ubuntuforums.org/showthread.php?t=975417 there is a fairly long solution requiring a static IP to be set in pxelinux.cfg/default. I have not attempted this yet.

So it’s a work in progress! Make any comments or suggestions you like, I am open to all advice!

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: First diskless MD boot
« Reply #1 on: October 06, 2010, 11:50:51 am »
Get a USB NIC

ThinkCentre

  • Regular Poster
  • **
  • Posts: 32
    • View Profile
Re: First diskless MD boot
« Reply #2 on: October 06, 2010, 12:46:14 pm »
Thanks for the advice!

I am able to install a second NIC if required,one reason I want to avoid it is that I already have far too many pieces of equipment hanging out of usb ports and hope to avoid more as much as possible as it sits below my TV. Also, is the dual NIC concept still applicable to current systems and technology? It seems that the original topology was designed before integrated router/wifi modems were mainstream, I say this because the WIKI describes an "existing home network" as a modem connected to a switch connected to ethernet devices and a wireless access point.

There appear to be a large number of people with single NIC's running successfully, is there still an issue with the setup instructions I followed? The core is the only DHCP on the network. If a single NIC is enough, is there a need to go further?

I'm only just getting my head around things so I hope I'm not too far off track.

The problem that i'm currently experiencing seems perhaps related to the driver for the MD's NIC? http://forum.linuxmce.org/index.php?topic=6247.15

ThinkCentre

  • Regular Poster
  • **
  • Posts: 32
    • View Profile
Re: First diskless MD boot
« Reply #3 on: October 07, 2010, 02:39:19 pm »
Ok so I’ve tried the network boot on my brother’s Gateway Netbook (ZA8) and SUCCESS!! A couple of issues are that when I use the touchpad LMCE thinks i'm also pressing the number 1 button and MythTV appears for a second then crashes, but otherwise it generally works.

So why won't my laptop work? There are 2 main differences between his laptop and mine. Firstly the network cards, I have an Intel 82577LM Gigabit card, he has “Realtek PCI Express Fast Internet Controller series 1.15..”. The second is that I have my IPV4 settings giving a static IP but his is provided by the DHCP. Just tried with a DHCP allocated IP too but still no dice.

It also seems that with the 1 NIC, and disabling DHCP in the router, I can no longer access the internet, the router does not appear on the network anymore.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: First diskless MD boot
« Reply #4 on: October 07, 2010, 03:48:56 pm »
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1031
    • View Profile
Re: First diskless MD boot
« Reply #5 on: October 07, 2010, 04:52:17 pm »
Ok so I’ve tried the network boot on my brother’s Gateway Netbook (ZA8) and SUCCESS!! A couple of issues are that when I use the touchpad LinuxMCE thinks i'm also pressing the number 1 button and MythTV appears for a second then crashes, but otherwise it generally works.

In the orbiter settings of webadmin under advanced there is a setting for 'ignore first press' or 'ignore first event' or something similar and I believe that may alleviate the '1' button issue...  Been a while, and I don't have a touchscreen MD, so I'm not certain if this will fix your issue. 

J.