Author Topic: Can't delete entries from "Respond to Events"  (Read 1168 times)

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Can't delete entries from "Respond to Events"
« on: September 27, 2010, 07:36:08 pm »
I have read this http://forum.linuxmce.org/index.php?topic=5943.0 but really don't want to try it for fear of f**king everything up (plus it's a relatively old thread). If anybody could tell me a reasonably safe method of deleting this events, I would very much appreciate it.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #1 on: September 27, 2010, 09:16:50 pm »
HI,

Did you try and delete it?
I just did delete one of my "Respond to events" just to see if it does delete. And after pressing the delete button, the screen refreshed and it was gone.

The snapshot I'm using is somewhere in May..... cant remember exactly which one.

Karel

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #2 on: September 28, 2010, 02:15:52 pm »
I have exactly the same problem as per the link in my initial post i.e. I click delete, press OK, and nothing happens.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #3 on: October 13, 2010, 11:33:58 am »
Awfully sorry to bump this, but I don't know what to do about it.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #4 on: October 13, 2010, 01:44:17 pm »
Hi Purps,

What snapshot are u using, because ur installation seems different then mine.
I can delete events, but u can't.

And If I can remind u...... my WiiMote is working but urs didnt.......

http://forum.linuxmce.org/index.php?topic=7873.15

Maybe its the snapshot that you have installed thats giving you issues?

Karel

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #5 on: October 14, 2010, 10:39:14 am »
I'm on snapshot 23165. The link in my original post refers to the exact same problem I have, I just don't want to screw everything up poking around in things I don't understand.

Yep, still have wiiMote issues i.e. it's not working. Everything seems to install fine, but the wiiMote just doesn't connect at the final stage. I've tried 3 BT dongles, so it's unlikely that is the problem. 2 out of the 3 recognise the remote and give me the MAC address.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #6 on: December 03, 2010, 12:21:27 am »
Same problem with snapshot 23388 - cannot delete Respond to Events.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #7 on: December 03, 2010, 12:49:27 am »
I just took a peek at the source - it has not been modified in 9 months, so it can't be related to any recent code changes.
Also, all the deletion code is local to the file, so changes to an external file wouldn't cause this either.

When you delete the event from the Respond To Events screen, do you get a message at the top of the page: "You are not authorized to modify installation."?  If not, do you get the message: "The event handler was deleted."?  This would help in troubleshooting.


Also, does it delete correctly if you go to Advanced->Configuration->Events and use the delete from there?

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #8 on: December 03, 2010, 02:33:54 am »
This will sound off the wall but try to turn off pop up blocker.  Also you might try deleting from firefox if you are not using it already.  I don't know if this will take care of your problem but I have seen an active pop up blocker not allow things to complete and some things will look/act different in firefox.  When deleting an item a couple of windows will try to open.  One of which is a box that tells you that an item has been deleted and to click ok.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #9 on: December 03, 2010, 11:31:41 am »
You click delete, and it asks "Are you sure you want to delete this event?", you click "OK", and that's it - it just doesn't disappear. Exactly the same story for doing it through Advanced->Configuration->Events.

I've tried this in Firefox, Konqueror and Chrome. I'm on Chrome now, but I will try turning off the pop-up blocker on Firefox this evening.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #10 on: December 03, 2010, 01:34:08 pm »
yes I understand but after you say ok delete it then two other windows will try to open.  The popup blocker usually catches those.  But as I said I don't know if this is the case in all instances.  Sorry if this did not help.

I just had another thought.  There may be some corruption in the database(just a guess on my part).  It may be interesting to do a tail -f on the mysql log while you are trying to delete an entry to see if any errors occur.  I am not sure what you will see since I know almost nothing about mysql(other than what I have read lately) but it could be worthwhile.
« Last Edit: December 03, 2010, 01:40:50 pm by mythtified »

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1371
  • If it ain't broke, tweak it
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #11 on: December 03, 2010, 03:28:33 pm »
yes I understand but after you say ok delete it then two other windows will try to open.  The popup blocker usually catches those.  But as I said I don't know if this is the case in all instances.  Sorry if this did not help.

I just had another thought.  There may be some corruption in the database(just a guess on my part).  It may be interesting to do a tail -f on the mysql log while you are trying to delete an entry to see if any errors occur.  I am not sure what you will see since I know almost nothing about mysql(other than what I have read lately) but it could be worthwhile.

Ahh OK, I see what you mean now. Will try it tonight with Firefox with popup blocker switched off.

Will try tail -f ing the hell out of it as well.

Does this help diagnose the problem? Doesn't mean much to me http://forum.linuxmce.org/index.php?topic=5943.0

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: Can't delete entries from "Respond to Events"
« Reply #12 on: December 03, 2010, 03:42:02 pm »
I am not sure.  I have read about some of what is talked about but have not actually put it into practice, so playing directly with sql commands on an active system would scare hell out of me.  I am not even sure if finding the mysql log and watching it as you try to delete from the admin page would yield results that could be used.  I would think that if there was a major problem that the present sql log level would be sufficient.  I do think that turning off your pop up blocker will help.  If it does work you may try fine tuning it by turning it back on and adding an exception to allow it to allow popups from your lmce machine.  I have not had the issue of not being able to delete things from the admin page for some time but I think I did turn off the pop up blocker and things started working.  I also noticed that things look different and act different between firefox and explorer.  So I pretty much use firefox when using a windoze machine to look at lmce through the admin page.