Author Topic: AV connections not being controlled - still problems with IR control  (Read 622 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Hia,
my audio setup is using a Yamaha DSP-A1 and a Roku SoundBridge, both being controlled by LinuxMCE, via IR.
As the SoundBridge is not being controlled by slimserver-plugin (it does not work for SoundBridge), i created a new template called SoundBridge IR, and entered all the discrete codes to control it, and defined as CD Players/Recorders (for having an OSD menu). All codes where tested under A/V Properties and all works.
Next, if defined, thru connection wizard the output of SoundBridge to input of the DSP-A1.
The orbiter is using the UI2.
MD is using input LD and SoundBridge is using input CD of the DSP-A1.
TV, Audio and Video works well selecting the LD input via IR.
Problems:
1) OSD Media Scenario -> select SoundBridge - DSP-A1 input CD is selected (takes around 10 seconds), OSD screen shows nothing (menu disapears), and it plays.
But when the menu key is hit, for any reason (KDE desktop or security or any other), the OSD main menu appears and and the DSP-A1 changes it's input to LD. The way to continue listening to the SoundBridge is selecting the CD menu and Resend A/V codes and selecting CD at the DSP-A1 row. After i do that, i can keep listening to the SoundBridge and scroll the presets.
2) OSD -> Power -> OFF [display] [soundbridge ir]. Selecting display, the DSP-A1 turns off, but the SoundBridge does not. Selecting soundbridge ir, nothing happens. It simply does not turns off, but under webadmin -> A/V Equipment -> A/V Properties, it works.
Questions:
1) How can i make it work? Selecting SoundBridge from the OSD, having it change and MAINTAIN the input source, even if browsing the OSD menu?
2) Is there a better CD OSD Menu?
3) How to have it turn off when changing the media, going to audio, video, TV, etc?
TIA,
Paulo

BTW, someone knows how to create discrete codes from the codes supplied by the manufacturer? I do have the Yamaha codes for the individual DSP modes and would like to have it converted to discrete.


UPDATE: Question 3 - solved after a full reboot of the system. Go figure  ???
             Questions 1 and 2 not solved.


« Last Edit: September 16, 2010, 01:30:38 pm by pw44 »

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: AV connections not being controlled - still problems with IR control
« Reply #1 on: September 13, 2010, 07:29:35 pm »
With regard to Question 3)

You may want to check each device in the 'device info' section there is a line 'Ignore On/Off' then radio buttons for On or Off.  I use this feature to stop my Reciever being turned off when ever media (TV/Video/Audio) stops playing playing.  You may want to check if the Soundbridge Has 'Ignore On/Off' turned on. 

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: AV connections not being controlled - still problems with IR control
« Reply #2 on: September 13, 2010, 07:37:27 pm »
I did check before. The Advanced | Device #74: SoundBridge IR Ignore on/off is off.
Thx!