Author Topic: New installation: mplayer + vdpau = not playing m2ts files  (Read 1801 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
New installation: mplayer + vdpau = not playing m2ts files
« on: September 07, 2010, 05:30:59 pm »
Hia,
as i installed LinuxMCE fresh again, during tests, i faced the following problem:
playing m2ts files with default media director: standard video card + xv acceleration = OK
playing m2ts files with media director setted to: geforce or TNT2 + vdpau acceleration = FAILS -> plays audio, but no video.
The new installation was web based, so i suppose the latest builds are there.
The hardware being used is the same (not a screw was changed).
Any ideas why it' s failing?
TIA
« Last Edit: September 09, 2010, 06:38:39 pm by pw44 »

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #1 on: September 09, 2010, 01:58:09 pm »
I encountered this issue after a dvd install a while back, unable to give the snapshot number at this point. What I found before responsibilities got the better of my time, that if you disable vpdau and used the standard acceleration it worked. When you check the Mplayer_Player log file, there was a complaint about cannot find -vo and I believe xv(working from memory here), if vdpau or auto is enabled, around the time playing the black.mpeg and before playing or attempting to play the movie in question.


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #2 on: September 09, 2010, 03:32:34 pm »
Sorry guys,

The issue is that we had to completely cut off the avenard repo for various reasons.

The version of mplayer that is being installed at present does not have VDPAU. This will be fixed as soon as we can get around to it.

-Thom

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1004
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #3 on: September 11, 2010, 01:18:28 am »
I just tested adding the avenard repo back into lmce and the mythtv repository pinning that is employed in the current snapshots seems to allow avenard to be used safely for mplayer.  Adding the avenard repo and doing an 'apt-get dist-upgrade' will pull in mplayer from avenard and leave mythtv untouched (it's pinned to the lmce repo). 

YMMV.

J.

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #4 on: February 01, 2011, 06:29:24 pm »
Is this work around still working for you with all the updates? I tried a dist-upgrade after the end of life with the new sources.list when I was trying to install something new and it basically broke the system. I had to do a new install--which on my system means a lot of fooling around to get everything working again.

Also can you play recorded mythtv files in LMCE and get both video and sound after you do this? I only get video currently with these files and no sound. Many thanks!

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3013
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #5 on: February 01, 2011, 06:48:21 pm »
I would advise against apt-get upgrade with the avenard repo in the sources.list. However, if all you want is a specific mplayer version, why not adding avenard repo, apt-get update, apt-get install mplayer , remove avenard repo?!

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #6 on: February 10, 2011, 12:06:17 am »
What would that specific version be?
I never quit... I just ping out.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1004
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #7 on: February 11, 2011, 12:57:05 am »
Is this work around still working for you with all the updates? I tried a dist-upgrade after the end of life with the new sources.list when I was trying to install something new and it basically broke the system. I had to do a new install--which on my system means a lot of fooling around to get everything working again.

The avenard repository is still in my sources.list, dist-upgrade pulls in mplayer and libx264-65 from avenard and everything else, including mythtv, from the lmce or ubuntu old-releases repositories.  Avenard hasn't updated his intrepid repository in a long time...  It just works for me!

Quote
Also can you play recorded mythtv files in LMCE and get both video and sound after you do this? I only get video currently with these files and no sound. Many thanks!

Upgrading mplayer will have no effect on playing Mythtv files in LMCE.  LMCE will play mythtv files with xine.

J.
« Last Edit: February 11, 2011, 01:54:20 am by phenigma »

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1004
    • View Profile
Re: New installation: mplayer + vdpau = not playing m2ts files
« Reply #8 on: February 11, 2011, 01:02:40 am »
What would that specific version be?

Mplayer 1.0rc3 and newer or any recent SVN version of mplayer has vdpau support.

J.