Author Topic: How to keep LinuxMCE up-to-date with updates  (Read 1552 times)

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
How to keep LinuxMCE up-to-date with updates
« on: August 20, 2010, 07:03:45 am »

Hello,

I have installed LinuxMCE-810 beta as instructed in: http://wiki.linuxmce.org/index.php/Installing_0810
According to the section in the above wiki page: "Keeping Up-to-date with updates"
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
should update to the latest and greatest
However, the version I have is: Version 2.0.0.44.09112922522 (Sun Nove 29 13:36:43 2009) (I get the version detalis from the LinuxMCE button in the Orbitter) The date is from almost one year ago !!!. When I do
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
I don't see anything updated.
I assume that the list of DVD snapshots contains incremental changes. How can I update these changes through the network?
Also, is there a way to remove the avenard repo so I don't get the error message every time I do sudo apt-get update?

Regards,
Avner
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #1 on: August 20, 2010, 07:19:51 am »
I should mention that I do have Internet connection. The first installation updates the packages. What I'm referring to is the lack of incremental updates

Avner
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #2 on: August 21, 2010, 09:35:34 pm »
The snapshots have all current changes/updates as of the moment they are created.  If you have installed from a recent snapshop then you would have the recent changes already.

Many of the snapshots have been problematic with updates.  If your snapshot install was prior to Aug 18, 2010 then there are some things you can do that should enable updates again properly.  I'll try to make this easy and painless.  Execute each of these from the terminal prompt as you have been doing already:

Remove the avenard repository from /etc/apt/sources.list:
Code: [Select]
sudo sed -e '/avenard/d' -i /etc/apt/sources.list

Re-order the local repository properly in sources.list:
Code: [Select]
sudo sed -e '/deb-cache/d' -e '1ideb file:\/usr\/pluto\/deb-cache .\/' -i /etc/apt/sources.list

Set apt preferences properly:
Code: [Select]
sudo echo 'Package: mythtv mythtv-frontend mythtv-backend mythtv-common mythtv-database mythtv-transcode-utils mythweb libmythtv-perl libmyth python-myth mythtv-themes mythplugins mytharchive mytharchive-data mythbrowser mythgallery mythgame mythmovies mythmusic mythnetvison mythnetvision-data mythnews mythvideo mythweather mythzoneminder myth-doc  
Pin: origin deb.linuxmce.org
Pin-Priority: 1001
'  | sudo tee /etc/apt/preferences

Update your package lists and try to upgrade:
Code: [Select]
sudo apt-get update
sudo apt-get upgrade

Try that out and let me know how it goes.

J.
« Last Edit: August 23, 2010, 02:48:19 pm by phenigma »

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #3 on: August 23, 2010, 07:42:11 am »

Using the commands above with slight variation (see code below), removed the avenard repository and enabled to do incremental upgrades:
Code: [Select]
sudo cp /etc/apt/sources.list /etc/apt/sources.list.orig
sudo sed -e '/deb-cache/d' -i /etc/apt/sources.list
sudo sed -e '1ideb file:\/usr\/pluto\/deb-cache .\/' -i /etc/apt/sources.list
sudo sudo sed -e '/avenard/d' -e /etc/apt/sources.list
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #4 on: August 23, 2010, 02:49:58 pm »
Sorry 'bout that it should've been a '-i /etc/apt/sources.list' on that line to remove the avenard repo.

Glad to hear you've got updates again!

J.

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #5 on: August 25, 2010, 06:47:41 am »
Phenigma,


I do get updates. However, I notice that your changes to apt prefernce:
 
Code: [Select]
sudo echo 'Package: mythtv mythtv-frontend mythtv-backend mythtv-common mythtv-database mythtv-transcode-utils mythweb libmythtv-perl libmyth python-myth mythtv-themes mythplugins mytharchive mytharchive-data mythbrowser mythgallery mythgame mythmovies mythmusic mythnetvison mythnetvision-data mythnews mythvideo mythweather mythzoneminder myth-doc 
Pin: origin deb.linuxmce.org
Pin-Priority: 1001
'  | sudo tee /etc/apt/preferences

remove the lower section as mentioned in http://forum.linuxmce.org/index.php?topic=10309.0

Code: [Select]
# If our local package uses the same version as elsewhere, we take the one we have locally.
Package: *
Pin: origin
Pin-Priority: 600

Is the lower section still needed?
 
Regards,
Avner

Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: How to keep LinuxMCE up-to-date with updates
« Reply #6 on: August 25, 2010, 04:17:59 pm »
The lower section should be removed to properly permit updates.  Recent changes have made that portion of preferences obsolete and it can interfere with getting updates.

J.