Author Topic: apt-get update; apt-get upgrade  (Read 708 times)

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
apt-get update; apt-get upgrade
« on: August 16, 2010, 01:13:58 am »
I'm not sure if I'm doing something incorrectly, but when I run "apt-get update"  on my md I get the follow at the end:
Quote
Fetched 11.9kB in 2s (4946B/s)
Reading package lists... Done
W: GPG error: http://packages.medibuntu.org intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: You may want to run apt-get update to correct these problems

then when I type "apt-get upgrade"  I get the following:

Quote
root@moon88:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  libxine-dev libxine1 libxine1-all-plugins libxine1-bin libxine1-console libxine1-dbg libxine1-ffmpeg libxine1-gnome libxine1-misc-plugins
  libxine1-plugins libxine1-x
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

I did manually install a xine patch a while back (altho I don't think that has anything do with the message I'm receiving now from apt-get)

joerod,

Your problem is related to xine. Not vdpau as demux of audio/video is done i software and not hw.
The demuxed video data is passed to gpu through vdpau and hence offloaded from cpu.

As TSCHAK pointed out we have a version of Xine that is unable to demux newer matroska containers in current release because we are unable to get vdr to run with the my backported version. I have started to look at how to port vdpau to xine 1.1.18.1. It´s a huge job that need to be done manually.
If you do not use vdr your problem can be solved either by installing the updated xine 1.1.16.3 with mkv backports as suggested or by building your own xinelib >1.1.17.
Unfortunately any version newer of xine than 1.1.16.3 do not have vdpau because the Xine devel team decided to focus on upcoming version 1.2 instead.
Before you ask I can say that v1.2 is not a possible road due to so much dependencies on newer libraries and also because 1.2 is not abi compatible with 1.1.x releases.

/niz23



I'm not sure what I'm doing wrong or if this even a problem, but and feedback is appreciated.

Thanks.

nzlneil

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: apt-get update; apt-get upgrade
« Reply #1 on: August 16, 2010, 01:59:05 am »
Hi Joerod

Try using aptitude in place of apt-get and see how you get on.

Neil

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: apt-get update; apt-get upgrade
« Reply #2 on: August 16, 2010, 02:13:27 am »
get the key for medibuntu, somehow it doesn't roll into the md's.

Quote
wget http://packages.medibuntu.org/medibuntu-key.gpg && sudo apt-key add medibuntu-key.gpg && rm medibuntu-key.gpg

Also check your preferences file and make sure the pin priority is set:

Quote
# If our local package uses the same version as elsewhere, we take the one we have locally.
Package: *
Pin: origin
Pin-Priority: 500

Just leave the deb.linuxmce.org pin alone.

then run apt-get update && apt-get upgrade again

Richard

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: apt-get update; apt-get upgrade
« Reply #3 on: August 16, 2010, 05:28:49 am »
oh and before i forget to mention this, you can force the upgrades with apt-get -f install

later,

Richard