Author Topic: [SOLVED] Can't play music  (Read 2514 times)

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
[SOLVED] Can't play music
« on: August 09, 2010, 12:52:19 am »
Just did a fresh install from snapshot. Copied mp3s and dvds etc back across the network to the internal hdd from my network backup.

Mostly OK but I have a weird problem. Videos are fine but my core/mds crash if I select audio and then any artist. The screen goes black as if I've clicked 'quick reload router' and the router reloads.

Any suggestions?
Barney

<edit>title for clarity</edit>
« Last Edit: August 13, 2010, 03:18:46 pm by b4rney »

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Selecting audio artist crashes md
« Reply #1 on: August 10, 2010, 10:45:37 pm »
Doing a fresh install. Had a few glitches anyway.
Barney

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Selecting audio artist crashes md
« Reply #2 on: August 11, 2010, 03:33:12 pm »
Full reinstall ... same problem.

Click audio...
Artists display
Click artist...
router dies

Anyone got any ideas? Here is an excerpt of the log.
Barney
Code: [Select]
07      08/11/10 14:11:30.312             Parameter 59(Signature):  <0x812c5b90>
05      08/11/10 14:11:30.345           ^[[33;1mSocket::ReceiveData 0xa95121c0 f$
05      08/11/10 14:11:30.345           ^[[33;1mSocket::ReceiveString2 ReceiveDa$
05      08/11/10 14:11:30.345           ^[[33;1mTCPIP: Closing connection to -10$
05      08/11/10 14:11:30.345           ^[[33;1mRouter::RemoveAndDeleteSocket 0x$
07      08/11/10 14:11:39.267           Event #65 has no handlers <0x812c5b90>
07      08/11/10 14:11:39.268           Received Message from 1 (^[[36;1mCORE / $
07      08/11/10 14:11:39.268             Parameter 5(Mac Address): 00:60:6e:87:$
07      08/11/10 14:11:39.268             Parameter 13(Text):  <0x812c5b90>
07      08/11/10 14:11:39.268             Parameter 28(IP Address): 192.168.80.1$
07      08/11/10 14:11:39.268             Parameter 49(PK_DeviceTemplate):  <0x8$
07      08/11/10 14:11:39.268             Parameter 51(VendorModelID):  <0x812c5$
07      08/11/10 14:11:39.268             Parameter 52(PK_CommMethod): 3 <0x812c$
07      08/11/10 14:11:39.268             Parameter 53(PK_PnpProtocol): 2 <0x812$
07      08/11/10 14:11:39.268             Parameter 54(PNP Serial Number):  <0x8$
07      08/11/10 14:11:39.268             Parameter 55(DeviceData):  <0x812c5b90>
07      08/11/10 14:11:39.268             Parameter 56(Category):  <0x812c5b90>
07      08/11/10 14:11:39.268             Parameter 59(Signature):  <0x812c5b90>
05      08/11/10 14:11:39.306           ^[[33;1mSocket::ReceiveData 0xa95121c0 f$
05      08/11/10 14:11:39.306           ^[[33;1mSocket::ReceiveString2 ReceiveDa$
05      08/11/10 14:11:39.306           ^[[33;1mTCPIP: Closing connection to -10$
05      08/11/10 14:11:39.306           ^[[33;1mRouter::RemoveAndDeleteSocket 0x$
08      08/11/10 14:11:44.874           Received Message from 21 (^[[36;1mOnScre$
08      08/11/10 14:11:44.875             Parameter 5(Value To Assign):  <0x70aa$
08      08/11/10 14:11:44.875             Parameter 13(Filename): !A575 <0x70aa4$
08      08/11/10 14:11:44.875             Parameter 45(PK_EntertainArea):  <0x70$
Return code: 139
3       08/11/10 14:11:45       DCERouter (server)      ^[[1;31mDevice died... c$
Wed Aug 11 14:11:45 BST 2010 died

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3060
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Can't play music
« Reply #3 on: August 11, 2010, 03:50:31 pm »
What happens if you retry it after it died?

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Can't play music
« Reply #4 on: August 11, 2010, 10:43:38 pm »
When I click on an artist the router dies and appears to do a 'quick reload router'. The screen goes blank and the message 'reconnecting to dcerouter as requested' appears on the screen. After this the main screen appears with the overlaid menus.

DVD snapshot 23227 from 2nd August. Using phenigmas script to enable local repo.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3060
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Can't play music
« Reply #5 on: August 11, 2010, 11:48:34 pm »
What happens if you retry it, after it died?

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Can't play music
« Reply #6 on: August 12, 2010, 12:27:19 am »
Hi posde,

Like I just said, it reloads the router again. Videos are fine, mythtv is fine, audio > artist crashes the router every time.

Barney

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3060
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Can't play music
« Reply #7 on: August 12, 2010, 09:19:19 am »
My reason for asking is, that the only time I have seen crashes during display is with timeouts on MySQL. And if you revisit the page, the result most probably is in the cache, and can be served much faster.

Could you filebin a dump of your pluto_media db.

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Can't play music
« Reply #8 on: August 12, 2010, 07:41:10 pm »
Thanks posde. Looks like it's not just me. Found this.
http://svn.linuxmce.org/trac.cgi/ticket/784

I tried deleting all audio files in case I had corrupt files, resynchronised etc and added a single album ... but same problem. Hopefully there'll be a fix soon.

Might be mplayer related. Here is a small section from the mplayer log from the moment I clicked on a performer.
Barney
Code: [Select]
05      08/12/10 18:36:20.219           ^[[33;1mSocket::ReceiveData 0x96ab300 failed, bytes left 0 start: 0 1: 0 1b: 0 2: 0 2b: 0 m_$
05      08/12/10 18:36:20.220           ^[[33;1mSocket::ReceiveString2 ReceiveData failed m_Socket: -1 Command_Impl1 Dev #26^[[0m <0$
01      08/12/10 18:36:20.220           ^[[31;1mReceive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev$
05      08/12/10 18:36:20.220           ^[[33;1mDumping 1 locks^[[0m <0xb68e2b90>
05      08/12/10 18:36:20.220           ^[[33;1mfinished check for exceptions^[[0m <0xb68e2b90>
05      08/12/10 18:36:20.220           ^[[33;1mOL: (0x96ab44c) (>87) MessageQueue Command_Impl.cpp l:822 time: 1:00:00a (1281634580$
05      08/12/10 18:36:21.219           ^[[33;1mDropping all sockets...^[[0m <0xb70e46c0>
05      08/12/10 18:36:21.219           ^[[33;1mDone dropping sockets!^[[0m <0xb70e46c0>
Return code: 2
2       08/12/10 18:36:21       26 (spawning-device)    ^[[1;33mDevice requests restart... count=1/50 dev=26^[[1;00m
Thu Aug 12 18:36:21 BST 2010 Restart
========== NEW LOG SECTION ==========
1       08/12/10 18:36:29       26 (spawning-device)    ^[[1;00mStarting... 1^[[1;00m
1       08/12/10 18:36:29       26 (spawning-device)    ^[[1;00mFound ./MPlayer_Player^[[1;00m
== ATTEMPT FRESH START ==
1       08/12/10 18:36:36       Spawn_Device.sh 26 (spawning-device)    ^[[1;00m5068 Dev: 26; Already Running list: 15,16,18,19,21,2$
1       08/12/10 18:36:36       Spawn_Device.sh 26 (spawning-device)    ^[[1;00m5068 Device 26 was marked as 'running'. Not starting$
1       08/12/10 18:36:36       Spawn_Device.sh 26 (spawning-device)    ^[[1;00m5068 Dev: 26; Exiting because not starting^[[1;00m

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3060
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Can't play music
« Reply #9 on: August 12, 2010, 08:09:44 pm »
When you copy/move your files onto your hard drive, do you put them into a folder with a folder lock?

Otherwise UpdateMedia might scan the files wrongly.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: Can't play music
« Reply #10 on: August 12, 2010, 08:26:29 pm »
Mplayer has no bearing on playing music. The symptom is elsewhere. Check your DCERouter log.

-Thom

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Can't play music
« Reply #11 on: August 13, 2010, 12:03:19 am »
@posde
That's what I thought, something to do with copying the files across the network and a bad media scan, but when I saw the trac ticket I thought it must be a wider issue. How do I check for a folder lock?

@Thom
Good point  :-[ I'll trawl my log files again.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3060
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Can't play music
« Reply #12 on: August 13, 2010, 12:26:55 am »
search for folder lock in the wiki

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Can't play music
« Reply #13 on: August 13, 2010, 01:59:17 am »
No locks found. Doesn't rule out bad parameters though.

Weird, I can play music using the search feature. This is the same behaviour someone described in the trac ticket I found.

Looks like it's failing on the 'Get Attributes For Media' line in the DCERouter.log.

Too tired now. Will look again tomorrow. Here's the log at the exact moment I clicked the performer.
Code: [Select]
08 08/12/10 23:15:19.985 Received Message from 21 (OnScreen Orbiter / Kitchen) to 10 (Media Plug-in / Kitchen), type 1 id 807 Command:Get Attributes For Media, retry none, parameters: <0xa1beeb90>
08 08/12/10 23:15:19.985   Parameter 5(Value To Assign):  <0xa1beeb90>
08 08/12/10 23:15:19.985   Parameter 13(Filename): !A1362 <0xa1beeb90>
08 08/12/10 23:15:19.985   Parameter 45(PK_EntertainArea):  <0xa1beeb90>
Return code: 139
3 08/12/10 23:15:20 DCERouter (server) Device died... count=23/200 dev=DCERouter
Thu Aug 12 23:15:20 BST 2010 died

bp5

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: Can't play music
« Reply #14 on: August 13, 2010, 12:13:30 pm »
I have the same issue with the 2 Aug snapshot: clicking on any artist name resets but if I just click on Play All it starts playing the first track, so I'm guessing it is some kind of database issue. Hope that helps, I'll watch this thread to see if anyone has a fix....