Author Topic: Jerky HD Video on Asus AT3N7A-I  (Read 1320 times)

stallione

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Jerky HD Video on Asus AT3N7A-I
« on: August 07, 2010, 06:29:46 pm »
Hi,
I am having a very hard time getting smooth playback of HD Video on this mobo running as an MD. I have 512 MB shared DD2 800Mhz to the video card. The processor spikes up when playing 1080p or even 720p video, I tried various different encoding, but xine player spikes up the CPU usage and the video playback is not pretty. Any ideas on what can be done? I understand that xine doesn't use vdpau?
TIA.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3059
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #1 on: August 07, 2010, 07:28:39 pm »
512MB might be too little. My board has 2G.

stallione

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #2 on: August 07, 2010, 10:38:27 pm »
Yes, I have 2 Gig total, what I meant was I was sharing 512 MB for Video. Trying to fiddle with other things in the Bios to figure it out. - Thanks.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #3 on: August 08, 2010, 01:03:29 am »
Have you set the MD to use vdpau in web admin?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

stallione

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #4 on: August 08, 2010, 06:53:20 pm »
Quote
Have you set the MD to use vdpau in web admin?

Yes, I have. What I am trying to play is HD Video (h.264 encoded) that I am encoding from my HD Camcorder using Cyberlink powerdirector v8. I tired various encoding options within the software and none of them are working. If I do a 1080i mpeg2 format, it works but obviously that is not ideal
Any ideas?
Thanks,
Stallione.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #5 on: August 09, 2010, 11:21:18 am »
So what is the file extension for the video in question?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

stallione

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #6 on: August 10, 2010, 03:16:33 am »
the file extension is m2ts

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4539
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #7 on: August 10, 2010, 08:02:56 am »
Hi,
I am having a very hard time getting smooth playback of HD Video on this mobo running as an MD. I have 512 MB shared DD2 800Mhz to the video card. The processor spikes up when playing 1080p or even 720p video, I tried various different encoding, but xine player spikes up the CPU usage and the video playback is not pretty. Any ideas on what can be done? I understand that xine doesn't use vdpau?
TIA.

The Atom processors available today just do not have the processing power to deliver smooth h.264 performance at 1080p on their own. You need to enable vdpau and let the GPU h.264 acceleration handle h.264 playback in hardware.

All the best

Andrew
« Last Edit: August 10, 2010, 12:35:16 pm by totallymaxed »
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Jerky HD Video on Asus AT3N7A-I
« Reply #8 on: August 10, 2010, 11:12:04 am »
the file extension is m2ts

Try changing to MKV?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps