Author Topic: [SOLVED] Telecom Not Recognizing DTMF (Touch Tones)  (Read 590 times)

team_steeze

  • Regular Poster
  • **
  • Posts: 15
    • View Profile
[SOLVED] Telecom Not Recognizing DTMF (Touch Tones)
« on: July 21, 2010, 11:45:13 pm »
I just got an incoming number working with Localphone.com and am getting it set up.

One problem that I am experiencing is that if I place an outside call in to LinuxMCE and wait until it goes to the prompts, the system will not recognize any of my touch tone inputs.
I have tried from two different cell phones.
I do not have a landline to test this from.
Is anyone else experiencing this problem?

I'm on a fully updated and recent snapshot.

Thanks!

UPDATE:
After digging around and looking at settings recommended by my VoIP provider (localphone.com), I was able to fix this issue by doing the following:
1) Launch FreePBX (From the WebAdmin, Advanced/Configuration/Phones Setup)
2) Select Trunks
3) Select the Trunk in question
4) Under Incoming Settings/USER Details, change:
Code: [Select]
dtmf=inband
dtmfmode=inband
to
Code: [Select]
dtmf=rfc2833
dtmfmode=rfc2833

The create_amp_localphone.pl script has been modified to reflect the above changes and submitted for inclusion.
« Last Edit: July 22, 2010, 04:41:58 am by team_steeze »