Author Topic: troubleshoot : system hangs need help [solved for now]  (Read 1668 times)

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
troubleshoot : system hangs need help [solved for now]
« on: July 21, 2010, 06:01:08 pm »
Hello guys,

I have been using linuxmce since a while now. my system core/hybrid 8.10 is running just fine. Except there is one little problem. And I dont know how should I solve it.

The Problem : system starts and runs just normal in the evening, next day morning when I wake up, I see it hanged. I cannot move cursor nothing. Only thing I have to do is hard reboot meaning turn it off by holding power key and turn back on after a while.  Sounds like heat issue but my case is running almost 6 fans !!

MY guess : unfortunately I have refurbished 8800GT and I am guessing that after a while the GPU is dying.

I dont know how to read logs. If someone can guide me through. how can i find out what is going on?

thank you all in advance.

take it easy. :)
« Last Edit: July 24, 2010, 07:50:27 pm by theteju »

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #1 on: July 21, 2010, 06:23:55 pm »
Keyboard works?
What mouse and keyboard do you have?
Keyboard and mouse connected to USB?
What is the motherboard and processor?
Can you telnet / ssh to it?

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #2 on: July 22, 2010, 12:02:34 am »
Hopefully its not a hardware issue but I have had this problem recently.

My machine was also hanging starting off stopping sometime over night then more often. Ended up being a stuffed motherboard that would not handle more than 1 stick of RAM at once. I ran MemTest86+ on the system which failed and then was manual testing of hardware to find the culprt. Of course if it is your GPU not likely fail that test!



team_steeze

  • Regular Poster
  • **
  • Posts: 15
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #3 on: July 22, 2010, 02:34:16 am »
I had a similar issue that I was able to trace back to the video card.
If you have onboard video, try taking out your 8800GT and seeing if the system runs without crashing.
Whatever the case, it is most likely hardware/heat related.

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #4 on: July 22, 2010, 04:15:34 am »
Keyboard works?
What mouse and keyboard do you have?
Keyboard and mouse connected to USB?
What is the motherboard and processor?
Can you telnet / ssh to it?

I am using logitech dinovo mini which servers purpose of keyboard and mouse both and yes that connects via USB. right now as I am typing the system is working just fine.
Asus P5Q and core 2 duo processor.
I don't know how to telnet/ssh .

Thanks for your reply.

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #5 on: July 22, 2010, 04:18:45 am »
i was just hoping if the system give me information about the particular hardware if its failing. In may be logs.
If not , i will do trial and error and check hardware one by one.

Thank you all for the reply, I shall keep you updated.


pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #6 on: July 22, 2010, 01:00:47 pm »
There are some hardware which does not handle USB right. Did happen to me, mouse and keyboard freeze, and the only way was to reboot, to restore it's use. But ssh worked, so i could use the system. Try to use webadmin from another orbiter or computer and see if it works. If yes, then you problem might be USB.....

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4526
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: troubleshoot : system hangs need help
« Reply #7 on: July 22, 2010, 01:15:48 pm »
Keyboard works?
What mouse and keyboard do you have?
Keyboard and mouse connected to USB?
What is the motherboard and processor?
Can you telnet / ssh to it?

I am using logitech dinovo mini which servers purpose of keyboard and mouse both and yes that connects via USB. right now as I am typing the system is working just fine.
Asus P5Q and core 2 duo processor.
I don't know how to telnet/ssh .

Thanks for your reply.

Try leaving your system with the Denovo USB dongle removed... see if the system fails to lockup without the Denovo's USB dongle. Some USB device can cause a USB Disconnect (MCE receivers will lock your system up if removed while the system is running for example) when removed or sometimes even while connected. Do the test and see if its the Denovo causing the problem...if not then you have removed another variable.

All the best


Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #8 on: July 22, 2010, 09:30:59 pm »
There are some hardware which does not handle USB right. Did happen to me, mouse and keyboard freeze, and the only way was to reboot, to restore it's use. But ssh worked, so i could use the system. Try to use webadmin from another orbiter or computer and see if it works. If yes, then you problem might be USB.....

well yes I had used weborbiter when it used to freez with myth problems,, this time when it freezes i cannot access the weborbiter. neither from internal nor from external network.

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #9 on: July 22, 2010, 09:32:12 pm »
Keyboard works?
What mouse and keyboard do you have?
Keyboard and mouse connected to USB?
What is the motherboard and processor?
Can you telnet / ssh to it?

I am using logitech dinovo mini which servers purpose of keyboard and mouse both and yes that connects via USB. right now as I am typing the system is working just fine.
Asus P5Q and core 2 duo processor.
I don't know how to telnet/ssh .

Thanks for your reply.

Try leaving your system with the Denovo USB dongle removed... see if the system fails to lockup without the Denovo's USB dongle. Some USB device can cause a USB Disconnect (MCE receivers will lock your system up if removed while the system is running for example) when removed or sometimes even while connected. Do the test and see if its the Denovo causing the problem...if not then you have removed another variable.

All the best


Andrew

thanks Andrew,, your point raised a question, I have recetly added usb Uirt to my system and since then I think i am having this issue. can it be possible?

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #10 on: July 22, 2010, 09:39:16 pm »
wow,, sorry to bother you guys, little more update.

Last night , the system froze while I was watching something. exactly at around 11. just now I noticed there is a error in my obiters log.

Error log

Device OnScreen Orbiter, # 21   
Device Template OnScreen Orbiter, device category Standard Orbiter, manufacturer Pluto.   
    
01   07/21/10 22:01:55.059      Orbiter::CMD_Goto_DesignObj m_pScreenHistory_Current while doing the object offscreen <0xb5292b90>

This matches exact time it froze yesterday.  Does it tell any information?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #11 on: July 23, 2010, 12:26:25 am »
I tracked through the code, and can't find any reason that would cause the system to freeze.

Sorry.

-Thom

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3047
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: troubleshoot : system hangs need help
« Reply #12 on: July 23, 2010, 08:04:01 am »
My money is on a thermal problem with the graphics adapter.

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #13 on: July 23, 2010, 08:53:22 pm »
surprising guys.. i dont know.. but

I unplugged USB urit and the system is working since yesterday.. !!!

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: troubleshoot : system hangs need help
« Reply #14 on: July 23, 2010, 09:31:13 pm »
Some USB chipsets does not handle 1.1 and 2.0 right, and thus, the USB system freezes.
My M3N78-VM does have this problem.
I ordered a PCI USB card, and hopefully the problem will end as i will plug all the 1.1 USB devices on it.
kernel 2.6.27 has this problem, and i did no see yet a patch to correct it.
But also check temperatures (graphic card and processor).