Author Topic: mythtv slows to a crawl  (Read 1226 times)

maverick0815

  • Addicted
  • *
  • Posts: 560
    • View Profile
mythtv slows to a crawl
« on: July 19, 2010, 06:27:04 pm »
When I'm watching tv on my MD (asrock ion330) and I hit F7 or try something fancy as PIP the playback slows down to a crawl...the system becomes very unresponsive....
Is this to be expected on an ion-plattform?
Also I have an issue with some movies....they sometimes freeze for a couple of seconds, then fastforwards to keep up again. I can rewind to the original place and watch normally. I think I have found out that when MythTV wasn't running before I watched, the videos play smoothly, no jerking.
Anyone else experienced something like that?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4501
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: mythtv slows to a crawl
« Reply #1 on: July 19, 2010, 06:43:24 pm »
When I'm watching tv on my MD (asrock ion330) and I hit F7 or try something fancy as PIP the playback slows down to a crawl...the system becomes very unresponsive....
Is this to be expected on an ion-plattform?
Also I have an issue with some movies....they sometimes freeze for a couple of seconds, then fastforwards to keep up again. I can rewind to the original place and watch normally. I think I have found out that when MythTV wasn't running before I watched, the videos play smoothly, no jerking.
Anyone else experienced something like that?

Are you running vdpau? Have you got the MythTV's CommFlagging turned on? Another candidate is MythFilldatabase...that can really hose your Core too. Any of these or some of them in parallel might cause video streams to hiccup as you describe.

All the best


Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

maverick0815

  • Addicted
  • *
  • Posts: 560
    • View Profile
Re: mythtv slows to a crawl
« Reply #2 on: July 19, 2010, 07:18:27 pm »
I will check the commflagging...seems a good start, thanks :-)

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: mythtv slows to a crawl
« Reply #3 on: July 19, 2010, 08:35:25 pm »
What is commflagging? A sort of QOS?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4501
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: mythtv slows to a crawl
« Reply #4 on: July 19, 2010, 09:54:22 pm »
What is commflagging? A sort of QOS?

Commercial Flagging... the post-process Myth runs if enabled to remove all the commercials from your TV recordings

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: mythtv slows to a crawl
« Reply #5 on: July 19, 2010, 11:02:56 pm »
Yep I'm running a new install as of last week and when I go in and out of TV guide the system locks up for few seconds or becomes jumpy. Eventually comes right but is pain in the arse.

I have not had chance to go through things yet but I do have comm skip turn on and VDPAU slim. I use a remote not keyboard so not sure what F7 does.

Running a 8600GT card.

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: mythtv slows to a crawl
« Reply #6 on: July 19, 2010, 11:13:45 pm »
Another possibility is disabling realtime priority threads in mythtv frontend. I think it is enabled by default.

http://forum.linuxmce.org/index.php?topic=10101.msg69320#msg69320

Did you try this solution?
Find the playback settings page and uncheck 'Enable realtime priority threads'. Then you should be able to use the normal vdpau profile.
Barney

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: mythtv slows to a crawl
« Reply #7 on: July 19, 2010, 11:18:09 pm »
Another possibility is disabling realtime priority threads in mythtv frontend. I think it is enabled by default.


Thats triggered the brain going :) I'm pretty sure I have done that in the past. Will test tonight.

Cheers,

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4501
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: mythtv slows to a crawl
« Reply #8 on: July 19, 2010, 11:33:01 pm »
Another possibility is disabling realtime priority threads in mythtv frontend. I think it is enabled by default.


Thats triggered the brain going :) I'm pretty sure I have done that in the past. Will test tonight.

Cheers,

My understanding is that realtime priority threads are now disabled by default in recent installs/updates...if not they should have been! This could definitely cause the problems you seeing.


Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: mythtv slows to a crawl
« Reply #9 on: July 20, 2010, 08:21:21 am »

Did the trick. realtime priority threads was ticked once changed no delays when changing to guide.

I'm not 100% sure what snapshot I installed so maybe a slightly older one.

Can someone with current snapshot confirm this?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4501
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: mythtv slows to a crawl
« Reply #10 on: July 20, 2010, 10:00:58 am »

Did the trick. realtime priority threads was ticked once changed no delays when changing to guide.

I'm not 100% sure what snapshot I installed so maybe a slightly older one.

Can someone with current snapshot confirm this?

Great. I have mentioned the need for this to be defaulted to 'off' to Posde in the channel.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: mythtv slows to a crawl
« Reply #11 on: July 20, 2010, 11:02:35 am »
Mentioning stuff in IRC is not the best way to get stuff done.

Best way to get stuff done is:
  • Create a trac ticket
  • Grab someone in IRC and point 'em to the trac ticket.

maverick0815

  • Addicted
  • *
  • Posts: 560
    • View Profile
Re: mythtv slows to a crawl
« Reply #12 on: July 20, 2010, 11:34:09 am »
I'm not sure about the realtime priority threads, but for me changing the commflagging to blank screen instead of try all methods worked.