Author Topic: [SOLVED] Sound | ALSA | V4L | disagrees about version of symbol in dmesg  (Read 1400 times)

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
I have a long time problem with the latest installs, that my two tv-cards are not producing sound in mythTV.
I used a liveCD of MythBuntu, and they worked like a charm.
In dmesg, both cards seem to have trouble to get them registered with alsa.
The dmesg is filled with errors eg:
Code: [Select]
disagrees about version of symbol.The problem arrises with both the Pinnacle 310i (saa7134_alsa) and my Hauppauge 4000 (cx88_alsa).

Reverting to older alsa version gets the card registered, and no errors in dmesg.
Code: [Select]
apt-get remove alsa-modules-`uname -r`
My questions.

  • Am I the only one?
  • Does this have something to do with wrongfull compiling alsa?
  • Or does it have something to do with how the drivers are loaded, e.g. first saa7134_alsa, and then the V4L drivers, and then alsa general.
  • Has it do with a incompatibility between alsa 1.0.23 and v4l?

« Last Edit: July 22, 2010, 11:03:57 pm by bongowongo »

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #1 on: July 17, 2010, 03:53:58 pm »
Could it have something to do with this?
http://www.sfr-fresh.com/linux/misc/alsa-driver-1.0.23.tar.gz:a/alsa-driver-1.0.23/INSTALL
Quote
 107   - On modern distros with 2.6 kernel, you are likely using udev.
  108     Don't forget to add --enable-dynamic-minors option.  Otherwise a
  109     device-file mismatch might happen.
  110
  111   - In short, a safe combination for the recent distros is:
  112    ./configure --with-debug=full --enable-dynamic-minors \
  113       --with-moddir=updates

I have no clue, but it looks like this could be our/my problem?
« Last Edit: July 19, 2010, 08:36:46 pm by bongowongo »

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #2 on: July 19, 2010, 08:34:36 pm »
The version mismatch has probably something to do with a wrong compiled alsa. Mismatch with kernel version. At least that is what I suspect.
Because nobody else has this problem I am going to make changes in hardware, see if that brings me more luck
Thanks for your help Possy.

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #3 on: July 20, 2010, 03:11:07 am »
yeh we went over this in IRC it is alsa  :P

Mandingo
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #4 on: July 20, 2010, 11:38:25 am »
Yes ok.
Possy did a build with the flags I provided, but it gave more problems and no solutions.
So what is the approach?
Trying to solve it? revert back to older alsa, or wait till we use newer kernel?

Also after reverting to older alsa, everything is registered nicely, but no sound in MythTV
TV works through mplayer -> video0 alsa=hw1,0 etc etc.
If I use ALSA:default or the ALSA:hw1,0 in myth-setup, no sound.

I am troubleshooting myself using mythbuntu 0810 and 1004 to see which settings should work.
I keep you posted on it

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #5 on: July 22, 2010, 11:03:32 pm »
Did a new install. This time a netinstall.
Reverted to older version of ALSA
Did not auto add the card, so I cannot view it in webadmin.
Manually added the card in MythTV and used the following for sound ALSA:hw:1,0
To be on the safe side I rebooted and voila, sound with TV.

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: [SOLVED] Sound | ALSA | V4L | disagrees about version of symbol in dmesg
« Reply #6 on: October 11, 2011, 08:13:44 pm »
I'm not sure where to put this, but I was having this same problem for a long time with the additional headache that when I downgraded alsa to 1.0.17 I lost my optical out on my realtek ALC888 sound card built into the motherboard. So it was either have the solo microphone and usb soundcards that could be used as squeezeslaves or have optical out. Looking at some posts that focused on this sound card it seemed that the problem might be alsa 1.0.23. So I downloaded and compiled alsa 1.0.24 on my lmce 8.10 setup and then rebooted. Curiously, even though cat /proc/asound/version still showed 1.0.23, something was fixed: I had optical out sound and I could see my usb sound card through squeezeslave -L. I'll keep testing to see if this broke something else but for now I am a happy camper. Just thought this might help someone in the same boat.