Author Topic: Picture Viewer shows pictures alpha blended on top of Photo Screen Saver  (Read 2081 times)

mathieu

  • Veteran
  • ***
  • Posts: 57
    • View Profile
Hi All,

I just followed this wiki http://wiki.linuxmce.com/index.php/Picture_Viewer.
It works, except the pictures are alpha blended on top of the Photo Screen Saver which makes it unusable.

A search in the forum didn't bring up anything.
I there a way to correct this?

br mathieu
« Last Edit: July 09, 2010, 03:06:59 pm by mathieu »

stallione

  • Veteran
  • ***
  • Posts: 59
    • View Profile
I tested it and ran into the same problem, I think the screen saver needs to be blanked out or splashed with a black screen when the picture viewer is started. Not sure if there is a ticket already open for it.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
I tested it and ran into the same problem, I think the screen saver needs to be blanked out or splashed with a black screen when the picture viewer is started. Not sure if there is a ticket already open for it.

This also affects Web Browsing & other computing Apps... they do not disable the pss when they are running.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2923
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
This also affects Web Browsing & other computing Apps... they do not disable the pss when they are running.

Is this still true on 810?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
This also affects Web Browsing & other computing Apps... they do not disable the pss when they are running.

Is this still true on 810?

It was a few months back... but this could have been fixed since that time. The Picture Viewer needs a media type that disables the pss.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
guys, you don't read the API close enough.

pay attention to the MediaStream object in Media PlugIn.

If ContainsVideo in your subclass returns true, then the Photo Screen Saver is disabled. Simple as that. Look at my Game and Hulu Plugin's mediastream subclasses.

-Thom

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
It should disable the screen saver. Does the screen saver show a static image, or are they zooming and panning as usual?

Thom: The picture viewer uses the standard MediaStream class which has ContainsVideo return true when the media type is the picture type.

best regards,
sambuca

mathieu

  • Veteran
  • ***
  • Posts: 57
    • View Profile
Hi,

The Photo Screen Saver shows a static background image. Pictures of the Picture Vieuwer are alpha blended on top and also not full screen.

br mathieu

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
Would you mind trying out a new version that might solve the problem? Download the new file from  http://hob.dyndns.org/lmce/Picture_Viewer and install it to /usr/pluto/bin on the MD(/hybrid). Reload the router, and test again.

best regards,
sambuca

mathieu

  • Veteran
  • ***
  • Posts: 57
    • View Profile
Hi sambuca,

Sure I wanna try, but is it possible the url is wrong?

The requested URL /LinuxMCE/Picture_Viewer was not found on this server.

br mathieu

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
Oops, sorry, the correct url is http://hob.dyndns.org/lmce/Picture_Viewer

br,
sambuca

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Still not working
Code: [Select]
Not Found

The requested URL /LinuxMCE/Picture_Viewer was not found on this server.
Apache/2.2.9 (Debian) mod_jk/1.2.26 PHP/5.2.6-1+lenny8 with Suhosin-Patch Server at hob.dyndns.org Port 80

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
wtf. I'm sure I put the right one in last time. The url should read / _lmce_ /Picture_Viewer , without the _s

br,
sambuca
« Last Edit: July 19, 2010, 04:12:11 pm by sambuca »

wierdbeard65

  • Guru
  • ****
  • Posts: 449
    • View Profile
    • My Quest
I can confirm that the URL does read that and doesn't work ;)

HTH
Paul
If you have the time to help, please see where I have got to at: http://wiki.linuxmce.org/index.php/User:Wierdbeard65

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
Yes, it seems our friendly forum decides to replace all _lmce_ with LinuxMCE, very helpfull  >:(

br, sambuca