Author Topic: Trying to update using "/usr/pluto/bin/getxmls"  (Read 625 times)

Riggs

  • Guru
  • ****
  • Posts: 185
    • View Profile
    • Kotonix LLC
Trying to update using "/usr/pluto/bin/getxmls"
« on: June 30, 2010, 06:40:05 pm »
ok so i go to web admin and try to run a update and a page comes up with  " /usr/pluto/bin/getxmls" in it and sets there so i ssh to the core and type  sudo /usr/pluto/bin/getxmls
and i get "see below" if im doing it wrong please let me know but it just seem like i get errors, what is the right way to update LinuxMCE, yeah i know sudo apt-get update & upgrade but i tried that before and had to reinstall.
or should i download the latest snapshot every so often to get up to date

simon@dcerouter:~$ sudo /usr/pluto/bin/getxmls
[sudo] password for simon:
Entity: line 1: parser error : Opening and ending tag mismatch: p line 0 and div
.." href="/app/comments/?categoryid=ajax-xml-css&amp;id=61218"></a></span></div>
                                                                               ^
Entity: line 7: parser error : Opening and ending tag mismatch: p line 0 and div
</div>
      ^
Entity: line 1: parser error : Opening and ending tag mismatch: br line 0 and div
.." href="/app/comments/?categoryid=ajax-xml-css&amp;id=51839"></a></span></div>
                                                                               ^
Entity: line 305: parser error : Attribute value redefined
submit-contain"><input type="submit" class="btn-submit" value="Search"  value=""
                                                                               ^
Found packages tag:
Entity: line 247: parser error : Attribute value redefined
submit-contain"><input type="submit" class="btn-submit" value="Search"  value=""
« Last Edit: June 30, 2010, 06:45:59 pm by Riggs »
Dell XPS Gen5 P4 3.2Ghz 64 x2, 3Gbs Ram, GeForce 8600GT 1Gb VRam, Creative Audigy 2 ZS, LinuxMCE 10.04 32bit,, 2 Eth Cards, Comcast business 25Mbs/5Mbs. Zwave, X10, Vera 3.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: Trying to update using "/usr/pluto/bin/getxmls"
« Reply #1 on: July 02, 2010, 12:52:10 am »
getxmls is no longer actively used. It was originally used to find and aggregate sources for the Add Software page.

Don't worry about it. If you want to see the code for it, it's in src/Add_Software, it consists of a google scraper, looking for a specific search phrase, scraping the results, and loading each page, looking for a passage of a specific XML format, pointing to a set of packages, and their repository sources.

-Thom

Riggs

  • Guru
  • ****
  • Posts: 185
    • View Profile
    • Kotonix LLC
Re: Trying to update using "/usr/pluto/bin/getxmls"
« Reply #2 on: July 02, 2010, 01:46:42 am »
Ok thanks Thom, shell i just run apt-get update & upgrade then,
Dell XPS Gen5 P4 3.2Ghz 64 x2, 3Gbs Ram, GeForce 8600GT 1Gb VRam, Creative Audigy 2 ZS, LinuxMCE 10.04 32bit,, 2 Eth Cards, Comcast business 25Mbs/5Mbs. Zwave, X10, Vera 3.