Author Topic: mythtv upgrade problems  (Read 702 times)

maverick0815

  • Addicted
  • *
  • Posts: 543
    • View Profile
mythtv upgrade problems
« on: June 27, 2010, 05:59:53 pm »
So I scrapped my MD-installation,  because it suffered from freezing movies...
First I tried rebuilding the image, but I got a blackscreen with a mousepointer, that just wouldn't go away. I thought, what the heck, and deleted the MD to try from ground up.
Everything went fine so far, except, that when I did an apt-get update and apt-get dist-upgrade, it wanted to install a lot of stuff...unfortunately for me, I didn't see it right away, because it also installed mythtv .22 as an "upgrade"...in the end, TV's not working, because of version mismatch.
I deleted the whole thing again and checked after it was finished building....its got mythtv .23 installed....I went to KDE-desktop and there it told me, I had packages for mythtv installed version 0.23, but a newer version 2.0.22 was available.
So I guess, I screwed something else up as well. If you guys can give me some hints, it would save me some work, because now I'm thinking of just scrapping the whole install and try the lastes snapshot...hopefully that would safe me some other trouble as well, because I thought by now working alsa-drivers had been included, so that my ion-md would work out of the box. Right now I have to manually install those to get it working...
--------------------
so far when I start mythtv, my monitor gets gray and I see date and time in the lower right corner...thats it, after a while it crashes back to the menu
« Last Edit: June 27, 2010, 06:19:54 pm by maverick0815 »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: mythtv upgrade problems
« Reply #1 on: June 27, 2010, 06:27:52 pm »
All of these issues have been fixed in the latest snapshots. I would suggest reinstalling the latest.

I'm sorry about it, but basically, we moved away from avenard as our repository for MythTV and some other related packages. Due to the way avenard abused the package system (improperly skewing versions), the wrong version of mythtv gets installed. This can be corrected with a version pinning, and it has been discussed in other threads to death, you can search them if you wish to go that route.

The issue with MythTV freezing has to deal with the fact that command line options and behaviour changed from MythTV 0.22 to 0.23. The pluto-mythtv-player for 0.23 fixes this issue. All of these things have been corrected...

Basically, in the future, we will not be relying on external repositories to handle specialized versions of packages, and will do any such customization, ourselves.

-Thom


maverick0815

  • Addicted
  • *
  • Posts: 543
    • View Profile
Re: mythtv upgrade problems
« Reply #2 on: June 28, 2010, 07:01:05 am »
Your're right...I will do the latest snapshot.
thanks Thom.
perhaps I fan also convince my celle to accept the java-orbiter.